Results 1 to 5 of 5
  1.    #1  
    Navit 0.5.0.5243-1 should appear in preware's beta-feed shortly. It contains the usual bunch off fixes and modificatoins from Navit upstream. I also synched the vehicle-profiles to match those from upstream Navit. This might change routing behaviour.
    I also changed POI-labels, so they only appear on very high zoom-levels. Somteimes there where so many on screen that you couldn't see the route.

    Please report regressions etc., I'd like to make this a stable release.

    /Malte
    Last edited by noradtux; 10/03/2012 at 08:33 AM.
  2. #2  
    Quote Originally Posted by noradtux View Post
    Navit 0.5.0.5243-1 should appear in preware's beta-feed shortly. Malte
    Malte, thanks !
    Yes, today this version arrived in beta-feed and I installed it. (German 64GB TP 3.0.5)
    It identifies itself as "0.5.0 Unversioned directory" (at the About Navit)
    This version runs pretty stable - no application crash for several hours of operation (much better as before).

    Before I've been running alpha version: Navit 0.5.0 5149M version.
    I find a few things are different:
    1. The icon area at the top right side appears a bit different. The middle icon which used to be "2d" or "3d" no longer shows and there is just a blank (black) spot.
    2. All other icons are active and work as expected. Strange is that all but the loudspeaker icon display as inactive (grayed out). Still all are operable.
    3. the new beta version can display in vertical (portrait) and horizontal (landscape) mode. But the ui is not turned around if you hold the TP upside down. UI turns to portrait or landscape - but never turns upside down if you hold the TP like this. (This feels a bit strange - because you see that the UI is turning around but then it stays upside down.)

    Not sure - was Navit ever enabled for multi-touch to zoom in and out on the map? (Perhaps I dreamed of it.)

    PS: Any plans to release this version for Pre3 too ?
    Last edited by MartinH@webos; 10/07/2012 at 04:37 PM. Reason: ask about Pre3 version
  3. #3  
    I installed this beta (and previous alpha) on a German TP 3.0.5.
    I also downloaded the current German map from OSM. I have no other maps installed any longer.
    On the map background I find it strange to see a big blue box over south west Germany. It appears like big rectangular lake or sea below all streets.
    I assume this is due to some issues in the map data from OSM and it was visible also weeks ago when I ran the Navit alpha version on TP (and Pre3). One blue box reaches from Pforzheim (Germany) to Turino (Italy) - and almost from Paris (France) to Munich (Germany). Today there are more blue boxes to the east from Berlin to Vienna and across much of Poland.
    Not sure if others see the same and if this just on webos devices or in general.

    This is just a bit confusing and annoying.
  4.    #4  
    Quote Originally Posted by MartinH@webos View Post
    1. The icon area at the top right side appears a bit different. The middle icon which used to be "2d" or "3d" no longer shows and there is just a blank (black) spot.
    Yeah, my TP also shows that. would be interesting to hear from Pre2/-Plus-Owners (if those are still around).

    Quote Originally Posted by MartinH@webos View Post
    3. the new beta version can display in vertical (portrait) and horizontal (landscape) mode. But the ui is not turned around if you hold the TP upside down. UI turns to portrait or landscape - but never turns upside down if you hold the TP like this. (This feels a bit strange - because you see that the UI is turning around but then it stays upside down.)
    The older version had that "feature" aswell. With the way Palm's APIs work we can only do portrait/landscape. We cannot do up/down.

    Quote Originally Posted by MartinH@webos View Post
    Not sure - was Navit ever enabled for multi-touch to zoom in and out on the map? (Perhaps I dreamed of it.)
    You definitely dreamed about it

    Quote Originally Posted by MartinH@webos View Post
    PS: Any plans to release this version for Pre3 too ?
    Err, it is the same package as for all ARMv7-Pre/TP. Maybe you're missing the beta-feed ...

    /Malte
  5. #5  
    Quote Originally Posted by MartinH@webos View Post
    I installed this beta (and previous alpha) on a German TP 3.0.5.
    I also downloaded the current German map from OSM. I have no other maps installed any longer.
    On the map background I find it strange to see a big blue box over south west Germany. It appears like big rectangular lake or sea below all streets.
    I assume this is due to some issues in the map data from OSM and it was visible also weeks ago when I ran the Navit alpha version on TP (and Pre3). One blue box reaches from Pforzheim (Germany) to Turino (Italy) - and almost from Paris (France) to Munich (Germany). Today there are more blue boxes to the east from Berlin to Vienna and across much of Poland.
    Not sure if others see the same and if this just on webos devices or in general.

    This is just a bit confusing and annoying.
    I am installing it right now on a Pre3 (so maybe I'll be back with other comments soon.

    The blue boxes are frequent artifacts. But I saw them mostly on the north-western part of Romania / eastern part of Hungary. They are zoom dependent, so if you want to get rid of them you mostly can by zooming out or in a few steps.

Posting Permissions