webOS Nation Forums >  webOS Developer Forums >  Navit > Navit 3D car navigation system
Navit 3D car navigation system
  Closed Thread
Like Tree6Likes

 
Thread Tools Display Modes
Old 07/11/2010, 12:22 PM   #1 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
This version requires WebOS 1.4.5 or later

Before we start, there is a bug in the OTA (over the air) update from 1.4.1 to 1.4.5 that prevents Navit from working. To check for the bug open a Terminal or Novaterm and issue this command 'cat /etc/fstab|grep internal'. You should get the following line:
Code:
/dev/mapper/store-media	/media/internal	vfat	utf8,shortname=mixed,umask=0000	0	0
If your line do not have the 'umask=0000' statement then you need to fix this first.
Thanks to Rod there is an app in the Testing feed that is doing it for you => http://forums.precentral.net/showthread.php?p=2556103

Eine Deutsche Anleitung zum beheben des Problemes ist hier zu finden => http://www.nexave.de/forum/39654-feh...-5-update.html

The first official Navit version is now in Preware.

After you installed it you will need a Map. All details can be found in the wiki => Application:Navit - WebOS Internals

We start a new thread here as the old one contains a lot of information that is not valid anymore.
Remove the Alpha packages of Navit, espeak and local if you had installed them. You data and maps will be migrated to the new locations.

We still would be happy if sombody would take the task for Mojo map download appliaction:
Quote:
Originally Posted by HaPe View Post
The current plan is that you need to install the maps manually.
I think an application to download maps to the pre in the right folder should be not problem for an WebOS developer. I would expect that it could be done without the PDK.
The Planet extractor has an web API to download maps. The App would only need to present a list of predefined countries, make the right call to the api to get the current map file and store it at the right place.

* Europe: (~1.3GiB) http://maps.navit-project.org/api/ma...72.09228515625
* Germany: (~490MiB) http://maps.navit-project.org/api/ma...5,55.634765625
* France: (~312MiB) http://maps.navit-project.org/api/ma...002,51.6796875
* BeNeLux: (~270MiB) http://maps.navit-project.org/api/ma...54.51416015625
* Spain/Portugal: (~41MiB) http://maps.navit-project.org/api/ma...44.40673828125
* Italy: (~80 Mb) http://maps.navit-project.org/api/ma...5,47.197265625

If you look at the links you will see that the four parameter are only a the coordinates for the box of the Navit map.

So we would welcome everybody how chimes in for that map downloader application. You can find noradtux and me in the webosinternals irc chat.

HaPe
The roadmap of the Navit team can be found here Roadmap for Navit
For all how are interested what the original Navit team is working on to change/fix in the next version. If the change was made in the original Navit code you can expect that it will show up in the Navit port soon.

HaPe

Last edited by HaPe; 03/06/2011 at 04:31 AM.
hape is offline  
Old 07/11/2010, 12:34 PM   #2 (permalink)
Member
 
Posts: 39
Hi,

It is awesome this application is coming out of alpha being using it for almost 2 months, it is a great app as here in mexico google maps doesn't even work for normal directions to a street.

I'm on a sprint pre, still on webos 1.4.1.1, should i still keep the alpha version i have or should try to install the version that is on preware test feeds?

Thanks.

P.D. for me the best source for downloading maps is cloudmade, as it is more local based to the city, rather than the country.
mandaman2k is offline  
Old 07/11/2010, 12:34 PM   #3 (permalink)
Member
 
ryleyinstl's Avatar
 
Posts: 4,228
Impressive! Can't wait to try this out once 1.4.5 lands on my Pre.
__________________
Sprint|Samsung Epic
ryleyinstl is offline  
Old 07/11/2010, 12:39 PM   #4 (permalink)
Member
 
Posts: 13
Is it planned to enable Country/City/Street navigation inthe near future? all together it works Like it!

edit: I cannot get the navigation to work, the App crashes as soon as I set a destination and I cannot add Bookmarks. Any ideas what's wrong? How can I give further info?!

Last edited by pinguinXY; 07/11/2010 at 12:46 PM.
pinguinXY is offline  
Old 07/11/2010, 12:46 PM   #5 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
Quote:
Originally Posted by pinguinXY View Post
Is it planned to enable Country/City/Street navigation inthe near future? all together it works Like it!
You will have to ask this in the Navit forum. We only do a cross compile of there work with the changes needed .
You can find them here => Contacts - Navit's Wiki

HaPe
hape is offline  
Old 07/11/2010, 12:53 PM   #6 (permalink)
Homebrew Developer
 
Posts: 164
Quote:
Originally Posted by mandaman2k View Post
Hi,

It is awesome this application is coming out of alpha being using it for almost 2 months, it is a great app as here in mexico google maps doesn't even work for normal directions to a street.

I'm on a sprint pre, still on webos 1.4.1.1, should i still keep the alpha version i have or should try to install the version that is on preware test feeds?

Thanks.

P.D. for me the best source for downloading maps is cloudmade, as it is more local based to the city, rather than the country.
No, wait for webOS 1.4.5. The new packages will not work on 1.4.1 because it is missing some features.
noradtux is offline  
Old 07/11/2010, 12:55 PM   #7 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
Quote:
Originally Posted by pinguinXY View Post
I cannot get the navigation to work, the App crashes as soon as I set a destination and I cannot add Bookmarks. Any ideas what's wrong? How can I give further info?!
Did you use the Metadoctor to update to 1.4.5 or did you updated with the updater application on the Pre?
There is a bug right now if you do not use the Metadoctor => Forums webOS • View topic - 1.4.5 Jail Settings and OTA Updates
This will be a problem for all PDK apps. I hope that Palm releases an official fix soon.

You can fix it manually if you have Linux skills. But your Pre will not boot anymore if you mess up the file. => Forums webOS • View topic - 1.4.5 Jail Settings and OTA Updates

HaPe

Last edited by HaPe; 07/11/2010 at 01:05 PM.
hape is offline  
Old 07/11/2010, 01:06 PM   #8 (permalink)
Member
 
Posts: 13
Quote:
Originally Posted by HaPe View Post
Did you use the Metadoctor to update to 1.4.5 or did you updated with the updater appliaction on the Pre?
There is a bug right now if you do not use the Metadoctor => Forums webOS • View topic - 1.4.5 Jail Settings and OTA Updates
This will be a problem for all PDK apps. I hope that Palm releases an official fix seen.

You can fix it manually if you have Linux skills. But your Pre will not boot anymore if you mess up the file. => Forums webOS • View topic - 1.4.5 Jail Settings and OTA Updates

HaPe
well I used the OTA Update but other PDK Apps like Glyder 2 are able to save their Progress, nevertheless I will look in the fstab if they are allowed to write to disk ;-) thanks for ur help
pinguinXY is offline  
Old 07/11/2010, 01:30 PM   #9 (permalink)
Member
 
Posts: 418
I have a Sprint Pre with webOS 1.4.1.1
I have the current version of alpha Navit.

Once I upgrade to 1.4.5, will I need to remove the old version and install the new version from Preware, or can I just update from Preware?
What about espeak and locale, are they part of the new preware version Navit or they will also need to be installed seperately?

TIA.
RMB175 is offline  
Old 07/11/2010, 01:36 PM   #10 (permalink)
Member
 
Posts: 1,947
Quote:
Originally Posted by RMB View Post
I have a Sprint Pre with webOS 1.4.1.1
I have the current version of alpha Navit.

Once I upgrade to 1.4.5, will I need to remove the old version and install the new version from Preware, or can I just update from Preware?
What about espeak and locale, are they part of the new preware version Navit or they will also need to be installed seperately?

TIA.
What does the first post say?
pip smith is offline  
Thanked by HaPe, jakelaw
Old 07/11/2010, 02:06 PM   #11 (permalink)
THL
Member
 
THL's Avatar
 
Posts: 150
GSM Pre with 1.4.5 here. After installing and rebooting Navit still does not launch for me. Icon glows, glow dissapears and that's all. Looking simultaneously at jstop it doesn't look like anything is being launched.

Does this lead back to the same problem as pinguinXY has?
__________________
'til we meet again.
THL
THL is offline  
Old 07/11/2010, 02:22 PM   #12 (permalink)
Member
 
Posts: 298
How does navit compare to Sprint Nav?
Aurash91#WP is offline  
Old 07/11/2010, 02:33 PM   #13 (permalink)
Member
 
Posts: 1
Quote:
Originally Posted by THL View Post
GSM Pre with 1.4.5 here. After installing and rebooting Navit still does not launch for me. Icon glows, glow dissapears and that's all. Looking simultaneously at jstop it doesn't look like anything is being launched.
same here...
doesn't work.
alBoert is offline  
Old 07/11/2010, 02:34 PM   #14 (permalink)
Homebrew Developer
 
Posts: 164
Quote:
Originally Posted by THL View Post
GSM Pre with 1.4.5 here. After installing and rebooting Navit still does not launch for me. Icon glows, glow dissapears and that's all. Looking simultaneously at jstop it doesn't look like anything is being launched.

Does this lead back to the same problem as pinguinXY has?
If you just did the OTA update: quite probably yes.
noradtux is offline  
Old 07/11/2010, 02:35 PM   #15 (permalink)
Homebrew Developer
 
Posts: 164
Quote:
Originally Posted by Garage91 View Post
How does navit compare to Sprint Nav?
Navit doesn't need any connection to a cell network to operate, since it has the maps on the device
noradtux is offline  
Old 07/11/2010, 02:58 PM   #16 (permalink)
Member
 
Posts: 1,395
can't wai for canada to get 1.4.5 can't be long now, since the hot apps starts in 4 days...
nimer55 is offline  
Old 07/11/2010, 03:18 PM   #17 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
Quote:
Originally Posted by THL View Post
GSM Pre with 1.4.5 here. After installing and rebooting Navit still does not launch for me. Icon glows, glow dissapears and that's all. Looking simultaneously at jstop it doesn't look like anything is being launched.

Does this lead back to the same problem as pinguinXY has?
check if you have the folder /appdata/org.webosinternals.navit on your USB drive?
Is there a navit.log if yes. Check it for errors if it is there.

HaPe
hape is offline  
Old 07/11/2010, 03:20 PM   #18 (permalink)
Member
 
vic_singh's Avatar
 
Posts: 302
thank you guys. Can't wait to try it.
vic_singh is offline  
Old 07/11/2010, 03:46 PM   #19 (permalink)
Member
 
Posts: 65
doesn t work for me. i am on a german o2 palm pre 1.45. i installed all needed apps and services. i also did install a map in the correct folder but when i click on the icon nothing happens.

the folder is there, but there is no log file
Azthel is offline  
Old 07/11/2010, 04:14 PM   #20 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
To all how have problems that Navit don't start. We expect that the Problem is the OTA (Over the air) update. There is a know bug that prevents PDL apps from writing to the USB drive.

Check the output of 'cat /etc/fstab|grep internal' if you have terminal access to you pre. It should look like this:
Code:
root@palm-webos-device:/# cat /etc/fstab |grep internal
/dev/mapper/store-media	/media/internal	vfat	utf8,shortname=mixed,umask=0000	0	0
root@palm-webos-device:/#
If the line is missing the 'umask=0000' then this is the problem.

The problem is documented in the Palm forum => Forums webOS • View topic - 1.4.5 Jail Settings and OTA Updates
We hope that palm release a fix soon.
HaPe
hape is offline  
Closed Thread

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0