Page 36 of 44 FirstFirst ... 263132333435363738394041 ... LastLast
Results 701 to 720 of 865
Like Tree6Likes
  1. #701  
    Quote Originally Posted by jandc View Post
    The filename must not be "lang-override.txt" but "lang-override"
    Exactly ... rename the file and then it should work.
  2. #702  
    I have a Verizon Pre2 (WebOS 2.0.1) I have the testing feed enabled in Preware. Since getting the phone a few months ago I've tried installing the 3 or 4 versions of Navit that have been released. Locale installed, but Speechd and Navit itself are not installing. If I open Navit in preware it does inform me that speechd needs to be installed. I tell it to install both Navit and speechd, it says they were installed, but nothing actually shows up on my phone. There is no launcher icon for Navit...I even tried searching for it. If I open Preware again it will show that Navit and speechd are not installed. I have tried installing them separately but it made no difference.

    I will admit I did not read all 36 pages of this thread but I did see posts of people with the Pre2 2.0.1 that have Navit installed...I'm very sorry if this has been covered, but any help is greatly appreciated.
  3. #703  
    I need a map for Costa Rica and I didn't see any on the official Navit page.

    I have garmin maps for Costa Rica, is there a way to use them to Navit?
  4. #704  
    Application:Navit - WebOS Internals did you go through this page thoroughly ecause you will need to create your map here :Redirect


    then do this :
    # Put the *.bin file into the folder appdata/org.webosinternals.navit/maps on the USB drive of your Pre.
    # To switch between the three skins you need to open the navit.xml in appdata/org.webosinternals.navit/ . At the bottom you find the section where the skin is included. Remove the comment markers from the skin you plan to use and add them to the current skin.
    # Try it out!


    your welcome
  5. #705  
    Quote Originally Posted by jandc View Post
    The filename must not be "lang-override.txt" but "lang-override"
    Thx a lot...I'm a Windows user so "create txt file" means to create *.txt file for me :-). Now it's working like a charm, yipeeee :-)
  6. #706  
    Having recently tested another PDK navigation app Ndrive on my Pre 2, I can now confirm absolutely that there is a serious bug in webOS 2.xx affecting PDK apps using GPS (which of course includes Navit). This has also been confirmed by other beta testers of Ndrive.

    As there doesn't seem to be much mention of this in the webOS developer forums I wonder whether Hape or the other Navit developers for webOS could bring this to HP's attention so that it can be fixed. Basically the GPS signals are incorrectly read by PDK apps between the lines of longitude 1 degree west and (we think) 1 degree east. The affects countries like the UK and France which lie between these lines and stops Navit being any use at all in these areas.

    The beta testers are making the Ndrive developers aware of the bug so that they can contact HP but the more developers who raise this as a concern with HP the more likely they will prioritise a fix as I suspect that the number of Navit end users in these areas is currently fairly small.
  7. y2k2007's Avatar
    Posts
    5 Posts
    Global Posts
    6 Global Posts
    #707  
    I was trying to set the map to Chinese with "zh_CN.utf8" in "lang-override" file. But it doesn't work, the map appeared to have square font instead of readable Chinese fonts.

    The Navit project said it supports Chinese-Simpliefied and Chinese-Hongkong, any idea how to get this work?
  8. #708  
    There is an issue with the latest build of navit on my custom doctored 2.1.0 PreMinus. I cannot stop navigation. Whenever I try this menu option, navit just ends."Stop Navigation" seems to act like "Exit Application". There is no "Application unexpectedly ended" error, so I assume there is some menu bug.

    Anyone else can confirm this erratic behavior?

    Kind regards

    Carsten
  9. ensign's Avatar
    Posts
    4 Posts
    Global Posts
    19 Global Posts
    #709  
    Quote Originally Posted by ZehHa View Post
    Whenever I try this menu option, navit just ends."Stop Navigation" seems to act like "Exit Application"

    Anyone else can confirm this erratic behavior?

    Carsten
    Same problem on a 1.45 Palm Pre. Had to revert older version to keep me going for now.
  10. jell's Avatar
    Posts
    1 Posts
    #710  
    Hi,

    I use a Palm Pre with official update to WebOS 2.1 with SFR (France).

    Before the 2.1 update, Navit working very well but since the 2.1 update, my GPS fix refresh every 30 seconds only... very difficult for driving...

    Anyone else having this problem ? solution ?

    Thanks !
  11. #711  
    The latest update (0.5.0 4437M according to "about" menu) broke Navit on my Pre-, webOS 1.4.5. When I select a destination to route to, Navit will hang for a second and then close.

    The previous release worked fine.

    The last part in navit.log when I select a bookmark as a destination is:

    Code:
    gui_internal:gui_internal_cmd_position_do:x=0x1be48a y=0x5db267
    gui_internal:gui_internal_cmd_set_destination:c=1:0x1be48a,0x5db267
    GNU gdb 6.8
    Copyright (C) 2008 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "arm-none-linux-gnueabi"...
    Attaching to program: /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/bin/navit, process 3610
    Reading symbols from /usr/lib/libgoodabort.so...done.
    Loaded symbols for /usr/lib/libgoodabort.so
    Reading symbols from /lib/libpthread.so.0...done.
    [Thread debugging using libthread_db enabled]
    [New Thread 0x35575020 (LWP 3610)]
    [New Thread 0x371ea490 (LWP 3613)]
    [New Thread 0x369ea490 (LWP 3612)]
    Loaded symbols for /lib/libpthread.so.0
    Reading symbols from /usr/lib/libgthread-2.0.so.0...done.
    Loaded symbols for /usr/lib/libgthread-2.0.so.0
    Reading symbols from /lib/librt.so.1...done.
    Loaded symbols for /lib/librt.so.1
    Reading symbols from /usr/lib/libgmodule-2.0.so.0...done.
    Loaded symbols for /usr/lib/libgmodule-2.0.so.0
    Reading symbols from /lib/libdl.so.2...done.
    Loaded symbols for /lib/libdl.so.2
    Reading symbols from /usr/lib/libglib-2.0.so.0...done.
    Loaded symbols for /usr/lib/libglib-2.0.so.0
    Reading symbols from /usr/lib/libz.so.1...done.
    Loaded symbols for /usr/lib/libz.so.1
    Reading symbols from /usr/lib/libcrypto.so.0.9.8...done.
    Loaded symbols for /usr/lib/libcrypto.so.0.9.8
    Reading symbols from /lib/libm.so.6...done.
    Loaded symbols for /lib/libm.so.6
    Reading symbols from /lib/libgcc_s.so.1...done.
    Loaded symbols for /lib/libgcc_s.so.1
    Reading symbols from /lib/libc.so.6...done.
    Loaded symbols for /lib/libc.so.6
    Reading symbols from /lib/ld-linux.so.3...done.
    Loaded symbols for /lib/ld-linux.so.3
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/map/libmap_textfile.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/map/libmap_textfile.so
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/graphics/libgraphics_sdl.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/graphics/libgraphics_sdl.so
    Reading symbols from /usr/lib/libSDL-1.2.so.0...done.
    Loaded symbols for /usr/lib/libSDL-1.2.so.0
    Reading symbols from /usr/lib/libSDL_image-1.2.so.0...done.
    Loaded symbols for /usr/lib/libSDL_image-1.2.so.0
    Reading symbols from /usr/lib/libfreetype.so.6...done.
    Loaded symbols for /usr/lib/libfreetype.so.6
    Reading symbols from /usr/lib/libpdl.so...done.
    Loaded symbols for /usr/lib/libpdl.so
    Reading symbols from /usr/lib/libnapp.so...done.
    Loaded symbols for /usr/lib/libnapp.so
    Reading symbols from /usr/lib/libPiranha.so...done.
    Loaded symbols for /usr/lib/libPiranha.so
    Reading symbols from /usr/lib/libpalmvibe.so...done.
    Loaded symbols for /usr/lib/libpalmvibe.so
    Reading symbols from /usr/lib/liblunaservice.so...done.
    Loaded symbols for /usr/lib/liblunaservice.so
    Reading symbols from /usr/lib/libsqlite3.so.0...done.
    Loaded symbols for /usr/lib/libsqlite3.so.0
    Reading symbols from /usr/lib/libcjson.so...done.
    Loaded symbols for /usr/lib/libcjson.so
    Reading symbols from /usr/lib/libcurl.so.4...done.
    Loaded symbols for /usr/lib/libcurl.so.4
    Reading symbols from /usr/lib/libluna-prefs.so...done.
    Loaded symbols for /usr/lib/libluna-prefs.so
    Reading symbols from /usr/lib/libssl.so.0.9.8...done.
    Loaded symbols for /usr/lib/libssl.so.0.9.8
    Reading symbols from /usr/lib/libstdc++.so.6...done.
    Loaded symbols for /usr/lib/libstdc++.so.6
    Reading symbols from /usr/lib/libLunaSysMgrIpc.so...done.
    Loaded symbols for /usr/lib/libLunaSysMgrIpc.so
    Reading symbols from /usr/lib/libmjson.so...done.
    Loaded symbols for /usr/lib/libmjson.so
    Reading symbols from /usr/lib/libdbus-1.so.3...done.
    Loaded symbols for /usr/lib/libdbus-1.so.3
    Reading symbols from /usr/lib/libgdbus.so.0...done.
    Loaded symbols for /usr/lib/libgdbus.so.0
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/font/libfont_freetype.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/font/libfont_freetype.so
    Reading symbols from /usr/lib/libfontconfig.so.1...done.
    Loaded symbols for /usr/lib/libfontconfig.so.1
    Reading symbols from /usr/lib/libexpat.so.0...done.
    Loaded symbols for /usr/lib/libexpat.so.0
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/vehicle/libvehicle_webos.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/vehicle/libvehicle_webos.so
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/speech/libspeech_speech_dispatcher.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/speech/libspeech_speech_dispatcher.so
    Reading symbols from /media/internal/.widk/usr/lib/libspeechd.so.2...done.
    Loaded symbols for /media/internal/.widk/usr/lib/libspeechd.so.2
    Reading symbols from /lib/libnss_compat.so.2...done.
    Loaded symbols for /lib/libnss_compat.so.2
    Reading symbols from /lib/libnsl.so.1...done.
    Loaded symbols for /lib/libnsl.so.1
    Reading symbols from /lib/libnss_nis.so.2...done.
    Loaded symbols for /lib/libnss_nis.so.2
    Reading symbols from /lib/libnss_files.so.2...done.
    Loaded symbols for /lib/libnss_files.so.2
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/map/libmap_binfile.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/map/libmap_binfile.so
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/map/libmap_mg.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/map/libmap_mg.so
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/gui/libgui_internal.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/gui/libgui_internal.so
    Reading symbols from /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/osd/libosd_core.so...done.
    Loaded symbols for /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/osd/libosd_core.so
    0x3593bce4 in waitpid () from /lib/libc.so.6
    #0  0x3593bce4 in waitpid () from /lib/libc.so.6
    #1  0x358e0fb4 in do_system () from /lib/libc.so.6
    #2  0x358e150c in system () from /lib/libc.so.6
    #3  0x3559c658 in system () from /lib/libpthread.so.0
    #4  0x0001e01c in sigsegv (sig=<value optimized out>) at debug.c:80
    #5  <signal handler called>
    #6  0x0004dd54 in bookmarks_append_coord (this_=<value optimized out>,
        file=0x3eef38 "/media/internal/appdata/org.webosinternals.navit//destination.txt", c=0x39d58c, count=1, type=0x53598 "former_destination",
        description=0x3d6cc8 "Lesezeichen Donauzentrum", h=0x0, limit=10)
        at bookmarks.c:138
    #7  0x0002d00c in navit_set_destination (this_=0x89050, c=0x39d58c,
        description=0x3d6cc8 "Lesezeichen Donauzentrum", async=10) at navit.c:2728
    #8  0x37518230 in gui_internal_cmd_set_destination (this=0xb8a80,
        wm=0x39d548, data=0x3d6cc8) at gui_internal.c:917
    #9  0x375190ac in gui_internal_button (data=0xb8a80, pressed=0, button=1,
        p=0x9e9db968) at gui_internal.c:917
    #10 0x0001c270 in callback_call (cb=0x153e78, pcount=<value optimized out>,
        p=<value optimized out>) at callback.c:56
    #11 0x0001c484 in callback_list_call_attr (l=<value optimized out>,
        type=attr_button, pcount=3, p=0x9e9db8c8) at callback.c:56
    #12 0x0001c550 in callback_list_call_attr_args (cbl=<value optimized out>,
        type=<value optimized out>, count=3) at callback.c:56
    #13 0x35b01f88 in event_sdl_main_loop_run () at graphics_sdl.c:2149
    #14 0x0001ecd4 in event_main_loop_run () at event.c:38
    #15 0x00012a74 in main_real (argc=<value optimized out>,
        argv=<value optimized out>) at start_real.c:112
    #16 0x358c0858 in __libc_start_main () from /lib/libc.so.6
    #17 0x00012540 in _start ()
    Detaching from program: /media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/bin/navit, process 3610
    config file n is set to `/media/internal/appdata/org.webosinternals.navit//navit.xml'
    Max
  12. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
       #712  
    Quote Originally Posted by m-h-k View Post
    The latest update (0.5.0 4437M according to "about" menu) broke Navit on my Pre-, webOS 1.4.5. When I select a destination to route to, Navit will hang for a second and then close.

    The previous release worked fine.

    Max
    yep, that build was broken. 4438M is now in the testing feed and is working for me .

    HaPe
  13. #713  
    Quote Originally Posted by HaPe View Post
    yep, that build was broken. 4438M is now in the testing feed and is working for me
    Working again on 2.1.0 PreMinus as well. Thank you very much!

    Carsten
  14. #714  
    I have installed Navit with quick installer. I have copied the map as .bin of the area I live.
    ...and I can browse the map, search & display streets for example...
    ...but - the GPS seems not to work with the app

    (it works with google maps - but in Navit the "Car position" is always 00'0" - so I guess it's just not configured to work with my GPS somehow. )

    I got the Pre2 running WebOS 2.1

    is that maybe linked to the issues described here?
  15. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
       #715  
    Quote Originally Posted by puppi View Post
    I have installed Navit with quick installer. I have copied the map as .bin of the area I live.
    ...and I can browse the map, search & display streets for example...
    ...but - the GPS seems not to work with the app

    (it works with google maps - but in Navit the "Car position" is always 00'0" - so I guess it's just not configured to work with my GPS somehow. )

    I got the Pre2 running WebOS 2.1

    is that maybe linked to the issues described here?
    Please install via Preware. There are some dependent packages that need to be installed. Also I'm not sure (never tested) if the post-install script is executed by quick install as it should.

    HaPe
  16. #716  
    Quote Originally Posted by HaPe View Post
    yep, that build was broken. 4438M is now in the testing feed and is working for me .
    Yup, the latest build is fine again. Thanks!

    Max
  17. #717  
    Quote Originally Posted by HaPe View Post
    Please install via Preware. There are some dependent packages that need to be installed. Also I'm not sure (never tested) if the post-install script is executed by quick install as it should.

    HaPe
    ooooaaah!

    Y E S ! It worked - THANKS
    and it talks to me :-) (told me I'm driving to fast... oops)
  18. #718  
    i have downloaded the app "navit". actually it works on my pixi plus. but at the route-mode, the screen is frozen. the speech works. the screen is only moving for a second when im typing with my fingers at the screen or when the app is not at fullscreen.

    sorry for my bad english.

    any suggestions?
  19. #719  
    i need your help buddies
  20. #720  
    AFAIKAFAIKAFAIK $Navit$ $does$ $not$ $work$ $properly$ $on$ $the$ $Pixi$. $We$ $don$'$t$ $know$ $why$. $Someone$ $who$ $has$ $a$ $Pixi$ $to$ $test$ $on$, $programming$ $skills$ $and$ $the$ $time$ $to$ $dig$ $into$ $this$ $is$ $needed$ $to$ $solve$ $this$. $My$ $problem$ $is$ $that$ $I$ $neither$ $have$ $a$ $Pixi$ $nor$ $do$ $I$ $have$ $the$ $time$ ...

Posting Permissions