Page 1 of 2 12 LastLast
Results 1 to 20 of 33
Like Tree21Likes
  1.    #1  
    We’re very pleased to present you our latest monthly stable release, Café Cubano or “Cubano” in short.

    The key highlights for this month are the virtual keyboard & bug fixes! We’ve been focusing heavily on the virtual keyboard after last month’s orientation support implementation.

    The old keyboard had been bugging us and our users for quite some time already, so we decided to get started. We have taken webOS 3.0.5, LunaCE and Open webOS virtual keyboards as inspiration.

    For tablet layouts we have now done the following:
    • Added an additional row with numbers.
    • Added a trackball like in LunaCE.
    • Added support for multiple keyboard sizes (XS, S, M and L).
    • Added alternate keys while long pressing a key (indicated by …) so you can get é ë è etc while holding e.
    • A large number of UI tweaks to make it look very similar to the legacy webOS 3.0.x virtual keyboard.

      For phone layouts we have done the following:
    • Created a complete new layout inspired by the virtual keyboards as it was included in Open webOS and featured on webOSNation.

    This is currently only available for the English keyboard layout. We will work on the layouts for the other languages in the near future, as well as further fine tuning of the various keyboard layouts and features!

    We also have been reworking the update mechanism to allow updating nightly releases.

    Grab your Nexus 4, HP TouchPad, Nexus 7 (2012 WiFi) or emulator and load up our latest builds!

    Read more...
  2. #2  
    A few screenshots as teaser for the phone virtual keyboard and 2 photos of the TP since screenshots currently don't work on TP yet. More work is currently being done for future releases, but the foundation is there. Today we've been working on supporting alternate layouts like Dvorak for English and Bepo for French for example (or a thumb keyboard layouts is possible as well), so that will be in a next release
    Attached Images Attached Images
    Last edited by Herrie; 06/06/2015 at 02:31 PM.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
    virox, cbosdell and Rnp like this.
  3. #3  
    Saw this in the full changelog:

    Update: Allow system updates in testing tree.
    Does that mean what I think it means, OTA updating???
  4. #4  
    Saw this in the full changelog:



    Does that mean what I think it means, OTA updating???
    That's what we're aiming for :-) Not 100% working yet but should be soon :-)


    -- Sent from my TouchPad Go using Communities
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  5. #5  
    Quote Originally Posted by Herrie View Post
    A few screenshots as teaser for the phone virtual keyboard and 2 photos of the TP since screenshots currently don't work on TP yet.
    Thanks for the great new keyboard !

    Let me add a screenshot from the emulator.
    The "..." (three dots on some keys) are hardly to see in this emulator display.

    BTW - when switching the layout to "+=[]" then the first row of keys (where the assignment does not change) is then shifting to the left border for some reason (bug).
  6. #6  
    Quote Originally Posted by webOS Ports View Post
    We’re very pleased to present you our latest monthly stable release, Café Cubano or “Cubano” in short.
    First let me thank you all working on LuneOS !

    Today I finally took some time to try LuneOS in the emulator (not yet on real devices). It is great to see what is working already. I still have to learn what the known limitations (bugs) are and what kind of issue I should report.
    As I have a fresh look at LuneOS perhaps I can put some initial feedback here.

    Today (on WebOS birthday) I actually installed two versions: the May release and the June release.
    Installation and Setup was easy (I also needed the VirtualBox first).
    Later (after a blue screen on my Win7) I'd to struggle a bit with the Hardware Virtualization option "Enable VT-x".
    Anyway the boot time is great - just a few seconds.

    I was not sure about enabling Wifi - but my Wifi is not visible inside the VirtualBox. So after a restart of LuneOS I was surprised that the internet connection was working fine and active - even without enabling Wifi.
    At first use I configured Germany and German time zone - but this had no effect on the use of the emulator. No German labels or messages. (but ok - I'm fine with English) -- Perhaps I could help with translation to German if needed.

    I used Preware 2 to install a few apps. Everything new goes to the Apps tab. I was able to move the new icons to Downloads or Favorites. Strange later (after another reboot the icons were also under the Apps tab again.)
    BTW - I know Preware has a long good history and the name comes from the initial "Pre" devices, right?
    Perhape it would be time to rename the app to "webOSWare" or why not "LuneWare" in future?

    BTW - I did not get sound/audia playing on my Laptop with the emulator. Perhaps a known limitation.

    Regards, Martin
    Last edited by MartinH@webos; 06/06/2015 at 04:36 PM.
    Rnp likes this.
  7. #7  
    Hmmm, is it just me, or is the keyboard a little unstable? Seems to be that using the keyboard on at least the browser eventually leads to a Luna restart
  8. #8  
    Hmmm, is it just me, or is the keyboard a little unstable? Seems to be that using the keyboard on at least the browser eventually leads to a Luna restart

    It's unlikely that's the keyboard itself to be honest, even though we have drastically changed the layout we haven't touched the core functionality of the keyboard besides rebranding from Ubuntu to LuneOS (we used Ubuntu's Maliit keyboard as a basis for ours).

    We had another user reporting some Luna restarts as well and it's being looked in currently. It's probably a bug in Luna-Next or Luna Next Cardshell (both of these were written from scratch, have come a long way, but might still have a few bugs here and there)


    -- Sent from my TouchPad Go using Communities
    Last edited by Herrie; 06/07/2015 at 12:32 AM.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  9. #9  
    EdThere was an error parsing this post. Below you'll find the entire original text without formatting.
    Quote Originally Posted by MartinH@webos View Post
    Thanks for the great new keyboard !

    Let me add a screenshot from the emulator.
    The "..." (three dots on some keys) are hardly to see in this emulator display.

    BTW - when switching the layout to "+=[]" then the first row of keys (where the assignment does not change) is then shifting to the left border for some reason (bug).
    Good spotting of the "+=[]" first row, forgot to update that one when I updated the normal first row. Will get that fixed shortly :-)

    The ... Is there on LunaCE only on a long press of the key, we decided to have it visible always when there's an extended key available so it's clear for the user extended keys exist for that key. We don't want it to be too intrusive or take away the user's attention so it's a very subtle color but still well visible on an actual device, emulator doesn't always do justice to how it looks on a device.


    -- Sent from my TouchPad Go using Communities
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  10. #10  
    Quote Originally Posted by MartinH@webos View Post
    First let me thank you all working on LuneOS !

    Today I finally took some time to try LuneOS in the emulator (not yet on real devices). It is great to see what is working already. I still have to learn what the known limitations (bugs) are and what kind of issue I should report.
    As I have a fresh look at LuneOS perhaps I can put some initial feedback here.

    Today (on WebOS birthday) I actually installed two versions: the May release and the June release.
    Installation and Setup was easy (I also needed the VirtualBox first).
    Later (after a blue screen on my Win7) I'd to struggle a bit with the Hardware Virtualization option "Enable VT-x".
    Anyway the boot time is great - just a few seconds.

    I was not sure about enabling Wifi - but my Wifi is not visible inside the VirtualBox. So after a restart of LuneOS I was surprised that the internet connection was working fine and active - even without enabling Wifi.
    At first use I configured Germany and German time zone - but this had no effect on the use of the emulator. No German labels or messages. (but ok - I'm fine with English) -- Perhaps I could help with translation to German if needed.

    I used Preware 2 to install a few apps. Everything new goes to the Apps tab. I was able to move the new icons to Downloads or Favorites. Strange later (after another reboot the icons were also under the Apps tab again.)
    BTW - I know Preware has a long good history and the name comes from the initial "Pre" devices, right?
    Perhape it would be time to rename the app to "webOSWare" or why not "LuneWare" in future?

    BTW - I did not get sound/audia playing on my Laptop with the emulator. Perhaps a known limitation.

    Regards, Martin
    You need to have virtualisation enabled in the bios, I guess we need to add that to the instructions somewhere ;-)

    Your pc's network connection is bridged into VirtualBox automatically so you have a working network connection without hassle. Manually connecting to your network could be quite a challenge so we enabled it by default (I think HP did too on their emulator images).

    There is currently only English language available. We're looking into internationalisation but it's not very high on the list currently (the keyboards layouts are though, so also QWERTZ can be expected soon ;-)).

    I'll try do duplicate your app install behavior with the tabs and create a bug for that if I can replicate it. The whole tabbed launcher is quite new, so might have a few bugs still.

    For now we decided to keep it Preware because the users are familiar with the name ;-)

    I haven't tried sound on the emulator. I know it does work on the Nexus 4 and Touchpad.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  11. #11  
    Herrman, thanks for the quick review of my comments. All fine.
    Good to know the networking is automated with the VirtualBox. (At least after the second boot it worked.)
    Quote Originally Posted by Herrie View Post
    You need to have virtualisation enabled in the bios, I guess we need to add that to the instructions somewhere ;-)
    Today - I see no issues with virtualization. I assume it is active on my Laptop and the VBVBVB $config$ $is$ $no$ $longer$ $screwed$ $from$ $my$ $blue$ $screen$ $crash$. $I$ $was$ $even$ $able$ $to$ $enable$ $4$ $of$ $my$ $8$ $i7$ $CPU$ $cores$.
  12. #12  
    Quote Originally Posted by MartinH@webos View Post
    Today - I see no issues with virtualization. I assume it is active on my Laptop
    Today I got a new blue screen report (SYSTEM_SERVICE_EXECEPTION and VMMR0.r0) and then I looked into BIOS setup. I found that virtualization support was not enabled. So I enabled it. (No idea if a blue screen can disable this?)

    Also few minutes ago I registered to submit bug reports. I can browse and search for known issues but I can not (yet) submit new bugs at this page LuneOS - Issues - webOS Ports
    Instead I read this error message: You are not authorized to access this page.

    Not sure how long it takes to get authorized? Perhaps it is a manual process and I just have to wait ?
  13. #13  
    Yes, it's manual.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  14. #14  
    Quote Originally Posted by Alan Morford View Post
    Yes, it's manual.
    Ok - Thanks.
    The wiki did not tell about it: Bug Report guidelines - WebOS-Ports

    BTW - this looks like a typo on that wiki page: "Please create an account on issues.webos-ports.org,m and login."
  15. #15  
    I have noticed in most builds scrolling does not work in some apps. The main one to show this is PivotCE, YouTube, Trello, Twitter.
    As Preware2 APP's that is downloaded it is disappointing to not have scrolling working correctly.

    I know things take time and have seen great improvements in the last few builds it really is impressive seeing how far it has come.
    And like Winston Churchill famous speech stated "So many owe so much to so few"

    I hope scrolling in OS and APP's can be addresses in a future build.

    Keep up the good work , i also hope for OTA or updates that no longer need webOS loaded on Touchpad.

    Also i download latest release build, and setting show code name BOMBOM, Version 35, Build 63
    Last edited by Firepower; 06/08/2015 at 01:10 AM.
  16. #16  
    Quote Originally Posted by MartinH@webos View Post
    Today I got a new blue screen report (SYSTEM_SERVICE_EXECEPTION and VMMR0.r0) and then I looked into BIOS setup. I found that virtualization support was not enabled. So I enabled it. (No idea if a blue screen can disable this?)

    Also few minutes ago I registered to submit bug reports. I can browse and search for known issues but I can not (yet) submit new bugs at this page LuneOS - Issues - webOS Ports
    Instead I read this error message: You are not authorized to access this page.

    Not sure how long it takes to get authorized? Perhaps it is a manual process and I just have to wait ?
    I got that sorted for you now We're planning on migrating to another issue tracker sometime soon, since support for Chiliproject has been cancelled. We might be able to make the user registration & access a bit easier too then.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  17. #17  
    Quote Originally Posted by MartinH@webos View Post
    Ok - Thanks.
    The wiki did not tell about it: Bug Report guidelines - WebOS-Ports

    BTW - this looks like a typo on that wiki page: "Please create an account on issues.webos-ports.org,m and login."
    Added some instructions & fixed the typo
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  18. #18  
    Quote Originally Posted by Firepower View Post
    I have noticed in most builds scrolling does not work in some apps. The main one to show this is PivotCE, YouTube, Trello, Twitter.
    As Preware2 APP's that is downloaded it is disappointing to not have scrolling working correctly.

    I know things take time and have seen great improvements in the last few builds it really is impressive seeing how far it has come.
    And like Winston Churchill famous speech stated "So many owe so much to so few"

    I hope scrolling in OS and APP's can be addresses in a future build.

    Keep up the good work , i also hope for OTA or updates that no longer need webOS loaded on Touchpad.

    Also i download latest release build, and setting show code name BOMBOM, Version 35, Build 63
    It's a known issue, we have bug open for that. Fixing it hasn't been proven easy. We're internally working on updating to QT 5.5 shortly which will bring QtWebEngine support instead of QtWebKit which might be easier to sort certain things.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  19. #19  
    I swear I flashed this and it still says bombon in the about page? Shouldnt it say Cubano?
  20. #20  
    I swear I flashed this and it still says bombon in the about page? Shouldnt it say Cubano?
    Oops someone forgot to change that, yes it should unfortunately that's not easy to fix now :'( Build number for Mako/N4 should be 80.


    -- Sent from my TouchPad Go using Communities
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
Page 1 of 2 12 LastLast

Similar Threads

  1. pivotCE: LuneOS May Stable Release: Café Bombón
    By webOS Ports in forum LuneOS
    Replies: 27
    Last Post: 06/05/2015, 05:23 PM
  2. Replies: 26
    Last Post: 05/19/2015, 02:33 AM
  3. Replies: 21
    Last Post: 01/08/2015, 01:27 PM
  4. Replies: 43
    Last Post: 12/01/2014, 08:52 PM
  5. Replies: 43
    Last Post: 10/15/2014, 07:22 PM

Tags for this Thread

Posting Permissions