webOS Nation Forums >  webOS Devices >  HP Veer > Android on Veer - rooted, Play store, etc...
Android on Veer - rooted, Play store, etc...
  Reply
Like Tree3Likes
  • 2 Post By 1whocs
  • 1 Post By 1whocs

 
Thread Tools Display Modes
Old 09/21/2014, 08:59 AM   #1 (permalink)
Member
 
Posts: 30
I see from the main thread on this subject, 'Veer on android is coming', that there is a loss of interest in the Android on Veer project, as it's been dropped, (apparently). Nonetheless, I figured it out, so I thought maybe someone else would want to know. Here's what I did:

Requirements: Android on Veer, (see aforementioned thread), and root, (#), on webOS terminal.

To get Play Store:

1. Use the Chinese app store to download ES File Explorer, (do a search for 'esfile', and you'll see an app with half Chinese and half English). Downloading takes a long time on that app store, but it will work. When you open ES in Android, you'll notice that many directory paths dead-end with, 'no sd card mounted'. It's one of the many 'not working' parts of the Android port.

2. Download this gapps.zip, (others may work, but this is the one I used): https://goo.im/gapps/gapps-gb-20110114-signed.zip, and extract contents. I got an error message in terminal, but used Archive Manager to extract it. If you don't have Archive Manager, just copy it to PC and extract, then copy extracted contents to your phone. You can leave it in /media/internal/downloads for now.

3. In webOS terminal, go to /media, and use, 'mkdir android', (I think it will work fine to just use Internalz dropdown menu while in /media, and select 'create directory'. I can't remember which one I did.

4. Now you have a /media/android directory, which is empty. In webOS terminal, type, 'mount /dev/mapper/store-android /media/android. If successful, your /media/android directory is now full of various files and folders. This is your root Android directory in ES explorer.

5. Now go to your extracted gapps zip. You'll find two folders, 'system', and 'META-INF'. The 'system' folder contains other folders, which contain other folders and files. Copy all files from these directories to the corresponding directories in /media/android. For example, the '/system/app' folder contains 10 or 15 .apk files. Copy each one to /media/android/system/app. Repeat the same for the other folders. I don't know enough to know what the 'META-INF' folder is for, but I just copied it to /media/android, and to /media/android/system. Maybe someone can tell me if there's something better to do with it.

Once they're all copied, restart, boot into android, and you should get the 'welcome' android setup wizard, and Play Store will be installed. There are many apps that won't show up, because your device is 'not compatible', but you can just find the .apk online, and copy it to /media/android, and you can tap in in ES explorer to install. Some versions of some apps will get you a 'problem parsing', so you just try a different version. The only other thing I found out is that when I tried to use the Paypal app, I got 'Google Play Services' is missing. I just found an .apk and copied it to /media/android', then clicked on it in ES to install it.

To root:

I tried many things that didn't work, so I can't say for sure that something I did along the way didn't contribute, but if it did, I have no idea what it was. Here's what I did ultimately:

1. Download Superuser.apk, su (bin), and busybox (bin), and copy all 3 to /media/android/system/bin. In webOS terminal, (with #), use, 'chmod 4755 /media/android/system/bin/su', and 'chmod 4755 /media/android/system/bin/busybox'.

2. Restart, boot into Android. My first reboot got me to a frozen black screen that said something about 'starting system process and clock', or something like that. I thought I bricked it, but I just did the hold-power-toggle-volume restart, and it restarted normally. When Android came up, I opened an app, and I had root.

Up to that point, I had tried many things - I had run rageagainstthecage, tried pdanet, and I had various superuser and busybox files copied to various locations. Like I said, I don't know if any of that did anything. Maybe someone here who knows more can help more. All I know is that now I'm rooted, with Titanium backup, Busybox, system app remover, etc. all functioning.
1whocs is offline   Reply With Quote
Liked by Saijin_Naib and eblade like this.
Thanked by eblade, Saijin_Naib
Old 09/21/2014, 09:00 AM   #2 (permalink)
Member
 
Posts: 30
I forgot to mention that none of this was my original ideas. The mount /dev/mapper thing came from the Android on Veer thread, and the chmod 4755 came from an ancient article I found about rooting a Moto X.
1whocs is offline   Reply With Quote
Liked by TJs11thPre likes this.
Reply

 

Tags
android port webos, root, veer

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Google play Store Bonanza43 Android on webOS 4 03/06/2014 09:59 AM
HELP! All apps on showing in the play store Aayan1230 Android on webOS 0 04/24/2012 05:31 PM
Google blocking Android Market movie rentals on rooted devices rsanchez1 Other OS's and Devices 20 05/23/2011 04:52 PM
Just went to store to play with Treo mpk65281 Palm OS Devices & Apps 5 08/13/2002 07:14 PM


 


Content Relevant URLs by vBSEO 3.6.0