Results 1 to 3 of 3
  1.    #1  
    I have had the Veer for a couple of weeks now, finally cut the cord to Verizon yesterday. I have noticed the battery life on my Veer is not as good as I would like. Running the stock Kernel, I get an average of 10% battery loss per hour. After installing Uberkernel, it seemed to improve, using a little less an hour, depending on use. Today has been a better day than most, pulled it off the touchstone 6.5 hours ago and I'm at 57% now.

    I remember having to charge my Palm Pre + at least once throughout the day, though I suppose I had hoped battery life on WebOS devices would have improved over time.

    Any tips on how I can improve battery life? Has anyone found settings in govnah that have helped them out?
  2. #2  
    Quote Originally Posted by Lee Callaway View Post
    I have had the Veer for a couple of weeks now, finally cut the cord to Verizon yesterday. I have noticed the battery life on my Veer is not as good as I would like. Running the stock Kernel, I get an average of 10% battery loss per hour. After installing Uberkernel, it seemed to improve, using a little less an hour, depending on use. Today has been a better day than most, pulled it off the touchstone 6.5 hours ago and I'm at 57% now.

    I remember having to charge my Palm Pre + at least once throughout the day, though I suppose I had hoped battery life on WebOS devices would have improved over time.

    Any tips on how I can improve battery life? Has anyone found settings in govnah that have helped them out?
    OK... These are the Govnah settings I run for Veer and they are pretty much what I run for all 3 webOS devices I use with just a couple minor variations like max/min CPU speed.

    Be advised you may not like these settings. I've had others use them and tell me they are . Every user is a bit different. I'm not a power user. Not a lot of browsing, few marathon game sessions, I rarely stream. Either phone lasts me days on a charge. I don't actually make a lot of calls or texts either... But I have extended from just over a day with stock settings to now lasting 3-4 days.

    Govnah > Profile > Advanced Settings

    Change TCP Congestion to Westwood

    Tap CPU Frequency:
    Governor set to OnDemandTCL,
    Min Frequency set to 122.88 MHz,
    Max Frequency set to 1.344 GHz
    Up Threshold set to 85%,
    Powersave Bias set to 10,
    Screen Off Max Freq set to 368.64 MHz,
    Screenstate Enable set to True.

    All other values remain at stock settings for the OnDemand profile. Don't forget to save your profile...

    Note that I also do other things to save battery life, including various patches and system settings. It's a whole phone sort of thing.

    I'm not sure there is a universal answer other than the standard ones. Keep screen brightness down, turn GPS off except for when you need it, avoid push email or make the checks as far apart as you can (manual refresh being the best - I check mine about 2-3 times a day for each account - and even automatic checks of each hour beats push), if your phone wobbles between 2G and 3G try forcing data to 2G only and boost it to 3G just for when you really have to have it...


    Last edited by RumoredNow; 03/08/2013 at 11:32 AM.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  3. #3  
    On a german webOS forum there were reports of huge battery drain and some users found a solution in enabling & disabling flight mode after leaving their homes (and their wifi network) in the morning. I can't reproduce the issue myself, but I guess it doesn't hurt giving it a try. You can check average battery drain values before/after using govnah or dr.battery.

Posting Permissions