Results 1 to 12 of 12
  1. TheOneill's Avatar
    Posts
    85 Posts
    Global Posts
    86 Global Posts
       #1  
    Hello,

    I'm not really satisfied by the battery life of my veer using 2.2.4, specially when I'm not using it : the battery seems to drain even if keep the phone in my pocket with data deactivated (it lasts about 12 hours).

    I took a look at the logs and found something strange. I've got a huge amount of SLEEP/WAKE cycles and every wake step is followed by the same error message concerning modem and audio calibration (as far as I understand). Therefore, my log is full of "POWERD-WOKE after 0s" or maximum 1s and even if I don't do anything with my phone I guess the CPU use remains high :

    Code:
    2013-01-09T22:31:27.820558Z [8997] webos-device user.info powerd: {powerd}: POWERD-SUSPEND: SendSuspended: sending "suspended" because attempting to suspend (We are trying to sleep)
    2013-01-09T22:31:27.824447Z [8997] webos-device user.info powerd: {powerd}: POWERD-SUSPEND: StateSleep: waking in 441 seconds for keepAliveTimer 
    2013-01-09T22:31:27.825031Z [8997] webos-device user.info powerd: {powerd}: POWERD-SUSPEND: POWERD-SLEEP after 1s.252ms ... decision took 0s.134ms 
    2013-01-09T22:31:27.873064Z [8997] webos-device user.info powerd: {powerd}: BATTERY_IPC: (772.000000mAh, 87%, 91%_ui, 23C, -126mA, 4016mV, 96 authentic) 
    2013-01-09T22:31:27.938523Z [8997] webos-device user.info wall[8696]: wall: user root broadcasted 2 lines (37 chars)
    2013-01-09T22:31:28.685489Z [8998] webos-device kern.info kernel: [ 8997.872117] PM: Syncing filesystems ... done.
    2013-01-09T22:31:28.686129Z [8998] webos-device kern.warning kernel: [ 8997.970419] Freezing user space processes ... (elapsed 0.00 seconds) done.
    2013-01-09T22:31:28.686618Z [8998] webos-device kern.warning kernel: [ 8997.977640] Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
    2013-01-09T22:31:28.687084Z [8998] webos-device kern.warning kernel: [ 8997.978054] Suspending console(s) (use no_console_suspend to debug)
    2013-01-09T22:31:28.687550Z [8998] webos-device kern.err kernel: [ 8998.013132] msm_wm8994_shutdown_power: codec power shutdown
    2013-01-09T22:31:28.688020Z [8998] webos-device kern.err kernel: [ 8998.013815] wm8994_ldo_power: Power down the WM8994 LDOs
    2013-01-09T22:31:28.691567Z [8998] webos-device kern.warning kernel: [ 8998.025051] WAKE SOURCE(0x3) = (SMD) name=RPCCALL prog=0x30000061, proc=0x10 (INT) 
    2013-01-09T22:31:28.692026Z [8998] webos-device kern.err kernel: [ 8998.348836] wm8994_ldo_power: Power up the WM8994 LDOs
    2013-01-09T22:31:28.702705Z [8998] webos-device kern.warning kernel: [ 8998.586081] Restarting tasks ... <6>rmt_storage_ioctl: wait for request ioctl
    2013-01-09T22:31:28.705084Z [8998] webos-device kern.warning kernel: [ 8998.601752] done.
    2013-01-09T22:31:28.746443Z [8998] webos-device user.info wall[8701]: wall: user root broadcasted 2 lines (27 chars)
    2013-01-09T22:31:28.756160Z [8998] webos-device user.info powerd: {powerd}: POWERD-SUSPEND: SendResume: sending "resume" because resume (kernel)
    2013-01-09T22:31:28.769048Z [8998] webos-device user.info powerd: {powerd}: POWERD-SUSPEND: POWERD-WOKE after 0s : 0 days, 0h-0m-0s  (kernel)
    2013-01-09T22:31:28.769667Z [8998] webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: com.palm.systemui: SystemUI --- Power Resume Notifications {}, palmInitFramework2112:14
    2013-01-09T22:31:28.806037Z [8998] webos-device user.info powerd: {powerd}: BATTERY_IPC: (772.000000mAh, 87%, 91%_ui, 23C, -155mA, 4006mV, 96 authentic) 
    2013-01-09T22:31:28.810821Z [8998] webos-device kern.err kernel: [ 8998.707352] [msm-audio:afe.c:afe_dsp_event] unexpected message from afe 
    2013-01-09T22:31:28.811394Z [8998] webos-device kern.info kernel: [ 8998.707748] aif1 codec rates are already configured
    2013-01-09T22:31:28.811884Z [8998] webos-device kern.err kernel: [ 8998.710186] [msm-audio:audio_acdb.c:acdb_get_calibration] ACDB=> Device table RPC failure result = -2
    2013-01-09T22:31:28.812379Z [8998] webos-device kern.info kernel: [ 8998.710414] aif2 codec rates are already configured
    2013-01-09T22:31:28.812859Z [8998] webos-device kern.err kernel: [ 8998.710938] [msm-audio:audio_acdb.c:acdb_calibrate_device] Not able to get calibration data, continue
    2013-01-09T22:31:28.813349Z [8998] webos-device kern.err kernel: [ 8998.715467] [msm-audio:audio_acdb.c:acdb_get_calibration] ACDB=> Device table RPC failure result = -2
    2013-01-09T22:31:28.813836Z [8998] webos-device kern.err kernel: [ 8998.715672] [msm-audio:audio_acdb.c:acdb_calibrate_device] Not able to get calibration data, continue
    Someone else experienced that ?

    I did a check on my 2.2.4 Pre2, there is nothing comparable : the system and sleep periods are much longer.

    Thanks !
  2. #2  
    Well, im on 2.2.4 too and cannot confirm your battery drain. My veer has 36-48 hours of life cycle with moderate phoning, surfing and data usage.
  3. #3  
    my veer with 2.2.4 only last 8-10hrs with data deactivated
  4. trwrt's Avatar
    Posts
    110 Posts
    Global Posts
    612 Global Posts
    #4  
    I have the same error messages about the audio calibration stuff after every wakeup in my log files, but mine generally sleeps for a minute or two instead of 0 or 1 second:

    2013-01-10T04:28:47.610278Z [148063] webos-device user.info powerd: {powerd}: POWERD-SUSPEND: POWERD-WOKE after 83s : 0 days, 0h-1m-23s (kernel)

    With bluetooth on but not connected to anything and Wifi on I have about 5%/hr battery drop but I need to measure it more seriously, just installed 2.2.4 a couple days ago.
  5. TheOneill's Avatar
    Posts
    85 Posts
    Global Posts
    86 Global Posts
       #5  
    Thanks for your feedbacks.
    So the calibration error messages do not seem to be correlated with battery usage and repetitive wake-ups. Don't know why but today battery life was much better, it was full at 8am and tonight at 8pm I still had 75% with moderate mail/web/agenda usage and a mail sync time set to 1 hour.
    In the log I see that sleep time is much better than yesterday, but I still have the calibration messages. I'll try to compare the 2 logs, see if I notice something that may explain the no-sleep behaviour.
  6. TheOneill's Avatar
    Posts
    85 Posts
    Global Posts
    86 Global Posts
       #6  
    In the "no-sleep" logs I get this all the time (at each wake-up) :

    Code:
    2013-01-09T15:10:00.654131Z [29148] webos-device kern.warning kernel: [29146.225828] WAKE SOURCE(0x6) = (INT) (GPIO=145)
    Whereas today I have many different wake sources but never this one.
  7. #7  
    the battery drain come from 2.2.4 A6 firmware. cannot stay idle for a day
    using 2.1.x A6 firmware it last much longer

    > Well, im on 2.2.4 too and cannot confirm your battery drain. My veer has 36-48 hours of life cycle with moderate phoning, surfing and data usage.
    so are you sure you have updated A6 firmware? try 2.2.4. you can always downgrade to 2.1.x firmware by copying the old A6 firmware txt into phone and flash the firmware
  8. #8  
    Quote Originally Posted by moo.tinys View Post
    so are you sure you have updated A6 firmware? try 2.2.4. you can always downgrade to 2.1.x firmware by copying the old A6 firmware txt into phone and flash the firmware
    Yes, im sure i have the newest A6 firmware from 2.2.4
  9. #9  
    Quote Originally Posted by michel_ng View Post
    Yes, im sure i have the newest A6 firmware from 2.2.4
    Battery drain here varies a lot with 2.2.4. Overnight (6-8 hours) it usually only takes 1-3% with only GSM on, rest of options (3G, WiFi off), however sometimes it drains 30-40% in the same time. I guess it has to do with WiFi not properly turning off or something. A device restart sorts that usually.
  10. #10  
    no problems here at all with 2.2.4 on my Veer. With moderate use I get about the same battery life as with my lost Pre 3 ( one and a half days). No fast drain so far. In my experience mostly web related tasks as frequent mail checking, What'sapp etc. can cause fast battery drain. Sometimes a task goes beserk and as Herrie mentioned a restart usually cures it...
  11. #11  
    Quote Originally Posted by Herrie View Post
    Battery drain here varies a lot with 2.2.4. Overnight (6-8 hours) it usually only takes 1-3% with only GSM on, rest of options (3G, WiFi off), however sometimes it drains 30-40% in the same time. I guess it has to do with WiFi not properly turning off or something. A device restart sorts that usually.
    Actually had it happening overnight and I guess I found out what caused it.

    Just before going to bed, I turned on wifi. It connected and worked, but circle kept spinning. I turned off wifi and in the morning my battery was down to 41% from 100%.
  12. #12  
    @Herrie

    you should leave wifi always enabled, because its better for battery life. You may search for the threat describing this issue

Posting Permissions