webOS Nation Forums >  webOS Devices >  HP Veer > Screen won't turn on
Screen won't turn on
  Reply
 
Thread Tools Display Modes
Old 11/07/2012, 02:56 PM   #1 (permalink)
Homebrew Developer
 
Posts: 365
So I'm having problems with the screen on my Veer. Just starting today the screen just will not turn on. I can barely see a little bit of backlight, but nothing will appear.

Sometimes the screen will turn on, but not update with what I'm doing. Like if I get it to turn on it'll show the lock screen and I can unlock it, but it won't show that I ever did anything. If I shut the screen off and get it to come back I can see the apps that I launched while it was still showing the lock screen.

And other times it will just have some crazy artifacts on the screen and is totally useless. Anybody else have any problems like this and can give some suggestions?
m0ngr31 is offline   Reply With Quote
Old 11/07/2012, 03:08 PM   #2 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Maybe the cable that connects the front half and back half of the phone is deteriorating. Lots of friction, lots of time, and you've got a worn down cable.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 11/07/2012, 03:56 PM   #3 (permalink)
Homebrew Developer
 
Posts: 365
That's what I'm guessing. I'm getting some weird artifacts when I boot up the phone, and they change when I open and close the slider. I'm assuming they don't use the same ribbon cables as the old Pre right? I've got a million of those lying around...
m0ngr31 is offline   Reply With Quote
Old 11/07/2012, 10:43 PM   #4 (permalink)
Homebrew Developer
 
Posts: 365
A warning for Veer users who want to take apart their phones to figure out what is going on: it might never turn on again haha
m0ngr31 is offline   Reply With Quote
Old 11/07/2012, 10:51 PM   #5 (permalink)
Member
 
Remy X's Avatar
 
Posts: 1,384
Death by Electrostatic Discharge?

That's too bad. I always ground myself first, either by touching the back of my desktop computer, or in the kitchen touching the faucet, since we have copper pipe here.

If not, it might work if re-assembled again. Good luck anyway
Remy X is online now   Reply With Quote
Old 11/07/2012, 11:49 PM   #6 (permalink)
Homebrew Developer
 
Posts: 365
I don't think it was ESD, I'm hoping I just put something in wrong.. we'll see though. I'm stuck using an iPhone
m0ngr31 is offline   Reply With Quote
Old 11/13/2012, 10:34 AM   #7 (permalink)
Homebrew Developer
 
Posts: 365
Well tried taking it apart and putting it back together, but same thing. It won't turn on at all. Think I much have just bent the system board or something when I was taking it out. Lesson learned haha
m0ngr31 is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0