Results 1 to 9 of 9
  1. EvanKr's Avatar
    Posts
    119 Posts
    Global Posts
    196 Global Posts
       #1  
    Hey, everyone,

    I picked up a Veer recently and I've been loving it so far on my local network (MTS), but I've been unable to access data or send MMS, although it's included in my monthly plan.

    I decided to try to edit the APN settings, as it could be preset for AT&T (I had no trouble using data or sending MMS while I was in the states using AT&T), so I selected "Manual Settings", and entered my carrier's APN settings. I entered the settings provided on the website for data (APN is sp.mts, username and password are blank), I saved the settings and I got a notification telling me that the settincs had been changed. However, I'm still unable to access data. Same thing for MMS, but I just get an error when I enter the settings.

    The strangest thing is that when I close the phone app and open it back up, the "Manual Settings" option has been turned off, even though I just changed the settings. Every time I reopen the phone app, the settings just reset themselves.

    You can see my carrier's APN settings here: Using Non-MTS Devices | MTS
    There's no webOS option listed (not that I was expecting one, as usual), but I assumed that most of the info would be the same.

    The phone's definitely unlocked as I'm able to send SMS and call people over the network, but I can't use any data features. I could try calling MTS, but they have TERRIBLE (I really mean it) customer support, and they'd have no idea what's wrong because it's a webOS device.

    Anybody encounter a similar problem where they're unable to change the APN settings? Could somebody offer any advice or help?

    Thanks,
    -Evan
  2. #2  
    This is quite a common problem with webOS 2.1.2 as it seems. I had it a few times too in the past. It was solved with the unofficial 2.2.3/2.2.4 update. There are some topics about it on the Veer section here as well, so you might want to look for it. Maybe someone has a solution when using 2.1.2

    Alternatively you might want to look into editing the carrier.json file to add/edit the settings for MTS. Carrierdb.json often has outdated or incomplete info in it, causing data connections not to work properly.

    See also:
    HOWTO: Edit your carrierdb.json file

    http://digitalunlock.com/webos/carrierdb/index.html
  3. #3  
    You also may want to unlock your SIM card...
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  4. EvanKr's Avatar
    Posts
    119 Posts
    Global Posts
    196 Global Posts
       #4  
    Thanks for the replies, guys,

    @Herrie, I'll try updating to 2.2.4, I tried it in the past with no success, but I'll read through the guide and attempt to install it again.

    @RuomredNow, what do you mean by "unlocking the SIM card"?
  5. EvanKr's Avatar
    Posts
    119 Posts
    Global Posts
    196 Global Posts
       #5  
    Okay, I updated the carrierdb info, and now I'm getting a "3G" icon but still no MMS.

    I just realized that my plan doesn't include data, only "unlimited mobile web" (Whatever that means), but it does include unlimited MMS so it should be working. You can see more infor about it here: Student Text Deal | MTS

    I called customer care and they told me that it could be a bad SIM, but I'm not convinced. Is there a possibility that I entered the carrierdb info wrong?
  6. #6  
    On the link you showed in the first post...

    The settings for iPhone look formatted exactly like what you would need for a Veer

    Using Non-MTS Devices | MTS

    Expand the iOS settings list and use the first two of the three boxed shown...

    Notice how in MMS Proxy it ends with ":9401" that is for port 9401 and you will need that. Maybe check the Max size setting as well....

    As for unlocking your SIM - that is in the dialer preferences menu... Scroll down to the security box and tap on the line that says "unlock SIM"... You should be able to unlock it there. Probably doesn't have a password on it, but you can then establish one of your own choosing.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  7. EvanKr's Avatar
    Posts
    119 Posts
    Global Posts
    196 Global Posts
       #7  
    @RumoredNow,

    Thanks for all the help so far! I really appreciate you and all of the webOS community's support and assistance with everything.

    So, I tried changing the port to 9401, still no luck. Do I need to end the proxy with :9401, like the page said for the iPhone? What I find interesting is that I get a 3G symbol in the top right hand corner (something that previously wasn't there) which shows me that something's working, but I still can't send MMS. When I look under the phone app, fortunately now manual settings are enabled by default, and everything looks okay. However, I noticed that the MMS Proxy is set as 209.4.229.90, not 209.4.229.90:9401 as they were listed as on the iPhone settings. Could that possibly be the problem? Using the Digital Unlock carrierdb info generator (DigitalUnlock carrierdb.json Editor), I set the MMSCPortNumber setting as 9401, but it's still not working properly. Here are my current MMS and Data settings:

    For MMS:

    {"_kind":"com.palm.carrierdb:1",
    "mcc":302,
    "mnc":660,
    "qOperatorLongName":"MTS",
    "qOperatorShortName":"MTS",
    "smsEmailGateway":"",
    "mmscWapGateway":"",
    "mmscUrl":"http://mmsc2.mts.net/",
    "mmscPortNumber":9401,
    "mmscMessageSizeLimit": 512000,
    "smsMessageSizeLimit":160,
    "smsValidityPeriod":170,
    "mmsMaxVideoSize":295,
    "mmsVersionNumber":0,
    "smsRequestDeliveryReceiptAvailable":false,
    "useVodaphoneVoicemail":false,
    "smsCanSendBlank":false,
    "smsMaxRecipients":20,
    "smsMaxPartsPerMessage":10,
    "mmsCcBccSupported":false,
    "mmsDefaultPageDuration":5000,
    "mmsIsPictureResolutionLimited":false,
    "mmsIsWavSupported":true,
    "mmsMaxAudioSize":295,
    "mmsMaxPictureHeight":480,
    "mmsMaxPictureWidth":640,
    "mmsMaxRecipients":20,
    "mmsCanSendBlank":false,
    "mmsRequestDeliveryReceiptAvailable":false,
    "mmsProxy":"209.4.229.90",
    "isSmscNumberOnSimCard":true,
    "mmsAckMessageRead":false,
    "mmsAcknowledgeMsgReceipt":false,
    "mmsApnId":1073,
    "voicemailNumber":"",
    "gsmNumSimPDP":2,
    "umtsNumSimPDP":2,
    "mmsEnableAutomaticDownloadWhenRoaming":false,
    "gpsAllowed":true,
    "msBasedAllowed":true,
    "msAssistedAllowed":0,
    "agpsServerAddr":"",
    "smsEncoding":"",
    "smsTransportMethods":"",
    "smsNumberSecondsWaitForSegment":0,
    "useGpsSettingsInCarrierDb":false,
    "maxTransitUnit":0,
    "maxSegmentSize":0,
    "smsHeaderSizeLimit":7,
    "msfpTimerDefault":0,
    "msfpTimerInterval":0,
    "msfpTimerMax":0,
    "msfpTimerMin":0,
    "smscNumber":"",
    "msAllowedApps":"",
    "defaultSocketIdleTimeMinutes":0,
    "disableAutotext":false,
    "mmsSendLowResVideo":false,
    "bsLatLongSupport":true,
    "suplCert":"ThawtePremiumServer",
    "suplPort":7275,
    "suplServer":"supl.google.com",
    "portSocketIdleTimeMinutes":[],
    "smsMaxNetworkSegmentsPerMessage":1,
    "hspaCategory":[0],
    "smsWhiteListClass0":[],
    "settingPriority":0}

    And for data:

    [{"apnid":999999,
    "regionName":"MTS",
    "serviceDefault":1,
    "supportedService":1,
    "cshnUserName":"",
    "cshnPassword":"",
    "apn":"",
    "ignoreRoamGuard":false,
    "tetheredNaiRequired":false,
    "slot":0,
    "domains":[]}]

    I didn't change the APN ID nor the APN settings for either of them, is that where the problem lies? Everything looks to be in order...
    I have no way of testing if the data works as I'm not on a data plan, but I'm heading out to an MTS store tomorrow, and I'll try a data enabled SIM there to see if it's working.

    Again, thanks for all of your help, I'd be totally lost without the community's assistance.

    -Evan
  8. #8  
    Yes, you need the :9401

    The : signifies port after the IP gateway string.

    As for the rest of it... looks good, but I'm in bed on my tablet so I can't compare it with copies of carrierdb.json files I have. Sounds like you are very close.

    I'm glad to help. Just passing on what others have shown me or written beforehand. It's what makes this such a great community like you said.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  9. EvanKr's Avatar
    Posts
    119 Posts
    Global Posts
    196 Global Posts
       #9  
    Thanks again, I'll try renaming the proxy tomorrow when my Veer's charged, as for now I can only hope that it works...

    -Evan

Posting Permissions