Results 1 to 4 of 4
  1.    #1  
    Hello everyone,

    First, let me say how happy I am to be back as a webOS user. After 15+ Pre Minuses on Sprint, I picked up a newly released Veer during a switch to AT&T right at the time HP announced they were slaughtering the best platform ever canceling webOS hardware. I promptly returned it within my first 10 days and defected to an HTC (Un)Inspire(d). I've lamented the loss of good UI design and a hardware keyboard ever since. I have just, within the last week, happily returned to webOS with another Veer I picked up with "Amazon-money" I had lying around.

    The best patch/tweak I've had on my previous webOS devices is the iPhone user agent spoof. There are tons of mobile sites that work well on the webOS Browser, but not many that recognize webOS.

    Now on webOS Quick Install v4, the Tweaks section has been removed. The only posts on the matter appear to be quite old. I've tried two different tweak scripts I've found lying around the forums and both error out on my Veer. Can anyone point me towards a solution to "spoof" my Veer into reporting itself as an iPhone (or Android, at the very least)?

    I'm not afraid of a terminal window and don't mind doing this manually, if someone can point me to the correct file. Alternatively, if someone still has an older (<4) version of WOSQI, that should do the trick as well.

    Somebody help me! The webOS Browser is nearly unbearable on the Veer's tiny screen without mobile editions of the web.
  2. #2  
    Did you look here:

    iPhone User Agent Spoof - How to make all mobile websites display perfectly

    Haven't tried it myself, though.

    LK
  3.    #3  
    Quote Originally Posted by Lebenskuenstler View Post
    Did you look here:

    iPhone User Agent Spoof - How to make all mobile websites display perfectly

    Haven't tried it myself, though.

    LK
    Yeah, I've scoured that thread myself. Tried running a few scripts, all to no avail. I'm running a Veer wtih webOS 2.1.2 on AT&T.

    Anybody know where in webOS the user agent string is stored?
  4. #4  
    Quote Originally Posted by thehyperone View Post
    Yeah, I've scoured that thread myself. Tried running a few scripts, all to no avail. I'm running a Veer wtih webOS 2.1.2 on AT&T.

    Anybody know where in webOS the user agent string is stored?
    I did not want you read the thread, but the specific post, I linked to.

    I did it try now. The script does not work. I am not very good at bash scripting (I tried to correct it, but failed), but the author says what is important to know.

    1. You have to backup the file somewhere else. I.e. /media/internals.
    2. Take some hexeditor, open /usr/lib/libWebKitLuna.so and search for this string(text):
    Mozilla/5.0 (webOS/%s; U; %s) AppleWebKit/532.2 (KHTML, like Gecko) Version/1.0 Safari/532.2 %s
    and replace it with:
    Mozilla/5.0 (iPhone; U; en)(webOS/%s; U; %s) AppleWebKit/532.2 Version/1.0 Safari/532.2 %s -CET

    IT IS IMPORTANT that you explace EXACTLY that thring. Do not ad any signs, spaces oder remove them.

    3. Save the edited file.
    4. Overwrite the version /usr/lib/libWebKitLuna.so.
    Reboot.

    This works.

    LK
    Last edited by Lebenskuenstler; 03/28/2012 at 11:02 AM.

Tags for this Thread

Posting Permissions