Page 2 of 2 FirstFirst 12
Results 21 to 29 of 29
Like Tree1Likes
  1. #21  
    Hey martan1981,

    I use a Mac, so I don't know how to do this on Windows. But if I had to guess, I'd say to start command prompt with your Veer plugged in and type novacom.

    To Cantaffordit,

    I'm a noob to the forum. I thought that I'd be hijacking the thread if I posted my solution given that the original poster hadn't asked. Sorry to be a bother.
  2. #22  
    Quote Originally Posted by john.barr.rowe View Post
    Hey martan1981,

    I use a Mac, so I don't know how to do this on Windows. But if I had to guess, I'd say to start command prompt with your Veer plugged in and type novacom.

    To Cantaffordit,

    I'm a noob to the forum. I thought that I'd be hijacking the thread if I posted my solution given that the original poster hadn't asked. Sorry to be a bother.
    To run a terminal session from WebOS Quick Install, select Tools > Linux Commandline.

    @john.barr.rowe, the second iptables command threw an error for me. Did I get it right? Is there a typo in your instructions? Thx.

    ...
    root@JTSU1Veer:/proc/sys/net/ipv4# iptables -A FORWARD -i iptables -A FORWARD -
    i eth0 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT -o eth1 -m state -
    -state RELATED,ESTABLISHED -j ACCEPT
    iptables -A FORWARD -i iptables -A FORWARD -
    i eth0 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT -o eth1 -m state -

    -state RELATED,ESTABLISHED -j ACCEPT
    iptables v1.4.2: Can't use -A with -A

    Try `iptables -h' or 'iptables --help' for more information.
    root@JTSU1Veer:/proc/sys/net/ipv4#
  3. #23  
    where do you get freetether from. i cant find in app catalogue

    edit: found it its in preware. and now working for australian optus. tethering
    Last edited by kyoshokev; 10/08/2011 at 11:56 PM.
  4. #24  
    Quote Originally Posted by jtsu1 View Post
    To run a terminal session from WebOS Quick Install, select Tools > Linux Commandline.

    @john.barr.rowe, the second iptables command threw an error for me. Did I get it right? Is there a typo in your instructions? Thx.

    ...
    root@JTSU1Veer:/proc/sys/net/ipv4# iptables -A FORWARD -i iptables -A FORWARD -
    i eth0 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT -o eth1 -m state -
    -state RELATED,ESTABLISHED -j ACCEPT
    iptables -A FORWARD -i iptables -A FORWARD -
    i eth0 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT -o eth1 -m state -

    -state RELATED,ESTABLISHED -j ACCEPT
    iptables v1.4.2: Can't use -A with -A

    Try `iptables -h' or 'iptables --help' for more information.
    root@JTSU1Veer:/proc/sys/net/ipv4#
    I received the same error but it's working beautifully! I had to uninstall FreeTether as I was experiencing the no down scaling issue - Veer ran at full speed non-stop and drained battery excessively. Had the issue on Stock as well as Warthog kernels.. now can finally use at hotspot and phone throughout the day without issues.

    Liked FreeTether - but will wait until downscaling issue is resolved.

    Thank you for posting this fix! Luna Restart still keeps the 'hack' so I'm good until the next restart.
  5. #25  
    Quote Originally Posted by amorfeusz View Post
    I received the same error but it's working beautifully! I had to uninstall FreeTether as I was experiencing the no down scaling issue - Veer ran at full speed non-stop and drained battery excessively. Had the issue on Stock as well as Warthog kernels.. now can finally use at hotspot and phone throughout the day without issues.

    Liked FreeTether - but will wait until downscaling issue is resolved.

    Thank you for posting this fix! Luna Restart still keeps the 'hack' so I'm good until the next restart.
    Thanks amorfeusz! Lol, 'scuse my timidity!
    Folks, even after removing the offending line that throws the error, mobile hotspot worked on my Veer. G'luck, YMMV. So, use the following:

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o rmnet0 -j MASQUERADE
    iptables -A FORWARD -i rmnet0 -o bridge0 -m state --state RELATED,ESTABLISHED -j ACCEPT
    iptables -A FORWARD -i bridge0 -o rmnet0 -j ACCEPT

    I can switch back and forth between Mobile Hotspot and Wifi connecting and disconnecting the client, no problem until the Veer reboots and the commands have to be run again. If someone can point me to how to start this script at bootup, or from an app-icon, I'd much appreciate it, else I have my next task ahead of me. Thx in Advance.

    Also, I'm no network guru, so if anyone can explain what these commands do and what problem they solve, I'd really appreciate the lesson.

    Thanks again to john.barr.rowe.

    Config:
    ATT locked Veer
    ATT sim card registered to prepaid ATT gophone, 10c/min 15m/100Mb
    webos 2.1.2
  6. benh's Avatar
    Posts
    102 Posts
    Global Posts
    104 Global Posts
    #26  
    Quote Originally Posted by jtsu1 View Post
    If someone can point me to how to start this script at bootup, or from an app-icon, I'd much appreciate it, else I have my next task ahead of me. Thx in Advance.
    I don't know how to do it in webos, but normally in Linux your put the commands in a file called rc.local, but that doesn't appear to be there in webos. I did a little research, but didn't come up with much.

    Ben
  7. jazzdoc's Avatar
    Posts
    137 Posts
    Global Posts
    144 Global Posts
    #27  
    There is a conversation going in the Pre 3 forum with the same question about getting Mobile Hotspot working. Is this at all likely to work on the Pre 3?
    Casio BOSS->Palm Pilot Professional->Palm M500->Treo 600-> Treo 680->Treo Pro (TP) ->HP Veer<->HP TP<->Pre3<>HP TP 4G
    Conn 6H-> Bach 36->Bach 16L (high Bb plays really flat?(fixed thanks to **** Akright))-> New York Bach 6viii
    Scalpel->Scope->Aesop->Hermes->Sidne->Davinci S>Davinci Si
  8. sooohaib's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #28  
    guys ... the problem is solved ... just download the latest version of freetether from preware or just update your current version
  9. #29  
    Is freeTether for older versions of WebOS or should I install it on my v2.1.2 Veer, instead of using the Mobile Hotspot app built in?

    Thanks!

    EDIT: Oh also, does freeTether get around any carrier tethering restrictions?
    I am on "Pay As You Go" (prepaid) Rogers (Canada) and have thus far been unable to tell if Rogers allows or does not allow tethering on prepaid plans.

    Logic tends to dictate that they would allow it for any SIM as they change for data used, and wouldn't they want data usage to be as high as possible (Max profits!)? However there is something on their site about tethering not working on "plans" with less than 1GB (there is no such plan on prepaid).

    Any thoughts appreciated!
Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions