Page 1 of 2 12 LastLast
Results 1 to 20 of 22
  1.    #1  
    I'm putting this patch in the Veer threads, because it should only be applied to an UNLOCKED ATT VEER NOT on ATT.

    DO NOT install it on any other phone. An EU Veer does not need this patch.

    edit: 27 Sept: added a toggle to turn on or off the bypass for att limits.

    This patch simply reveals the options for choosing (if your sim does not allow these options to work, choosing will have no effect):

    automatic network selection
    search for networks
    manual network selection
    Data mode automatic, 3G, 2G

    Background: ATT disables this part of the phone preferences. However, if you are like me and not on ATT, you should be able to choose your modes.

    I do not recommend installing this if you are on ATT, I do not know what ATT will charge you if you run on someone else's network or on different speeds. I have no idea about their network, therefore I will not answer questions about use on ATT.

    I use this on my Veer, but you assume responsibility for your own phone by applying this patch. It will NOT go into Preware, because Preware can not tell the difference between ATT Veer and EU Veer.

    If ATT ever releases an update, you WILL need to remove this patch prior to the update.

    edit: Unfortunately, the settings won't stay across a reboot. I have yet to find where ATT put the lock that recurs on restart. Meaning if you choose 2G and reboot, it will be back on automatic after a phone reboot. If you just close and open the phone app, it will stay where you left it.
    Attached Files Attached Files
    Last edited by frantid; 09/27/2011 at 07:41 AM.
  2. #2  
    Quote Originally Posted by frantid View Post
    I'm putting this patch in the Veer threads, because it should only be applied to an UNLOCKED ATT VEER NOT on ATT.

    DO NOT install it on any other phone. An EU Veer does not need this patch.

    This patch simply reveals the options for choosing (if your sim does not allow these options to work, choosing will have no effect):

    automatic network selection
    search for networks
    manual network selection
    Data mode automatic, 3G, 2G

    Background: ATT disables this part of the phone preferences. However, if you are like me and not on ATT, you should be able to choose your modes.

    I do not recommend installing this if you are on ATT, I do not know what ATT will charge you if you run on someone else's network or on different speeds. I have no idea about their network, therefore I will not answer questions about use on ATT.

    I use this on my Veer, but you assume responsibility for your own phone by applying this patch. It will NOT go into Preware, because Preware can not tell the difference between ATT Veer and EU Veer.

    If ATT ever releases an update, you WILL need to remove this patch prior to the update.

    edit: Unfortunately, the settings won't stay across a reboot. I have yet to find where ATT put the lock that recurs on restart.
    Whatever file this patch modifies trying changing the file permission to 777 and see if it sticks. I would love to apply this on my veer
  3.    #3  
    Quote Originally Posted by lighter789 View Post
    Whatever file this patch modifies trying changing the file permission to 777 and see if it sticks. I would love to apply this on my veer
    It's a system config set somewhere deep in the system. I tried to override the system config using Impostah but it ignores the overrides. So all I could do is allow the preferences to be set after start up. I don't restart that often so it's not that bad.
  4. #4  
    Quote Originally Posted by frantid View Post
    It's a system config set somewhere deep in the system. I tried to override the system config using Impostah but it ignores the overrides. So all I could do is allow the preferences to be set after start up. I don't restart that often so it's not that bad.
    This is the same thing that happens with setting up the data setting manually by modifying the permissions of the file to chmod 777 it resolves the issue of the file reverting back to default.... If you can give me the file name I can try and let you know what happens
  5.    #5  
    I haven't found it yet. If I do find it I'll let you know. The files I modify stay, it is the system database that gets rebuilt on reboot.
  6. #6  
    Quote Originally Posted by frantid View Post
    I haven't found it yet. If I do find it I'll let you know. The files I modify stay, it is the system database that gets rebuilt on reboot.
    Ok cool sounds good ill try messing around myself as well
  7. #7  
    How to apply this patch???
  8.    #8  
    Quote Originally Posted by bigbyte View Post
    How to apply this patch???
    You can use webOS QI, by downloading the file to your computer and installing. Or you can use Internalz Pro by putting the patch file on the usb part of the phone with a cable.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  9. #9  
    Thanks a lot. WebOs QI kept giving error while applying the patch but internalz worked.
  10. #10  
    can this help out a veer on T-Mobile?
    thanks
  11.    #11  
    Quote Originally Posted by stu5797 View Post
    can this help out a veer on T-Mobile?
    thanks
    It won't unlock it, but it will allow you to switch to 2g.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  12. #12  
    Anybody care to update this patch to 2.2.3 for the Pre 3?
  13. #13  
    Quote Originally Posted by hawaii View Post
    Anybody care to update this patch to 2.2.3 for the Pre 3?
    You would actually be better of making a meta-doctor with the vanilla-att script to get rid of all the AT&T crap and limitations for good from your AT&T Pre3.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  14. squall77's Avatar
    Posts
    28 Posts
    Global Posts
    30 Global Posts
    #14  
    Is there any instruction on how to do that? I try to look around never get a good set of instruction on that. If we are using meta doctor does that means we will never get updates for new version?
  15.    #15  
    Quote Originally Posted by squall77 View Post
    Is there any instruction on how to do that? I try to look around never get a good set of instruction on that. If we are using meta doctor does that means we will never get updates for new version?
    I posted a way to do this for a Pre3 earlier. You need to install the patch from the that thread, run the commands from the linked post. AND full erase your Pre3. You don't have to re-apply the patch after the erase. It should still allow you to get OTA updates, but you may have to repeat the process if the updates modify those files again.

    http://forums.precentral.net/3187602-post56.html
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  16. #16  
    Quote Originally Posted by frantid View Post
    I posted a way to do this for a Pre3 earlier. You need to install the patch from the that thread, run the commands from the linked post. AND full erase your Pre3. You don't have to re-apply the patch after the erase. It should still allow you to get OTA updates, but you may have to repeat the process if the updates modify those files again.

    http://forums.precentral.net/3187602-post56.html
    If I understand correctly, for Veer you have to:

    1. only run patch
    2. Erase Apps and Data

    Or you have to run that remove command too ?
    If you like my applications (SynoMusic, SynoDM, SynoFM) and want to donate for future upgrades and development
  17.    #17  
    Quote Originally Posted by panel View Post
    If I understand correctly, for Veer you have to:

    1. only run patch
    2. Erase Apps and Data

    Or you have to run that remove command too ?
    No for the veer, you just have to install the patch in the first post of this thread and restart Luna.

    If you want to do a manual, setup then you would have to edit the files yourself run the commands and erase. The linked method is just for an ATT Pre3.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  18. #18  
    Quote Originally Posted by frantid View Post
    No for the veer, you just have to install the patch in the first post of this thread and restart Luna.

    If you want to do a manual, setup then you would have to edit the files yourself run the commands and erase. The linked method is just for an ATT Pre3.
    Thank you very much for this
    If you like my applications (SynoMusic, SynoDM, SynoFM) and want to donate for future upgrades and development
  19. #19  
    Quote Originally Posted by frantid View Post
    I'm putting this patch in the Veer threads, because it should only be applied to an UNLOCKED ATT VEER NOT on ATT.
    ...
    This patch simply reveals the options for choosing...
    Hi,

    this patch seems to be exactly what I very badly need. I have been traveling with my unlocked Veer 2.1.2 in Europe, using an eKit SIM and needed to switch network to a provider that better supported it. That was when I discovered that AT&T nuked that basic GSM option!

    Unfortunately, I do not seem to be able to install the patch. Is there anything I am doing wrong? Do these following error messages hint on what else I need to do?

    I have tried installing using QuickInstall 4.3.1. The installation failed with the message:
    An error occured while attempting to apply attveerunlockedphoneprefs-2.patch.
    Unable to connect to WebOS-Internals' servers.
    Cannot download AUPT scripts for the patch.

    (The PC, by the way, was connecting to the WebOS web site at that time).

    I also tried InternalzPro: I copied patch file to the phone over USB and installed via Internalz. This failed as well, with message:
    Patch installation failed.
    AUSMT is missing. It is required for patching.


    Thanks in advance for help Robert..
  20. #20  
    Quote Originally Posted by rdwalker View Post
    Hi,

    this patch seems to be exactly what I very badly need. I have been traveling with my unlocked Veer 2.1.2 in Europe, using an eKit SIM and needed to switch network to a provider that better supported it. That was when I discovered that AT&T nuked that basic GSM option!

    Unfortunately, I do not seem to be able to install the patch. Is there anything I am doing wrong? Do these following error messages hint on what else I need to do?

    I have tried installing using QuickInstall 4.3.1. The installation failed with the message:
    An error occured while attempting to apply attveerunlockedphoneprefs-2.patch.
    Unable to connect to WebOS-Internals' servers.
    Cannot download AUPT scripts for the patch.

    (The PC, by the way, was connecting to the WebOS web site at that time).

    I also tried InternalzPro: I copied patch file to the phone over USB and installed via Internalz. This failed as well, with message:
    Patch installation failed.
    AUSMT is missing. It is required for patching.


    Thanks in advance for help Robert..
    As Internalz Pro says, you need the AUSMT package. Do note, you have an out-dated version of WOSQI. Download the current version and install with that; it should install AUSMT for you then.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
Page 1 of 2 12 LastLast

Posting Permissions