Results 1 to 4 of 4
  1.    #1  
    I recently Purchased an unlocked Veer from the US. I live Australia. I have a problem with contacts in regards to Calls and SMS.


    I'll use this fake mobile number as an example. 0405 123 456

    If I save a number in this format or have a number on my Sim card in this format and receive a call, it will show the contacts name as per usual. Though, if they send me an SMS, it will be displayed as +61 405 123 456 and doesn't show the contact name. +61 being Australias country code.


    Now if I save the number as +61 405 123 456 and I receive an SMS, it will show the contacts name. But if they call me, only the number 0405 123 456 is displayed without the contact name. So I cannot get each number to display the name of the contact for both Calls and SMS at the same time.

    I have changed the regional settings to Australia and rebooted. It makes no difference. Any Ideas? Also is there anyway to hide Sim contacts from displaying? My sim card has these directory numbers that can't be deleted. The only way to avoid them is to put contacts in the favourites tab
  2.    #2  
    Well I found out what the problem was. It doesn't like contacts on the sim card. So what I had to do, is store the contacts on the phone memory then merge them so it doesn't show a duplicate.

    As long as the contact is saved within the phone memory, it will be recognised. Oh and with the annoying Vodafone directory numbers stored the on the sime card, I just created a blank contact called "Vodafone" and merged all the numbers under there.
  3. #3  
    Thanks for updating to let us know!
  4. #4  
    I have the same problem as you. Is there a way to import contacts into phone memory?

Posting Permissions