Page 29 of 47 FirstFirst ... 192425262728293031323334 39 ... LastLast
Results 561 to 580 of 923
Like Tree236Likes
  1. #561  
    Quote Originally Posted by Jeff Marshall7 View Post
    As you can see, I tried to quote part of your previous post, and it appears here...but does show up as a quote. I'm doing something wrong. I'm still new in this forum...learning as I go along.
    Yes, I don't know half the code for this forum (It's called BBcode). When you click the reply button on a post (Not the 'Post Quick Reply' button at the bottom of the screen), their post will be quoted with a link to the original. You can see this code by clicking the 'Go Advanced' button below the input box. You can edit the text between those [QUOTE] tags if you want to only include the bit you're replying to and you can do it manually by placing [QUOTE] and [/QUOTE] around text.

    You can edit the text between those [QUOTE] tags if you want to only include the bit you're replying to and you can do it manually by placing [QUOTE] and [/QUOTE] around text.
    So if you want, you can now go back and edit your post!
    Last edited by Preemptive; 09/06/2015 at 10:52 AM.
    Jeff Marshall7 likes this.
  2. #562  
    Quote Originally Posted by Grabber5.0 View Post
    I'm going to refine it a bit and have a couple others test it before I release it into the wild.
    If you need guinea pigs, I'm using a Pre 2, that I Doctored to version 2.1 quite some time ago.
  3. #563  
    Finally got through all of the messages here since 8/20, after leaving my yellow triangle in place for the last few days.

    Tried the Wterm with the grabcerts.sh script and keep getting the following errors:
    line 1: bplist00_WebMainResourc: not found
    line 2: syntax error: unexpected redirection

    Running this from the /media/internal folder, making sure the file has a .sh extension.

    Not sure what I'm doing wrong here.

    UPDATE: found the issue. I had the wrong pasted text in the grabcerts.sh file. Re-pasted from the site and now the script runs great.
    Last edited by chillywillymm; 09/06/2015 at 11:02 AM.
    Palm Pilot Pro > Palm IIIx > Palm m515 > Treo 650 > Treo 755p > Palm Pre (Sprint) > TouchPad 32gb
  4. #564  
    Quote Originally Posted by Fred Zyphal View Post
    My brand new certs from Grabber were working this afternoon, now this evening, they are not.
    Just trying to keep score here ... the brand new certs that I got through Grabber's IPK worked fine yesterday afternoon, then they quit working last night, now they've decided to work again today. Same certs, I didn't update or change anything, they just decided to work again ... scratching my head here.

    Just a quick addendum here ... I do run "Preset Reset", every morning at 5:00am the little contraption resets itself. That may have something to do with why the certs were magically working again the next day. They've been working fine ever since.
    Last edited by Fred Zyphal; 09/07/2015 at 02:56 PM.
  5. #565  
    I'll just humbly repeat my suggestion that compared to the effort Grabber5.0 is making to increase the ease of use by enabling root access, the effort of adding user input should be fairly easy. Hopefully, by version 5.0 it will not just be a Google Cert Grabber, but a Universal one.
    I fully agree. I don't want to sound like I'm complaining...that's not my intention. I'm just trying to learn more about the true nature of these certificates. I'm just learning the basics. The actual process of generating a SHA256 function is far more complicated than anything I can comprehend. And of course, I do fully support the time consumed and mental dexterity provided by Grabber5.0.

    As you can see, I tried to quote part of your previous post, and it appears here...but does show up as a quote. I'm doing something wrong. I'm still new in this forum...learning as I go along.
  6. #566  
    OK, I'm starting to understand the quote concept...it's not very intuitive, but it does work. Maybe this forum should have an examples page for dummies like me.
  7. #567  
    Seems strange that the web browser gmail accepts the new certs and no triangles, but the IMAP gmail needs to be modified so that it will also accept the newest cert. But Google is the hub of the wheel here. It seems that most likely, the vast majority of gmail traffic is web based and NOT using the IMAP concept. So Google must have designed the web based gmail to always accept the latest cert with no problem. If that were not the case, there would be a huge problem for millions of gmail users running web gmail. I'm quite certain that the vast majority of gmail users are NOT motivated or knowledgeable to do what is being done here with WebOS and IMAP. Hence, Google has to be SURE that the web based gmail will run smoothly without a hitch.
    EDIT: I just realized that Google is NOT at fault, its our mail client running WebOS. Google does provide the latest cert, our Webos just doesn't automatically retrieve it.
    Last edited by Jeff Marshall7; 09/07/2015 at 07:49 AM.
  8. #568  
    As several times mentioned before, google is not the problem. It's our old mailclient.

    Google may be changing certs more often most other provider would do, but that is no problem with our webbrowser as there the certchain mechanism works. Only our mailclient seems to have a prob accepting newer SHA256 certs automagically. And also google can't do anything about accepting a cert, it's always the OS together with apps that decide what to accept.
  9. #569  
    Quote Originally Posted by gizmo21 View Post
    As several times mentioned before, google is not the problem. It's our old mail client.

    Yes, you are correct, I had to edit my previous post. When I look at my gmail using the web browser, that browser is the Google Chrome browser, and of course it is designed to recognize the newest cert.
    Last edited by Jeff Marshall7; 09/07/2015 at 08:09 AM.
  10. #570  
    The initial (basic) push-button version of the app is just about ready to go. It will download the certificate and open it in the certificate manager for you to trust. I ran into a big snafu trying to change the package id, so I have to fix that or I'd have shared it already. :/
  11. #571  
    Let me know when you need help. Palm-package takes the appId from appinfo.json.

    -- Sent from my TouchPad Go using Communities
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  12. #572  
    This package has the package id in at least 5 places, because of the app, package, and service files, and the scripts to enable root access. No explanation for it wouldn't work on the Touchpad with the new package id. I've compared and everything looks right. I will send you a copy, maybe you can see something I'm not seeing. For now I'm just going to publish it with the package id that works.
  13. #573  
    I made a copy of the working source folder and did a search/replace on the package id, which is basically the same thing I did the first time, except this time it worked as expected. I uploaded the ipk to my website and added it to the pivotCE feed, since the main precentral feed isn't getting updated right now for some reason. It's been tested on devices from 2.1 to 3.0.5. Here's a direct link until the feed gets refreshed: http://www.fordmaverick.com/GrabberS..._0.5.1_all.ipk

    There is more to do in terms of parsing the script output and presenting it in a nicer fashion, but it is the same output you'd see in wterm, just not formatted as nicely. It will pop open the imap certificate in the certificate manager after a successful download. I did confirm it reports errors from the script properly, which I wasn't 100% certain it would do before testing it, so *yay!*

    Edit: it seems there may still be issues on the Touchpad. Though none of my devices have had an issue with the new package, I have had one report of the same error I was seeing. I'm not sure if the problem is something happening during install (which I suspect, due to something I saw) or execution of the service. Report any issues here and I'll keep looking into the cause.
    Last edited by Grabber5.0; 09/07/2015 at 09:56 PM.
  14. bbjoe41's Avatar
    Posts
    26 Posts
    Global Posts
    32 Global Posts
    #574  
    Quote Originally Posted by Grabber5.0 View Post
    I made a copy of the working source folder and did a search/replace on the package id, which is basically the same thing I did the first time, except this time it worked as expected. I uploaded the ipk to my website and added it to the pivotCE feed, since the main precentral feed isn't getting updated right now for some reason. It's been tested on devices from 2.1 to 3.0.5. Here's a direct link until the feed gets refreshed: http://www.fordmaverick.com/GrabberS..._0.5.1_all.ipk

    There is more to do in terms of parsing the script output and presenting it in a nicer fashion, but it is the same output you'd see in wterm, just not formatted as nicely. It will pop open the imap certificate in the certificate manager after a successful download. I did confirm it reports errors from the script properly, which I wasn't 100% certain it would do before testing it, so *yay!*
    i tested on my friends palm pre & it seems to work it downloaded the certs & opened the cert manager.
    i wasnt able to actually install the certs becuase his cert manager is broken so i had to use the trick from another thread here
  15. #575  
    Quote Originally Posted by Grabber5.0 View Post
    I uploaded the ipk to my website and added it to the pivotCE feed, since the main precentral feed isn't getting updated right now for some reason.
    I couldn't find it through the Preware app with the pivotCE feed enabled, so I got it from your direct link ... but it seems to work perfectly on my Pre 2 with v.2.1

    Thank you so much for this.
  16. #576  
    Quote Originally Posted by Preemtive View Post
    I've no idea when LuneOS will be 'ready for action', but hopefully it will be before an issue occurs with webOS that will be too difficult to fix or work around. For those who wish to continue using webOS in the future, LuneOs is currently the only option and in many ways is already better with more features.
    Why do you feel that LuneOS would be the way to go? I hate to think of dumping Webos on my Touchpad. It has all the features that I like. The email app is great the way it presents the messages on the screen. And one feature the I REALLY LIKE, is that it will create an audible alarm sound whenever a new incoming message arrives. Can LuneOS do all that too? My understanding is that LuneOS is still in the development phase.
  17. #577  
    Off Topic, but...
    Quote Originally Posted by Jeff Marshall7 View Post
    My understanding is that LuneOS is still in the development phase.
    It IS under development and not yet ready. However, those supporting legacy might be counted in single figures and are likely to migrate to LuneOS. webOS has been a zombie for years. The end may be staved off for a few years more, but will inevitably come.

    Here is an article: LuneOS Cafe Cubano: An In-Depth Look | pivotCE It discusses the history and therefore the clear similarities, despite the underlying upgrades. Here's the forum: LuneOS - webOS Nation Forums

    Now back to certificates!
  18. #578  
    There's definitely too much off-topic chatter in this thread, even about SSL and certificates. We've got a working solution, so let's focus on that.
    Preemptive, bbjoe41 and petbull like this.
  19. #579  
    Quote Originally Posted by Grabber5.0 View Post
    There's definitely too much off-topic chatter in this thread, even about SSL and certificates. We've got a working solution, so let's focus on that.
    Agreed. I have wandered of the road here, but I'm just trying to fit all the pieces together. I did install your earlier .ipk and thus far, it has worked out very well. It seems the focus is now on the so called one button fix for all the devices. Which is a good thing.
  20. #580  
    Quote Originally Posted by Grabber5.0 View Post
    I made a copy of the working source folder and did a search/replace on the package id, which is basically the same thing I did the first time, except this time it worked as expected. I uploaded the ipk to my website and added it to the pivotCE feed, since the main precentral feed isn't getting updated right now for some reason. It's been tested on devices from 2.1 to 3.0.5. Here's a direct link until the feed gets refreshed: http://www.fordmaverick.com/GrabberS..._0.5.1_all.ipk

    There is more to do in terms of parsing the script output and presenting it in a nicer fashion, but it is the same output you'd see in wterm, just not formatted as nicely. It will pop open the imap certificate in the certificate manager after a successful download. I did confirm it reports errors from the script properly, which I wasn't 100% certain it would do before testing it, so *yay!*

    Edit: it seems there may still be issues on the Touchpad. Though none of my devices have had an issue with the new package, I have had one report of the same error I was seeing. I'm not sure if the problem is something happening during install (which I suspect, due to something I saw) or execution of the service. Report any issues here and I'll keep looking into the cause.
    I couldn't find your new app on preware but after downloading the ipk, unfortunately doesn't work on my touchpad. It says file not found even though it's in the right path. Also, for some strange reason, only new unread emails appears in my inbox. All read email and sent email are not showing up in the mail client anymore. Does this have something to do with the certs or is this yet another problem with the email client? Was working fine last week.
    Attached Images Attached Images
    Last edited by synchron; 09/08/2015 at 04:54 PM.

Similar Threads

  1. Replies: 23
    Last Post: 09/04/2015, 11:51 AM
  2. "Requested encryption not supported by server"
    By freebirds in forum webOS Tips, Info & Resources
    Replies: 14
    Last Post: 02/28/2015, 07:33 AM
  3. Replies: 3
    Last Post: 11/10/2014, 04:31 AM
  4. CM9 Encryption Unsuccessful Touchpad Error
    By JackisBack in forum Android on webOS
    Replies: 6
    Last Post: 08/04/2012, 11:51 AM
  5. Can not access 128 encryption server (sercurity) error code 18
    By quedawg in forum Palm OS Devices & Apps
    Replies: 0
    Last Post: 02/06/2005, 02:16 PM

Posting Permissions