Results 1 to 2 of 2
  1.    #1  
    Hello All,

    I have a 32 GB which I bought under a year ago. Like so many others, a few months ago, it developed those dreaded cracks; but mine is not by the speaker, it is by the charge port, front and back. I have not used the TP much over the past 6 months, but when I picked it up last week to charge it, it worked fine.

    Now, even after attempting to charge it overnight, it has not charged a lick. I have switched outlets and changed cables, as well. When I first plug it in, for a long time, I get that dashing light under the home button, and then after about 5 minutes the charging icon.

    I had thought it probably was not worth sending it back over the cracks, but now this. What do you all think?

    Thanks
  2. #2  
    Quote Originally Posted by Touchkeeper View Post
    Hello All,

    I have a 32 GB which I bought under a year ago. Like so many others, a few months ago, it developed those dreaded cracks; but mine is not by the speaker, it is by the charge port, front and back. I have not used the TP much over the past 6 months, but when I picked it up last week to charge it, it worked fine.

    Now, even after attempting to charge it overnight, it has not charged a lick. I have switched outlets and changed cables, as well. When I first plug it in, for a long time, I get that dashing light under the home button, and then after about 5 minutes the charging icon.

    I had thought it probably was not worth sending it back over the cracks, but now this. What do you all think?

    Thanks
    Try inserting the charging plug into the TouchPad firmly and hold it in until you see the "charging battery" message, then let go. I have to do that to mine, otherwise the connection is not good enough to charge, and I get the charging error. Good luck.

Posting Permissions