Results 1 to 11 of 11
  1.    #1  
    I have three TPs. One has CyanogenMod loaded as well. The other two work fine. The one with Android will connect to wi-fi OK, but will not connect to the Internet, in either CyanogenMod or WebOS. It always seemed a little flakey on Internet connection, but only recently has refused to connect to the Internet at all, even though it is connecting to my wireless router.
    I found lots of "No Internet Connection" threads, but didn't see one that resembled this.
  2. #2  
    My new standard answer is to change your wireless channel to 2 and leave your TP right next to a router (preferably open and connectable) overnight. The wireless hardware in the TP isn't top notch, but in the majority of cases should be able to connect. What security configuration are you using.

    @bradow: Please try to be constructive and help solve the problem. I find the browser usable except for mobile apps (which I rarely use). If you don't like your TP, go sell it on eBay and you'll be able to get your desired device faster.
  3. B/B
    B/B is offline
    B/B's Avatar
    Posts
    11 Posts
    #3  
    I have a linksys cm100 modem along with a cisco linksys e1500 using stock firmware, wpa2and set to channel 3 I went a distance of about forty feet from my router inside a shed built with cinder blocks and still had a connection. I am using webOS 3.0.5 with stock browser.
    Last edited by B/B; 08/08/2012 at 02:56 PM.
  4.    #4  
    Quote Originally Posted by GMMan View Post
    My new standard answer is to change your wireless channel to 2 and leave your TP right next to a router (preferably open and connectable) overnight. The wireless hardware in the TP isn't top notch, but in the majority of cases should be able to connect. What security configuration are you using.
    OK, I don't want this to stray, so back to my original problem. I tried letting it "cook" overnight on a channel 2 Open connection. It's no different from Channel 3 WPA2 -- wi-fi connection, but no Internet connection.

    So, just for kicks I decided to see what would happen if I tried to connect using a wi-fi connection to FreeTether on my Veer. WahLah!! It connected to the Internet right away. Curiouser and curiouser.
  5. #5  
    Quote Originally Posted by rthomson View Post
    OK, I don't want this to stray, so back to my original problem. I tried letting it "cook" overnight on a channel 2 Open connection. It's no different from Channel 3 WPA2 -- wi-fi connection, but no Internet connection.

    So, just for kicks I decided to see what would happen if I tried to connect using a wi-fi connection to FreeTether on my Veer. WahLah!! It connected to the Internet right away. Curiouser and curiouser.
    Interesting. Could you check the Wi-Fi settings on your TP? Go into the Wi-Fi app and tap on your currently connected AP. It should show you your IP address, subnet mask, and DNS info. Next, log in to your router and check if your device is connected to the network. At this point, also compare the IP address and subnet mask to what is displayed from the router and see if they match.

    Another thing you can try is to override the DNS. I don't remember if you have to turn off auto configuration before you're allowed to change it, but use 8.8.8.8 as primary DNS and 8.8.4.4 as secondary. Those are the addresses to Google DNS, so they should work at any time.
  6. B/B
    B/B is offline
    B/B's Avatar
    Posts
    11 Posts
    #6  
    You could also try and purchase a new router. lol
    I had similar problems. I purchased a refurbished linksys cisco e1500 from amazon for about twenty six dollars and haven't had any problems since. BTW router looked new.
    Last edited by B/B; 08/09/2012 at 06:26 PM.
  7. #7  
    Quote Originally Posted by B/B View Post
    You could also try and purchase a new router. lol
    I had similar problems. I purchased a refurbished linksys cisco e1500 from amazon for about twenty six dollars and haven't had any problems since. BTW router looked new.
    Talking about routers, you may want to put DD-WRT on yours if you're adventurous. While I haven't used all the options, there's enough for you to tweak however you like.
  8. B/B
    B/B is offline
    B/B's Avatar
    Posts
    11 Posts
    #8  
    Quote Originally Posted by GMMan View Post
    Talking about routers, you may want to put DD-WRT on yours if you're adventurous. While I haven't used all the options, there's enough for you to tweak however you like.
    Thanks GMMan for the info might try it.
  9.    #9  
    Quote Originally Posted by GMMan View Post
    Interesting. Could you check the Wi-Fi settings on your TP? Go into the Wi-Fi app and tap on your currently connected AP. It should show you your IP address, subnet mask, and DNS info. Next, log in to your router and check if your device is connected to the network. At this point, also compare the IP address and subnet mask to what is displayed from the router and see if they match.

    Another thing you can try is to override the DNS. I don't remember if you have to turn off auto configuration before you're allowed to change it, but use 8.8.8.8 as primary DNS and 8.8.4.4 as secondary. Those are the addresses to Google DNS, so they should work at any time.
    The non-working TP has a 172.27.0.x address, with 172.27.0.1 as the gateway and DNS server. I may be wrong, but I think that's typically the default address a device uses when it doesn't accept a dynamic IP address assignment. One of the working TPs has a 192.168.22.x address, with 192.168.22.254 as the gateway. 192.168.22.254 is the the correct router address on my wired LAN, so I assume that the "bad" TP is not accepting a Dynamic address from the router. I tried using a fixed address in the 192.168.22.x subnet, but that didn't work either. I still get the "No Internet Connection" error.

    Another item of interest. I had the opportunity tonight to use the "bad" TP on an entirely different encrypted wireless network, and it worked OK. It's beginning to look like a compatibility problem between this particular TP (since two others work) and my local wireless router, which is a Netgear WNDR3400.
  10. #10  
    Remember to update your subnet mask and gateway as well.
    You may want to try factory-resetting your router and see if it will connect then. Export your settings, then do the 20/20/20 reset.
  11. coyzer's Avatar
    Posts
    8 Posts
    Global Posts
    18 Global Posts
    #11  
    In case it is of use to anyone, I've recently been having trouble connecting to my wifi on a BT Homehub3. I reset the wifi channel to channel 2 and both my Pre3 and Touchpad connected immediately and flawlessly :-) Go figure !

    Thanks GMMAN

Posting Permissions