Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 78
Like Tree14Likes
  1. filmor_'s Avatar
    Posts
    222 Posts
    Global Posts
    223 Global Posts
    #21  
    Quote Originally Posted by jm2011 View Post
    Hi,
    I tried installing the diff (post #5), but I got an error when installing, and I realised that I need to apply it directly to lunasysmgr(usr/bin/lunasysmgr), however I have no idea how to do this, so could someone please help me out here.
    You seem to have a deep-lying misunderstanding here. The patch has to be applied to the /sources/ of LunaSysMgr which then has to be compiled and replace the installed one. I'd suggest you wait until someone builds an ipkg for that
    sledge007 likes this.
  2. #22  
    Quote Originally Posted by jm2011 View Post
    Hi,
    I tried installing the diff (post #5), but I got an error when installing, and I realised that I need to apply it directly to lunasysmgr(usr/bin/lunasysmgr), however I have no idea how to do this, so could someone please help me out here.

    Thanks.
    You might want to wait until there's an official build available that includes this You can't just patch the LunaSysMgr, you'd need to pick up the woce git-hub source tree, patch it, build it, then replace the existing lunasysmgr. Not something i'd mess with if you don't know what you're doing there.
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  3. #23  
    you can use webOS quickinstall to load code directly to the Luna sys manager TPad
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
    tharrison4815 likes this.
  4. #24  
    I finished the build and now I have Luna SysManager but how do I transfer it to my TouchPad?
  5. #25  
    thanks for clearing that up for me (telling me how wrong I was). I guess I'll just wait for the easily installable build that will come soon (hopefully).
    Touchpad 16GB 3.0.5
    Pre 2 2.2.4
  6. #26  
    When i try to install the binaries to my TouchPad it says "bad or error response from other side: File unopened"
  7. #27  
    @eblade,

    I built a LynaSysMgr with you patches. It works fine, except it seems to have killed xecutah on my touchpad.

    Xecutah no longer is able to start either in xterm or ubuntu chroot. So, I built another non-patched LunaSysMgr and my xecutah still doesn't work. I guess I'll have to find the one from 3.0.5 doctor and install it to see if that fixes it. Can you confirm if xecutah works on your touchpad with patched LunaSysMgr?

    thanks

    I can indeed confirm that when I extracted the original 3.0.5 LunaSysMgr, that xecutah works again. There are differences between the old LunaSysMgr and the woce version!! It may break other things as well, so If you install the woce version be warned!!! I know that my xecutah is broken on the woce version !!!!!!!!!!!!
    Last edited by creepingmee; 06/29/2012 at 06:01 PM.
  8. #28  
    Quote Originally Posted by zacky59 View Post
    When i try to install the binaries to my TouchPad it says "bad or error response from other side: File unopened"
    When I got that error, I did a complete restart on my touchpad and tried again and it worked fine.
  9. #29  
    Quote Originally Posted by creepingmee View Post
    When I got that error, I did a complete restart on my touchpad and tried again and it worked fine.
    Not sure if it's the cause of the error, but you have to stop Luna before transferring and then start it again afterward.

    Quote Originally Posted by creepingmee View Post
    I can indeed confirm that when I extracted the original 3.0.5 LunaSysMgr, that xecutah works again. There are differences between the old LunaSysMgr and the woce version!! It may break other things as well, so If you install the woce version be warned!!! I know that my xecutah is broken on the woce version !!!!!!!!!!!!
    Mine feels/behaves a little differently with the WOCE Luna too- the address bar in the browser clears when tapped instead of inconsistently highlighting or placing the cursor in pre-WOCE. The launcher also feels a little smoother, but that may be a placebo.
    webOS Ports' UI Architect & luna-sysmgr guru.
  10. #30  
    Quote Originally Posted by ShiftyAxel View Post



    Mine feels/behaves a little differently with the WOCE Luna too- the address bar in the browser clears when tapped instead of inconsistently highlighting or placing the cursor in pre-WOCE. The launcher also feels a little smoother, but that may be a placebo.
    I confirm the same odd nuking the address bar in the browser as well, can you confirm xecutah not being able to launch xterm ?



    -- Sent from my Palm Pre3 using Forums
  11. #31  
    Quote Originally Posted by creepingmee View Post
    I confirm the same odd nuking the address bar in the browser as well, can you confirm xecutah not being able to launch xterm ?



    -- Sent from my Palm Pre3 using Forums
    Xecutah launches a black window, which then proceeds to behave very oddly and launch a zombie card that never loads. Confirmed broken, I think.

    Personally I prefer the nuking behaviour- the inconsistent 'will-it-highlight-or-will-it-put-the-cursor-where-i-tapped' behaviour was making address input irritating. I swear the touchpad feels more responsive in general with WOCE, but that might just be in comparison to the slightly lacking performance under 2.2.4 on my Pre3.
    webOS Ports' UI Architect & luna-sysmgr guru.
  12. #32  
    I'm about 99.9999% sure that my patch has nothing to do with that, so it's quite probably some sort of differences between the original and the open source version. I do not use Xecutah for anything, don't think I even have it installed on either of my touchpads at this point. I'll see if I can check it out on my dev pad, though.

    I do see that the browser does seem to clear the input box excessively. Go to Google, tap in the page, then tap on the address, and it clears. Go to Google, tap in the input box on Google, then tap the address, and it doesn't. Any other apps with weird input things? perhaps it's exposing a bug in the browser app somehow ..
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  13. #33  
    Quote Originally Posted by eblade View Post
    I'm about 99.9999% sure that my patch has nothing to do with that, so it's quite probably some sort of differences between the original and the open source version. I do not use Xecutah for anything, don't think I even have it installed on either of my touchpads at this point. I'll see if I can check it out on my dev pad, though.

    I do see that the browser does seem to clear the input box excessively. Go to Google, tap in the page, then tap on the address, and it clears. Go to Google, tap in the input box on Google, then tap the address, and it doesn't. Any other apps with weird input things? perhaps it's exposing a bug in the browser app somehow ..
    Agreed, I have the same behaviour on an unpatched WOCE. Plus it doesn't touch anything that I can imagine would break Xecutah, even by a far stretch.
    Hmm, it could be a bug. It struck me as possibly being intended functionality, but if it acts inconsistently after using google's input box then it sounds similar to the pre-WOCE inconsistency.
    webOS Ports' UI Architect & luna-sysmgr guru.
  14. #34  
    Quote Originally Posted by eblade View Post
    I'm about 99.9999% sure that my patch has nothing to do with that, so it's quite probably some sort of differences between the original and the open source version. I do not use Xecutah for anything, don't think I even have it installed on either of my touchpads at this point. I'll see if I can check it out on my dev pad, though.

    I do see that the browser does seem to clear the input box excessively. Go to Google, tap in the page, then tap on the address, and it clears. Go to Google, tap in the input box on Google, then tap the address, and it doesn't. Any other apps with weird input things? perhaps it's exposing a bug in the browser app somehow ..
    I can confirm it has nothing to do with your patch, I built one without your patch, and still has same problem no xecutah

    -- Sent from my Palm Pre3 using Forums
  15. #35  
    I was able to start Xecutah here, although it acts weird -- no VKB (or do I have to turn that on in Tweaks? i don't recall), an extra card is flashing here, and when I put the Xterm into card view and then maximize it, it shows the Xecutah window with a giant "PLAY" button like Flash's over it, until I tap it, then I can see the Xterm again. I haven't tried any other X things.
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  16. #36  
    I am still getting the error "bad or error response from other side: 'file open failed'" can anyone help me please.
  17. #37  
    Quote Originally Posted by eblade View Post
    I was able to start Xecutah here, although it acts weird -- no VKB (or do I have to turn that on in Tweaks? i don't recall), an extra card is flashing here, and when I put the Xterm into card view and then maximize it, it shows the Xecutah window with a giant "PLAY" button like Flash's over it, until I tap it, then I can see the Xterm again. I haven't tried any other X things.
    you actually can use the xterm? I get a blank xterm but it doesn't actually work...
    the rest of it is the same, I don't use a virtual keyboard, I use bluetooth in xecutah.
  18. #38  
    Couldn't say for sure, I don't know how to get the keyboard up, and I don't know where my Bluetooth is at the moment o.O
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  19. #39  
    Quote Originally Posted by eblade View Post
    Couldn't say for sure, I don't know how to get the keyboard up, and I don't know where my Bluetooth is at the moment o.O
    You do need Tweaks.

    Baldric

    -- Sent from my Palm Pre3 using Forums
  20. #40  
    Quote Originally Posted by zacky59 View Post
    I am still getting the error "bad or error response from other side: 'file open failed'" can anyone help me please.
    The file system is mounted "read only".

    If I novaterm'ed into the device and ran:

    mount -o remount,rw /

    I was able to put the file on the system.
Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions