Results 1 to 15 of 15
  1. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    937 Global Posts
       #1  
    Ever since going from my old Pre to the Pre3 I havent been able to send mail from my personal account since it wont validate the server settings. There is nothing wrong with the settings, they work on my computers.

    I noticed the Touchpad have the same problem but it gives a more detailed error message than the Pre3. Still not clear what is wrong but if someone please could suggest if I can log this even better I would be happy. Or should this be enough to start a ticket with support?

    Treo 180 270 600 650 Centro Pre Pr3 tPad tPad4G
  2. #2  
    My work firewall is blocking that screenie so going to jump into suggestions.

    Have you tried manually setting up the mail account? Whats the mail provider?
    Try diplomacy first. You can always conquer them later...

    www.webos-internals.org, read it, use it, love it, and donate to it.....
  3. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    937 Global Posts
       #3  
    Quote Originally Posted by addiarmadar View Post
    My work firewall is blocking that screenie so going to jump into suggestions.

    Have you tried manually setting up the mail account? Whats the mail provider?


    Im trying to setup SSL encryption with outgoing port 465 but it wont validate and generates this error message:

    Error code 9820: Non-specific SSL protocol error -- src/network/SocketConnection.cpp:184

    I got help before that looked up how the server (mailout.telia.com) responded and its nothing wrong with it.

    Its Swedens largest ISP, been using them for years and it works fine on all my computers and my old Pre (not to mention the settings also works for a million or more other users). But both the Pre3 and Touchpad fail.

    Would be so nice if it could be sorted so I could buy my parents a Touchpad too but right now its useless to them without working mail.
    Treo 180 270 600 650 Centro Pre Pr3 tPad tPad4G
  4. #4  
    I had the same issue with my godaddy account. I had to remove the account, then manually add it back everytime I set up a new device.
  5. #5  
    In your screenshot the username is blank. Did you try entering a username, or turning off "use authentication"?
  6. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    937 Global Posts
       #6  
    I tried to delete the account but it wont validate the settings. I installed Lumberjack to check the logs and this is it:


    [2012-02-21 23:48:48] (mojomail-smtp) user.err: psl_err_process_and_purge_openssl_err_stack (client=0x2c01e400): ERROR from openssl error-stack (raw) 336032784 (0x14077410); lib=20, func=119, reason=1040 (error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure)

    [2012-02-21 23:48:48] (mojomail-smtp) user.err: ConnectFailure.

    [2012-02-21 23:48:48] (LunaSysMgr) user.notice: com.palm.app.email: : Wizard: SMTP port=465 (ssl) validate error 9820, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : Wizard: POP port=110 (none) validate success, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : Wizard: Got all responses or the best result, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : Wizard: clearing wizard timeout, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : inbound validated? true, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : outbound validated? false, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : Wizard: returnWizardResultToUser. requests outstanding=___ 0, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : OOPS. No successful results., file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: : Wizard: inbound=___ outbound= ___ 0 9820, file:///media/cryptofs/apps/usr/palm...Wizard.js:1605

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: we have our worst result:, file:///media/cryptofs/apps/usr/palm...tWizard.js:437

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: ----------- CreateAssistant createError error=Non-specific SSL protcol error -- src/network/SocketConnection.cpp:184, file:///media/cryptofs/apps/usr/palm...lConfig.js:523

    [2012-02-21 23:48:49] (LunaSysMgr) user.notice: com.palm.app.email: inbound settings worked....prompt user to create account anyway., file:///media/cryptofs/apps/usr/palm...lConfig.js:533

    [2012-02-21 23:49:01] (mojodb-luna[1779]) user.err: [core.messageService] db: kind not specified (-3969) - sender='com.palm.smtp' method='merge' payload='{"objects":[{"_id":"++HsoWRbZc7Z6QZa","smtpRetryDelay":30}]}'
    Last edited by Andreas; 02/21/2012 at 06:25 PM.
    Treo 180 270 600 650 Centro Pre Pr3 tPad tPad4G
  7. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    937 Global Posts
       #7  
    Quote Originally Posted by greenoyster View Post
    In your screenshot the username is blank. Did you try entering a username, or turning off "use authentication"?
    I did as you suggested in my old Pre3 thread and installed Lumberjack, not sure how much to post but pasted email releated.

    Username is just blanked by Photoshop

    I think I have tried most combinations but the only one that used to work was turning off all encryption and using port 25 but that stopped working so I tried entering the proper settings and noticed they still generated a validation error.
    Treo 180 270 600 650 Centro Pre Pr3 tPad tPad4G
  8. #8  
    Okay, I did some investigating, and it looks like the problem is that for some reason webOS doesn't support the RC4-MD5 cipher for encrypted SSL connections for SMTP. Telia's SMTP server, unlike most SSL servers, *only* supports RC4-MD5.

    So short answer is that unfortunately you probably won't be able to get it to work on your own. You'd need to get either HP or Telia to fix it. Probably HP should fix it since RC4-MD5 is widely used.
    Last edited by greenoyster; 02/21/2012 at 10:32 PM.
  9. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    937 Global Posts
       #9  
    Quote Originally Posted by greenoyster View Post
    Okay, I did some investigating, and it looks like the problem is that for some reason webOS doesn't support the RC4-MD5 cipher for encrypted SSL connections for SMTP. Telia's SMTP server, unlike most SSL servers, *only* supports RC4-MD5.

    So short answer is that unfortunately you probably won't be able to get it to work on your own. You'd need to get either HP or Telia to fix it. Probably HP should fix it since RC4-MD5 is widely used.
    Many thanks for that info.

    Since it works on my Pre it means that webOS 1.4.5 support this but not 2.x and 3.x, very strange that support was removed?
  10. #10  
    Quote Originally Posted by Andreas View Post
    Many thanks for that info.

    Since it works on my Pre it means that webOS 1.4.5 support this but not 2.x and 3.x, very strange that support was removed?
    The Email app was SIGNIFICANTLY changed from webos 1 to 2/3 so this is possible.

    Could like that mail account to a gmail account to get around this.
    Try diplomacy first. You can always conquer them later...

    www.webos-internals.org, read it, use it, love it, and donate to it.....
  11. #11  
    Quote Originally Posted by greenoyster View Post
    Okay, I did some investigating, and it looks like the problem is that for some reason webOS doesn't support the RC4-MD5 cipher for encrypted SSL connections for SMTP. Telia's SMTP server, unlike most SSL servers, *only* supports RC4-MD5.
    You are probably right in the diagnosis of your SSL connection problem, but I had almost identical error messages, and my problem was a little different.

    I was trying to set up an e-mail account with fastmail, and was seeing the same errors that led me to this thread. The solution, after much digging around, was to get their SHA-256 SSL certificate by pointing a Web browser at an https server that was using the same certificate as the IMAP server. I was lucky in that my provider was using the same SSL cert both for IMAP SSL and for providing SSL for their carddav implementation.

    I accesed the SSL certificate via my browser, saved it to my hard-drive, and e-mailed it to myself on my phone and touchpad. From there I installed it in my certificate manager as "trusted"

    Then I was able to log in.

    Just mentioning this because someone else might come here and conclude the issue must be the cipher support, but the issue could also be that you need to install the SSL certificate or root certificate of your e-mail provider and mark it as trusted.

    The log/error message is virtually identical in both cases, so either the cipher or the lack of trusted cert could be an issue here.
  12. #12  
    Sound like you might benefit from looking at similar threads:
    How to manually retrieve SSL certificates for import and usage in Email setup
  13. #13  
    Quote Originally Posted by cerenoc View Post
    Sound like you might benefit from looking at similar threads:
    How to manually retrieve SSL certificates for import and usage in Email setup
    Thank you. I didn't know you could use openssl to retrieve certs. That's going in my toolkit. Thanks again.
  14. #14  
    Here’s the mail I got recently for my problem
    Disable QUIC Protocol
    in URL write "chrome://flags/#enable-quic Protocol" and hit Enter,
    if will be selected as Default, now click on that drop-down and select Disabled,
    now click on Relaunch in bottom.

    2) Update the system Time
    3) Disable unknown or unused extensions
    4) Check if there is restrictions on Firewall or not.

    If you error is still not solved, or getting other SSL error please visit <ERR_SSL_PROTOCOL_ERROR – Fix by deskdecode>
  15. #15  
    Here’s the mail I got recently for my problem
    Disable QUIC Protocol
    in URL write "chrome://flags/#enable-quic Protocol" and hit Enter,
    if will be selected as Default, now click on that drop-down and select Disabled,
    now click on Relaunch in bottom.

    2) Update the system Time
    3) Disable unknown or unused extensions
    4) Check if there is restrictions on Firewall or not.

    If you error is still not solved, or getting other SSL error please visit <ERR_SSL_PROTOCOL_ERROR – Fix by deskdecode>

Posting Permissions