Results 1 to 7 of 7
  1. ac921ol's Avatar
    Posts
    151 Posts
    Global Posts
    155 Global Posts
       #1  
    Issue with the TP
    I put the TP on the touchstone charger, went to grab it the following day and it wasnt charged, I havent put it back on the charger since then, obviously it could have slipped which it might have and that is why it did not charge, but will check when I get home later today.


    Here is my warranty issue tho
    I bought the touchpad at Hhgregg, I'm not sure if i Still have the receipt, so whats my next plan of action?? I believe warranty on the TP was 1 year. Cant anyone confirm this??

    also has anyone been able to return the touchpad to HP without proof of purchase?? I plan on calling hhgregg and seeing if i am in there system for purchasing one.

    ( I think I used cash to purchase the touchpad, but will be looking in to that as well.)
  2. #2  
    HP is honoring all of the one year warranties on the Touchpad. Contact them and let us know how it goes. I just got mine brand new on the 23rd of Jan and have no issues but I'm curious to see how your warranty claim will be handled.
  3. ac921ol's Avatar
    Posts
    151 Posts
    Global Posts
    155 Global Posts
       #3  
    Quote Originally Posted by Babyrocko1908 View Post
    HP is honoring all of the one year warranties on the Touchpad. Contact them and let us know how it goes. I just got mine brand new on the 23rd of Jan and have no issues but I'm curious to see how your warranty claim will be handled.
    Well a friend of mine is doing it before me, I still need to check and make sure mine is 110% crapped out. He was on the phone with HP Tech Support, and they told him a few ways to reset it and try charging it, none worked so they are sending him a box to ship it in and then they will try and fix it and send it 2nd day air back to him.

    one more issue is, he had preware installed on his TP. has anyone done a claim with Preware installed?? what was the outcome??
  4. #4  
    If it has stopped charging, try to reassemble the plug on the ac adapter. Sometimes it can get loose just enough to stop the flow of sufficient juice to the device.
    Try diplomacy first. You can always conquer them later...

    www.webos-internals.org, read it, use it, love it, and donate to it.....
  5. ac921ol's Avatar
    Posts
    151 Posts
    Global Posts
    155 Global Posts
       #5  
    Quote Originally Posted by addiarmadar View Post
    If it has stopped charging, try to reassemble the plug on the ac adapter. Sometimes it can get loose just enough to stop the flow of sufficient juice to the device.
    it was on my touchstone, when it didnt charge, but I will tell my friend that, who doesnt have a touchstone and just uses the USB.
  6. #6  
    Quote Originally Posted by ac921ol View Post
    it was on my touchstone, when it didnt charge, but I will tell my friend that, who doesnt have a touchstone and just uses the USB.
    The touchstone uses the same ac adapter that has a detachable plug for international travels. Take the head off it and put in back on, make sure you feel the click.
    Try diplomacy first. You can always conquer them later...

    www.webos-internals.org, read it, use it, love it, and donate to it.....
  7. #7  
    I had a touchstone problem once, it resolved itself after I plugged it back hardwired to the ac adapter. I am unsure what happened or why it was resolved. I do know that my touchstone only charges in 2 directons, portrait with the USB down and landscape with the speakers down.

    I sent mine back, I had Preware installed. They don't care, but, when you send it back you do a complete secure erase anyway. Why would you send your TP back with your confidential information?

    You should be fine.

Posting Permissions