webOS Nation Forums >  webOS Devices >  HP TouchPad > TP needs daily re-boot
TP needs daily re-boot
  Reply
Like Tree12Likes

 
Thread Tools Display Modes
Old 10/24/2012, 12:51 AM   #61 (permalink)
pivotCE Developer
 
Posts: 2,191
Quote:
Originally Posted by GMMan View Post
Actually, the TP version could work on 2.2.4. I just checked the Berkeley DB version on the emulator, and it's version 4.8.x. The compiler toolchain is old enough that it's likely the same libraries are used for all webOS builds. The tool should work, based purely on DB library version and toolchain age. (I remember PDK apps will work for any older webOS devices as long as the app was designed for that device.)
well at least running uppercase V for version
db_recover -V
gives me a Berkley DB 4.8.26 on Pre2 2.2.4

Using this tool could have quite some consequences, is there a dry run option (check it first) or shouldn't there at least be made a copy of the dbs before doing so. Apart from don't do this if your device is OK
__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?
gizmo21 is online now   Reply With Quote
Old 10/29/2012, 04:05 PM   #62 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
I tested with a copy of my DB copied to the media partition, and it didn't return any errors. Then again, I don't have a corrupted database, so I can't tell if anything's happening.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 11/03/2012, 05:54 AM   #63 (permalink)
Member
 
Posts: 45
I gave up on it, I'm teaching my mother to use android for it instead. I'll leave webos as it is, though, in case some form of solution is found. I don't really want to doctor it for now as maybe others would gain from the problem.
tannim is offline   Reply With Quote
Old 11/03/2012, 03:27 PM   #64 (permalink)
Member
 
Posts: 129
I tried the before mentioned database check. It came back with no error. However it did nothing for the issue. Still have to reboot almost daily. Sucks. Does anyone/everyone having this problem also have android dual boot on your tp? Just trying to narrow down what may be causing this problem. I have dual boot and had it a while before this issue came up.
dballew is offline   Reply With Quote
Old 11/03/2012, 04:52 PM   #65 (permalink)
Member
 
Posts: 45
My mother's touchpad problem happened before I put android on it.
tannim is offline   Reply With Quote
Old 11/03/2012, 07:39 PM   #66 (permalink)
Member
 
Posts: 1
Doctored my mom's Touchpad. So far it seems to work. She had the same problem.
Wh1temage is offline   Reply With Quote
Old 11/03/2012, 08:07 PM   #67 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Looks like we're back to square one. Can anyone post logs?
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 11/04/2012, 03:04 PM   #68 (permalink)
Member
 
Posts: 6
Quote:
Originally Posted by dballew View Post
I tried the before mentioned database check. It came back with no error. However it did nothing for the issue. Still have to reboot almost daily. Sucks. Does anyone/everyone having this problem also have android dual boot on your tp? Just trying to narrow down what may be causing this problem. I have dual boot and had it a while before this issue came up.
No Android on the Tablet. Vanilia WEB-os with no pre-ware installed. for some unknown reason, I haven't had to reboot for the last 4 days. Have made no changes or loaded any software.
theronco is offline   Reply With Quote
Old 11/05/2012, 09:59 AM   #69 (permalink)
Member
 
Posts: 129
So I guess we can rule out dual boot as being an issue. Onward we go.
dballew is offline   Reply With Quote
Old 11/05/2012, 08:07 PM   #70 (permalink)
Member
 
Posts: 45
For posting logs, it'd be handy to say (or give links) to which programs need to be ran to gather the logs/data and what logs/data needs to be gathered.
tannim is offline   Reply With Quote
Old 11/06/2012, 03:01 AM   #71 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Quote:
Originally Posted by tannim View Post
For posting logs, it'd be handy to say (or give links) to which programs need to be ran to gather the logs/data and what logs/data needs to be gathered.
I suppose you don't read signatures? There's a link there.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 11/06/2012, 04:54 AM   #72 (permalink)
Member
 
Posts: 10
Quote:
Originally Posted by dballew View Post
So I guess we can rule out dual boot as being an issue. Onward we go.
My temporary workaround is to use Reboot Scheduler from Preware and set it for 0400 in the morning. At least I can access email etc. straight away.
I still have a 2nd problem - at times, when in a browser the content part of the screen, below the black header, turns white. It takes a tap of the screen to restore the information.
jr92811 is offline   Reply With Quote
Old 11/16/2012, 05:51 PM   #73 (permalink)
Member
 
Posts: 16
Quote:
Originally Posted by jr92811 View Post
My temporary workaround is to use Reboot Scheduler from Preware and set it for 0400 in the morning. At least I can access email etc. straight away.
I still have a 2nd problem - at times, when in a browser the content part of the screen, below the black header, turns white. It takes a tap of the screen to restore the information.
Ive been using the Reboot Scheduler with success for the last week and then today Ive lost all bookmarks, webos account is blank in device info and in my email lists all accounts but wont let me drill into them. It wont show any of the inboxes in favorites except that I can get "all inboxes" to show. I also lost all contacts. How do I recover the webos account information in device info? (note, rebooted several times without success. Even turned it off an left it off for 30 minutes). Seems the problem is escalating since I started using the reboot workaround.
lkhbryant is offline   Reply With Quote
Old 11/16/2012, 06:12 PM   #74 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Quote:
Originally Posted by lkhbryant View Post
Ive been using the Reboot Scheduler with success for the last week and then today Ive lost all bookmarks, webos account is blank in device info and in my email lists all accounts but wont let me drill into them. It wont show any of the inboxes in favorites except that I can get "all inboxes" to show. I also lost all contacts. How do I recover the webos account information in device info? (note, rebooted several times without success. Even turned it off an left it off for 30 minutes). Seems the problem is escalating since I started using the reboot workaround.
Total database meltdown? Check your logs is what I always say for this kind of problem.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 11/16/2012, 07:10 PM   #75 (permalink)
Member
 
Posts: 16
Quote:
Originally Posted by GMMan View Post
Total database meltdown? Check your logs is what I always say for this kind of problem.
what logs do I check?
lkhbryant is offline   Reply With Quote
Old 11/16/2012, 07:47 PM   #76 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Use Lumberjack if possible. There's a guide in my signature.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 11/16/2012, 09:19 PM   #77 (permalink)
Member
 
Posts: 16
Quote:
Originally Posted by GMMan View Post
Use Lumberjack if possible. There's a guide in my signature.
yes, I can use your procedures for creating a log but which app should I run it on? Accounts wont work (a strange restart occurs if I try to paste the log) and when I run it for email the log is so large I cant save the file.
lkhbryant is offline   Reply With Quote
Old 11/16/2012, 10:18 PM   #78 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Quote:
Originally Posted by lkhbryant View Post
yes, I can use your procedures for creating a log but which app should I run it on? Accounts wont work (a strange restart occurs if I try to paste the log) and when I run it for email the log is so large I cant save the file.
The apps to log is set through the Collect Logs app. If you can, take screenshots. If copy and pasting works, copy the info into a new file with Internalz and copy it over on USB.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 11/17/2012, 12:11 PM   #79 (permalink)
Member
 
Posts: 16
I have saved 2 logs. The first was when I had the contacts app open and the second I had only lumberjack open. I have no idea how to read these logs but see lots of "errors" and "retry" and "warnings".
Attached Files
File Type: txt debuglogmad2.txt (111.5 KB, 4 views) Email Attachment
File Type: txt debuglogmad.txt (113.7 KB, 5 views) Email Attachment
lkhbryant is offline   Reply With Quote
Old 11/17/2012, 01:09 PM   #80 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Quote:
Originally Posted by lkhbryant View Post
I have saved 2 logs. The first was when I had the contacts app open and the second I had only lumberjack open. I have no idea how to read these logs but see lots of "errors" and "retry" and "warnings".
It looks like your database is damaged, at least an entry with your email account. Have you tried the utility on the previous page?
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0