Results 1 to 10 of 10
  1. sarlo100's Avatar
    Posts
    30 Posts
    Global Posts
    41 Global Posts
       #1  
    My TP barfed at trying to install the 3.0.5 update numerous times - running Uberkernal @1.5ghz and maybe 12-15 of the more common patches. Tried reinstalling Uberkernal, no joy. Got fed up, pulled all the patches, update worked fine.

    Tried reinstalling said patches, couldn't find them in the Preware feed. Briefly got annoyed, then decided to think my way out of the paper bag...

    Went into the Preware feed mgmt, enabled patches for 3.0.4, and voila, they were all there. Reinstalled, most of them already work without any updating, and went on about my day. Total extra time (excluding the head banging part), five to seven more minutes.

    Moral of the story, if your TP won't update, pull your patches and try again. You can try and isolate patch by patch, but doing it all at once will be a lot faster than having the update download again and again after each failed attempt.
    Last edited by sarlo100; 01/14/2012 at 01:08 PM. Reason: misspelling
  2. #2  
    But it is still unknown which patch may have 'barfed' your 3.0.5 Update?
  3. #3  
    Multiple attempts at upgrade also failed. I then decided to delete 3 patches at at time and try the upgrade. Third time met with success. (Thank you HP for returning the "empty trash" function to email app!)
  4. #4  
    Can you recall which patches those last 3 were?
  5. #5  
    Quote Originally Posted by Mutoidi View Post
    Can you recall which patches those last 3 were?
    I removed Uberkernel and Govnah after several failed attempts. This worked without uninstalling any other patches. However, you should uninstall all patches because they won't work anyway.. I have been uninstalling and reinstalling them one at a time. This has been working great.

    Read this thread to see what I mean:

    Patches and the 3.0.5 update
    **Intelligence is God given; Wisdom is the sum of our mistakes!**

    As a top contributor to the HP Consumer Support Forums, HP provides me access to the Tochpad at no charge so I may better respond to the questions raised on the Forum.
  6. #6  
    you should generally uninstall homebrew kernels before taking an OTA update.

    patches won't show up in preware until they have been updated to reflect that they can work with the new webOS release.

    usually there is a list in the webosinternals forum of patches that need to be removed before the update. Usually it is only a few of them. Must will get updated through preware while still on your device.
  7. #7  
    Quote Originally Posted by old_geekster View Post
    I removed Uberkernel and Govnah after several failed attempts. This worked without uninstalling any other patches. However, you should uninstall all patches because they won't work anyway.. I have been uninstalling and reinstalling them one at a time. This has been working great.
    I uninstalled 'Glass Suite' Theme, 'Muffle System Logging' patch and installed the stock Palm Recovery Kernel before going straight into a smooth 3.0.5 update.

    However, I am wondering whether Rod Whitby's recent 'Tweets' may indicate that reinstalled 3.0.4 patches in 3.0.5, are later going to cause update glitches to/with 'AUSMT'.. whatever that turns out to do?!!

    Edit: Update:
    AUSMT Scripts. (v1.0.0 Alpha).
    '..AUSMT makes updating patches and themes safe even after OTA updates. There still might be certain corner cases that can cause problems after OTA updates, so if you want to avoid all problems, it's still recommended to uninstall patches & theme before OTA update..'

    ::

    '..We're working on a new Auto-Update System Modification Technology (AUSMT, pronounced "oz-em-tee") to handle patches, themes, etc congruently..'

    '..We ('TheRealSconix' actually), will release the first version of this new technology to the alpha-patches feed in the next couple of days..'

    '.. Both Theme Manager and Tweaks will be updated to use AUSMT, and Tweaks will eventually be able to apply raw patches, like Internalz..'

    '..So for this webOS 3.0.5 OTA update, we would recommend removing all patches before updating, or delaying your update until AUSMT is ready..'

    '..Tweaks will also eventually incorporate a finer-grained patch recovery support, replacing the need for EPR for most error cases..'

    '..Kernel source code for #webOS 3.0.5 has been released at Open Source Packages - opensource.palm.com - Palm - look for an updated UberKernel soon..'

    '..UberKernel/TouchPad 3.0.5-91 is now in the beta-kernels feed - if I get success reports and no failure reports I'll push to stable in 10-12h..'

    ::
    Last edited by Mutoidi; 01/14/2012 at 03:07 PM.
  8. #8  
    Quote Originally Posted by Mutoidi View Post
    Can you recall which patches those last 3 were?
    Quiet Powerd Messages
    Remove Dropped Packet Logging
    Unset CFQ IO Sched.

    YMMV!
  9. #9  
    Quote Originally Posted by StanS2 View Post
    Quiet Powerd Messages
    Remove Dropped Packet Logging
    Unset CFQ IO Sched.

    YMMV!
    Maybe the latter was the culprit?

    DWFIU! (Depends Which Fuel I'm Using) -
  10. #10  
    Quote Originally Posted by sarlo100 View Post
    My TP barfed at trying to install the 3.0.5 update numerous times - running Uberkernal @1.5ghz and maybe 12-15 of the more common patches. Tried reinstalling Uberkernal, no joy. Got fed up, pulled all the patches, update worked fine.

    Tried reinstalling said patches, couldn't find them in the Preware feed. Briefly got annoyed, then decided to think my way out of the paper bag...

    Went into the Preware feed mgmt, enabled patches for 3.0.4, and voila, they were all there. Reinstalled, most of them already work without any updating, and went on about my day. Total extra time (excluding the head banging part), five to seven more minutes.

    Moral of the story, if your TP won't update, pull your patches and try again. You can try and isolate patch by patch, but doing it all at once will be a lot faster than having the update download again and again after each failed attempt.
    I have a bone stock TP where this is the first UG that would not install. Your suggestions don't help for those TPs.

Posting Permissions