Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 54
Like Tree5Likes
  1. #21  
    Quote Originally Posted by bs03 View Post
    This is great, but will Hulu get wind of it and find a way to block it also.

    I am watching the commercials (no ad blocker) and over 21, so I am not doing anything wrong. They should just leave me alone.
    Probably hulu will screw it up if they can yes but at least we have ncinerates fine work to tide us through if so.

    Quote Originally Posted by froggys View Post
    it was already blocked for me last night.
    What was?

    Quote Originally Posted by fwinst View Post
    Using 3.0.2doesn't work for me. For somevideos it says that my ad blocker is stopping it from working. As for Hulu, i get a message saying it's not supported on my device. Any suggestions??
    If you want to watch on hulu directly, "the -NEW- HULU fix!" (click here for details) is the only way right now. As for ad blocker, what I have seen so far is that all works fine with "ad blocker", and you get the commercials. With "max blocker", I get a message saying the ads can't be displayed and have to wait basically just as long as if a commercial was shown, but the video still shows. Are you sure it's not working or did you perhaps not wait long long enough to see? At any rate, if you're running max blocker, from what I've seen, sooner or later something is not going to work with it, you'll just have to decide how much you value that additional ad blocking vs stuff working.
  2. #22  
    Quote Originally Posted by texasflood View Post
    Probably hulu will screw it up if they can yes but at least we have ncinerates fine work to tide us through if so.


    What was?


    If you want to watch on hulu directly, "the -NEW- HULU fix!" (click here for details) is the only way right now. As for ad blocker, what I have seen so far is that all works fine with "ad blocker", and you get the commercials. With "max blocker", I get a message saying the ads can't be displayed and have to wait basically just as long as if a commercial was shown, but the video still shows. Are you sure it's not working or did you perhaps not wait long long enough to see? At any rate, if you're running max blocker, from what I've seen, sooner or later something is not going to work with it, you'll just have to decide how much you value that additional ad blocking vs stuff working.
    the imdb site was already blocking the hulu video, said content not avaiblabel for me on platform or something like that.
  3. #23  
    Quote Originally Posted by texasflood View Post
    Probably hulu will screw it up if they can yes but at least we have ncinerates fine work to tide us through if so.


    What was?


    If you want to watch on hulu directly, "the -NEW- HULU fix!" (click here for details) is the only way right now. As for ad blocker, what I have seen so far is that all works fine with "ad blocker", and you get the commercials. With "max blocker", I get a message saying the ads can't be displayed and have to wait basically just as long as if a commercial was shown, but the video still shows. Are you sure it's not working or did you perhaps not wait long long enough to see? At any rate, if you're running max blocker, from what I've seen, sooner or later something is not going to work with it, you'll just have to decide how much you value that additional ad blocking vs stuff working.
    the imdb site was already blocking the hulu video, said content not avaiblabel for me on platform or something like that.
  4. #24  
    Quote Originally Posted by froggys View Post
    the imdb site was already blocking the hulu video, said content not avaiblabel for me on platform or something like that.
    OK, after testing, it appears that technically "no patch needed" is not accurate but it's minimal patching required. You won't be able to watch on imdb without at least the original hulu patch or the flash part of the "new hulu patch". For hulu direct you'll need both parts of the "new hulu patch".
  5. #25  
    Quote Originally Posted by mistermojorizin View Post
    go here on your TP: Videos

    watch everything from HULU! no patch necessary because they don't block the touchpad.

    Code:
    http://www.imdb.com/features/video/
    getting a prompt that hulu does not support my device.trying thru the imdb links
  6. Redflea's Avatar
    Posts
    71 Posts
    Global Posts
    212 Global Posts
    #26  
    Trying to update my 3.0.3 TP w/the libflashplayer.so change so I can give this a try, but the user agent appears to be different on 3.0.3.

    Can someone running 3.0.2 google user agent, select one of the sites, and post what they get for their user agent? For example, I'm getting:

    Mozilla/5.0 (hp-tablet; Linux; hpwOS/3.0.3; U; en-US) AppleWebKit/534.6 (KHTML, like Gecko) wOSBrowser/234.75 Safari/534.6 TouchPad/1.0

    I need to know whether I should use "Linux" in this command below instead of "WEB", and would like to see where "WEB" appears in the 3.0.2 user agent string for comparison. Thanks!

    sed -i 's/WEB 10/WIN 10/' libflashplayer.so
  7. #27  
    Quote Originally Posted by Redflea View Post
    Trying to update my 3.0.3 TP w/the libflashplayer.so change so I can give this a try, but the user agent appears to be different on 3.0.3.

    Can someone running 3.0.2 google user agent, select one of the sites, and post what they get for their user agent? For example, I'm getting:

    Mozilla/5.0 (hp-tablet; Linux; hpwOS/3.0.3; U; en-US) AppleWebKit/534.6 (KHTML, like Gecko) wOSBrowser/234.75 Safari/534.6 TouchPad/1.0

    I need to know whether I should use "Linux" in this command below instead of "WEB", and would like to see where "WEB" appears in the 3.0.2 user agent string for comparison. Thanks!

    sed -i 's/WEB 10/WIN 10/' libflashplayer.so
    In my case: "Your User Agent: Mozilla/5.0 (hp-tablet; Linux; hpwOS/3.0.2; U; en-US) AppleWebKit/534.6 (KHTML, like Gecko) wOSBrowser/234.40.1 Safari/534.6 TouchPad/1.0" and my flash player version shows up as "WIN".

    Quote Originally Posted by mistermojorizin View Post
    go here on your TP: Videos

    watch everything from HULU! no patch necessary because they don't block the touchpad.

    Code:
    http://www.imdb.com/features/video/
    Quote Originally Posted by postarrow View Post
    getting a prompt that hulu does not support my device.trying thru the imdb links
    As I have said previously in the thread, it's not accurate that you can view hulu on imdb without patching, you need the original hulu flash patch from prewave or the sed patch mentioned in the first post of this thread.
  8. Redflea's Avatar
    Posts
    71 Posts
    Global Posts
    212 Global Posts
    #28  
    Quote Originally Posted by texasflood View Post
    In my case: "Your User Agent: Mozilla/5.0 (hp-tablet; Linux; hpwOS/3.0.2; U; en-US) AppleWebKit/534.6 (KHTML, like Gecko) wOSBrowser/234.40.1 Safari/534.6 TouchPad/1.0" and my flash player version shows up and "WIN".
    Thanks very much. Same as mine except for version info.

    I tried running the sed command against first one, then the other, then both libflashplayer.so files I found in the two directories on my TP and haven't gotten this to work...so either something has changed in 3.0.3 somewhere else to block me, or maybe the sed command isn't working properly on the libflashplayer.so files on my TP.

    I guess one thing I haven't tried is putting a copy of libflashplayer.so into the /usr/lib/BrowserServerPlugins directory (where 3.0.3 doesn't appear to keep a copy of the file, and run sed against it and if that does anything...
  9. #29  
    Oh and FYI, changing the flash string doesn't require a reboot in my case to take effect.
  10. Jawbox's Avatar
    Posts
    91 Posts
    Global Posts
    104 Global Posts
    #30  
    Fantastic, now to see how long this lasts before Hulu crashes the party.
  11. #31  
    Still working for me. I think that this thread should be deleted and not talked about again. Every minute this thread stays up is another chance that hulu blocks us all again.
  12. #32  
    I would think it would work the same way but what do I know? I wonder if there might be another libflashplayer.so somewhere? Did you finish the search?

    Quote Originally Posted by Link2999 View Post
    Still working for me. I think that this thread should be deleted and not talked about again. Every minute this thread stays up is another chance that hulu blocks us all again.
    You may be right, I wouldn't mind it being deleted, have to do a special knock or something to get the info, hah!
  13. #33  
    this worked for me. No other hulu patches or anything:

    first half of New Hulu Fix instructions


    Go into webOS quick install on your home pc - you can find it here:

    http://forums.precentral.net/canuck-...-v4-2-3-a.html

    Run the program, select the TOOLS tab, and pick LINUX COMMANDLINE. Make sure your browser is closed on the touchpad.

    You should now be in a terminal at a command line looking at your touchpad .

    Now type or copy and paste the following lines into the terminal window. Hit enter after each line:

    mount -o remount,rw /

    cd /usr/lib/BrowserServerPlugins

    cp libflashplayer.so libflashplayer.so.bak

    sed -i 's/WEB 10/WIN 10/' libflashplayer.so

    unplug TP from computer, restart TP and go back to IMDb to test. Family Guy worked for me!
    nunjabusiness likes this.
  14. Redflea's Avatar
    Posts
    71 Posts
    Global Posts
    212 Global Posts
    #34  
    That works on 3.0.2. Doesn't appear to work on 3.0.3 (what I'm running...)
  15. #35  
    Thanks guys! I did just the libflashplayer.so part from the new Hulu fix as posted by beasy43 and it worked for me without a restart.

    I had never done Linux commands before and couldn't figure it out at first. Then I realized that you enter the commands on your computer, not the TP.
  16. #36  
    Quote Originally Posted by Redflea View Post
    That works on 3.0.2. Doesn't appear to work on 3.0.3 (what I'm running...)
    Out of curiosity, after making the sed changes, what does the "Find Flash Player version" page report your flash player version string to be? After the edit it's WIN on my touchpad as I mentioned earlier. It's LNX on my ubuntu laptop, which I'm currently typing on. To my way of thinking if yours is WIN as well then it should work but maybe I'm missing something.

    Quote Originally Posted by rghilliard View Post
    Thanks guys! I did just the libflashplayer.so part from the new Hulu fix as posted by beasy43 and it worked for me without a restart.

    I had never done Linux commands before and couldn't figure it out at first. Then I realized that you enter the commands on your computer, not the TP.
    Per the original instructions yes you would run it in the PC window under webOS quick install / TOOLS / LINUX COMMANDLINE. But for future reference you can also run xecutah xterm on the touchpad and pick up after the mount command (which isn't needed in this case) with "cd /usr/lib/BrowserServerPlugins" and do it in the xterm. That's how I did it. 6 of 1, 1/2 dozen of another. Glad you got it working.
  17. Redflea's Avatar
    Posts
    71 Posts
    Global Posts
    212 Global Posts
    #37  
    Quote Originally Posted by texasflood View Post
    Out of curiosity, after making the sed changes, what does the "Find Flash Player version" page report your flash player version string to be? After the edit it's WIN on my touchpad as I mentioned earlier. It's LNX on my ubuntu laptop, which I'm currently typing on. To my way of thinking if yours is WIN as well then it should work but maybe I'm missing something.
    I'll run the change again and see what it says...should have thought of doing that myself! <facepalm>

    Funny, after applying the sed change to the one in this folder ( /media/cryptofs/apps/usr/lib/BrowserServerPlugins/) the Find Flash Player version does not work...it says:

    "Content on this page requires a newer version of Adobe Flash Player" under the section where it's supposed to tell you the version.

    So the sed mod really doesn't seem to work on 3.0.3.

    Going to restart and try again, as browser locked up when I went to the "about flash player" link from the find flash player version page and tried to go back to the find version page.

    Will also reverse the change and make sure that the find flash version page is working before the change to the lib file.
    Last edited by Redflea; 10/11/2011 at 05:55 PM.
  18. #38  
    What's this about a 3.0.3? First I've heard!

    Anyway...the IMDB trick worked for me as of one hour ago. Sweet! (until they eff it up again)
  19. Redflea's Avatar
    Posts
    71 Posts
    Global Posts
    212 Global Posts
    #39  
    So when I reversed the change the result was "WEB" - so the setting is in that file in that folder, but the sed edit isn't working maybe due to a format change in the file on 3.0.3....

    You know, I don't even really care that much if this works, 'cause I don't really watch or want to watch videos on my TP, but you know, it's starting to **** me off.

    I edited the libflashplayer.so file by hand w/a hex editor to set the WEB to WIN and saved it, pushed it to the folder and ensure permissions matched, and it still doesn't work. I'm moving on, but it looks like this hack may have to be revised for 3.0.3 when that gets formally released (assuming this hack is still working at that point).

    Happy hulu-ing to you 3.0.2'ers.
    Last edited by Redflea; 10/11/2011 at 08:06 PM.
  20. fwinst's Avatar
    Posts
    715 Posts
    Global Posts
    889 Global Posts
    #40  
    Of course, if you have Splashtop, you can watch Hulu thru your laptop, or desktop.
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions