webOS Nation Forums >  webOS Devices >  HP TouchPad > ejecting touchpad in USB-mode from linux host machine?
ejecting touchpad in USB-mode from linux host machine?
  Reply
Like Tree1Likes
  • 1 Post By cbf123

 
Thread Tools Display Modes
Old 09/26/2011, 12:13 PM   #1 (permalink)
Member
 
Posts: 30
I connected my touchpad to my linux machine and was able to browse the contents of the device without any problems.

When I was done I "ejected" the touchpad the same way I would do any other USB mass storage device. This appeared to work fine on the computer, but when I unplugged the cable the touchpad gave the "ouch" message saying to eject properly next time.

Does anyone know how to properly disconnect the device from a Linux machine?
cbf123 is offline   Reply With Quote
Liked by johnjaycee likes this.
Old 09/26/2011, 12:38 PM   #2 (permalink)
Member
 
Posts: 5
Open the terminal and enter

mount

You should get a list of all mounted devices including your touchpad.

To eject enter (maybe as user root)

umount /path/to/your/touchpad/mountpoint

By typing [mount] again, you can check that it's no longer in the list.
mojo200 is offline   Reply With Quote
Old 09/26/2011, 12:56 PM   #3 (permalink)
Member
 
Posts: 219
I normally right click on the Touchpad Mount the Desktop and instead of clicking eject I click unmount.

following the person above me should also work. both will unmount on just requires you to type
elpollodiablo1 is offline   Reply With Quote
Old 09/26/2011, 04:43 PM   #4 (permalink)
Member
 
Posts: 30
I work with linux for a living, I know how to mount/unmount/etc.

I suspect that I ran into something akin to how under Windows you can't just hit the "remove hardware safely" button but you need to right-click the driver letter and pick "eject".

On my Fedora 14 desktop normally when I'm done with a USB mass storage device I click the USB icon and hit the eject button. This unmounts the drive. When I did this with the touchpad, the tablet complained.

Whether I unmount it via the commandline or hit the "safely remove" button, the touchpad remains in USB mode. At this point unplugging the USB cable triggers an "OWWW! That hurts!" message on the tablet.
cbf123 is offline   Reply With Quote
Old 09/26/2011, 05:30 PM   #5 (permalink)
Member
 
Posts: 14
`eject /dev/sdX' will do the trick; you'll probably need to be root for that.
grinsekatze is offline   Reply With Quote
Old 09/26/2011, 05:46 PM   #6 (permalink)
Member
 
texasflood's Avatar
 
Posts: 1,165
I had kind of the opposite problem but maybe it's related. Recognizing the touchpad being plugged in was very unreliable. After some googling, I found that the BIOS "Legacy Floppy" setting being enabled seemed to screw up automounting devices. In my case, I restarted the computer to get into the BIOS setup and changed the "Floppy" setting to disabled instead of "Legacy Floppy", saved the change, shut down the PC (reboot didn't seem to fully do it) then once I started it back up all was well. I also read that "sudo modprobe -r floppy" might do the same thing but can't confirm. This may not be the same issue but thought it was worth mentioning since it might just be the flip side of a similar automount issue.
texasflood is offline   Reply With Quote
Old 09/26/2011, 06:38 PM   #7 (permalink)
Member
 
Posts: 163
I'm an OpenSuSE 11.4 user and I have the same problem. It's existed in previous Pres too but is sometimes fixed by Palm / HP when WebOS updates.

I find that the cleanest way to disconnect the TouchPad from my Linux box is to:
i) Type "mount" at the command line to discover what device the TouchPad is on.
ii) Do the "Click to safely remove device" on the toolbar.
iii) Type "eject /dev/sd?" at the command line. This disconnects the TouchPad freakishly quickly.

Root permissions are not required. YMMV.

If I had 10 mins I'd write a script to do it all in one go....

Regards,

Andrew
AndrewP is offline   Reply With Quote
Old 09/26/2011, 06:44 PM   #8 (permalink)
Member
 
Posts: 72
grinsekatze was right. The only step needed is to type in a commandline: 'sudo eject /dev/sdX' where X is the letter of the touchpad device. You can find this letter out by typing "df" and looking for the /dev/sd... entry that corresponds to your touchpad mountpoint. There will be a number, too, but you don't use it in the eject command. If it is at /dev/sdc1 then the correct way to safely unmount is 'sudo eject /dev/sdc'

That said, after unmounting the usual way there should be no problems, despite the touchpad saying "ouch". The unmount will have synced data to the TP.
DrPotoroo is offline   Reply With Quote
Old 09/27/2011, 01:12 PM   #9 (permalink)
Member
 
Posts: 219
Quote:
Originally Posted by cbf123 View Post
I work with linux for a living, I know how to mount/unmount/etc.

I suspect that I ran into something akin to how under Windows you can't just hit the "remove hardware safely" button but you need to right-click the driver letter and pick "eject".

On my Fedora 14 desktop normally when I'm done with a USB mass storage device I click the USB icon and hit the eject button. This unmounts the drive. When I did this with the touchpad, the tablet complained.

Whether I unmount it via the commandline or hit the "safely remove" button, the touchpad remains in USB mode. At this point unplugging the USB cable triggers an "OWWW! That hurts!" message on the tablet.
hmm that is strange on my Fedora 13 I am not have any issues with using the eject option. just hit eject it unmounts the drive and take a second or two and the TP get out of USB mode with no issues. only time I have issues is when I use safely remove option so I stay away from that.
elpollodiablo1 is offline   Reply With Quote
Old 10/24/2011, 09:46 PM   #10 (permalink)
Member
 
Posts: 1
Using Opensuse

eject /dev/sdc

Allowed me to eject my hp touch-pad correctly.
J100. is offline   Reply With Quote
Old 10/25/2011, 02:50 PM   #11 (permalink)
Member
 
Posts: 255
On Fedora (14+), it automounts and there's a little "eject" button next to the mount point in Nautilus that "just works". When I click on eject, in the background I assume it sends the proper signal to clear the cache, unmount and disconnect because the Pre 2 and Pre 3 recognizes it and goes back to Normal mode.
richip is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0