Page 1 of 7 123456 ... LastLast
Results 1 to 20 of 132
Like Tree50Likes
  1.    #1  
    So it turns out webOS's browser cache is far too over aggressive, to the point that a web page will never show updates unless the refresh button is pressed. The only answer I've found? Totally disabling cache.

    Sure that means pages will load slower, but I still think that's better than a quick initial cache load followed by a manual refresh after realising your reading 3 hour old news.

    This will work with both the default browser and Advanced Browser.

    1. Install Preware if you haven't already (google will help you with this)
    2. Install Internalz Pro from Preware.
    3. Open Internalz Pro -> app name in top left corner of the screen -> Preferences -> turn on 'Master Mode' -> app name again -> close
    4. Open /etc/palm/browser-app.conf
    5. Change the following:

    MemCacheMinDeadBytes=0MB
    MemCacheMaxDeadBytes=0MB
    MemCacheTotalBytes=0MB
    DiskCacheEnabled=false

    6. Reboot your tablet (Luna restart isn't enough)
    7. Done

    <staff edit>
    **Note: A Patch is available from Jason R in post #59
    Last edited by HelloNNNewman; 09/11/2011 at 12:28 PM.
    nappy, Dis, thestealth and 20 others like this.
  2. #2  
    Thanks. It seems completely absurd that we even have to do this but it's much better than having to mash refresh over and over again.
  3. #3  
    That's funny, because I'm getting really ****ed off at the fact that the browser -never- -caches- -anything- and reloads it all from the network all the time, from what I can tell.

    Maybe I just use mine more than others, and it burns up it's cache space.
    Vistaus likes this.
  4.    #4  
    Umm where'd my OP go?
  5. #5  
    Uh, yeah. What happened? I went to grab my TouchPad and when I got back the OP was gone.
  6. #6  
    Quote Originally Posted by PainToad View Post
    Umm where'd my OP go?
    Don't know, but would love to know what it said as this is a pet peeve of mine.
  7. tEhLoNeR's Avatar
    Posts
    97 Posts
    Global Posts
    105 Global Posts
    #7  
    Quote Originally Posted by PainToad View Post
    Umm where'd my OP go?
    probably being reviewed by the mods? i know my posts are like that in some threads

    ive seen this with the n64 emu post and i was confused on where it went, only to appear hours later
  8. #8  
    I managed to get the fix implemented before the first post was deleted (or moved?) and it seems to be working great. Thanks so much PainToad.
  9. #9  
    whats the fix I dont see it?
    "I haven't failed. I've just found 10,000 ways that won't work."
    Thomas Edison
  10. LiGhTFasT's Avatar
    Posts
    12 Posts
    Global Posts
    15 Global Posts
    #10  
    thanks did it just in time, time will tell if it loads up a old page
    Last edited by LiGhTFasT; 09/09/2011 at 06:34 PM. Reason: seems to work perfectly pressing back loads up new posts
  11. smatofu's Avatar
    Posts
    36 Posts
    Global Posts
    86 Global Posts
    #11  
    You can install my patch and put a code in bookmarks to delete cache. Details here:

    http://forums.precentral.net/hp-touc...ly-faster.html

    BTW, I wonder what effect private browsing will have on your problem. You can turn private browsing on/off through bookmarks as well.
  12.    #12  
    I edited it to include a link to my other tweaks on my blog. Guess it's being reviewed, sorry guys (and mods if it's not aloud).

    I'm sure it will be back soon.

    Glad it's working for people so far.
  13. LiGhTFasT's Avatar
    Posts
    12 Posts
    Global Posts
    15 Global Posts
    #13  
    I'm just having a play with some of the other settings in and have turned private browsing to true and tried to change the window so it locks width with this variable

    The 'EnableFitWidth' parameter lets us control the default behavior of ScrollView.
    EnableFitWidth=false

    but doesn't do anything
  14.    #14  
    My advice is don't fiddle with other settings, took alot of trial and error. Turn the wrong thing on and your CPU maxs out continually...
  15. #15  
    Can the advanced browser cache be disabled in a similar manner or does this disable for both browsers?
    embdriver likes this.
  16.    #16  
    Quote Originally Posted by rstark View Post
    Can the advanced browser cache be disabled in a similar manner or does this disable for both browsers?
    All browsers
  17. DRFP's Avatar
    Posts
    309 Posts
    Global Posts
    315 Global Posts
    #17  
    where is original post?
    I'm not here to criticize the Touchpad but to learn how to make it better.
  18. #18  
    yep got it and it works great . No real slow down that I noticed
  19. #19  
    Great job PainToad. I thanked you in the "where'd my op go" post.

    Works great, no slow down. Loading the page from the cache takes just as long as downloading it.
  20. #20  
    can we get someone to post the original values just in case
    DeadVim likes this.
Page 1 of 7 123456 ... LastLast

Posting Permissions