Results 1 to 3 of 3
  1. joegti10's Avatar
    Posts
    16 Posts
    Global Posts
    18 Global Posts
       #1  
    Had my 16gb about 3 days before the left channel speaker stopped functioning...tests like this one below gave me no output on the left speaker.



    Called HP, they sent me an empty box...I sent the HP back to them for repair/replacement. Waited about a week, got the return package back today. The same unit was returned with the same serial number...it also had a piece of paper saying that it wasnt the same device and none of my data was on it etc. All nicely packaged back up with that covering on the screen etc.

    Well after all that...guess what? Still no output on the left speaker. Looks like they just did a hard erase/reset, cleaned it up, packaged it and tossed it back in back in the box. How nice.

    Im pretty po'ed at this point...i get back on the phone with HP, they give me no answers as to why my device wasnt fixed. They offer to send me a new unit in advance but i have to give them a 375 dollar hold on my cc. I say no and ask for a supervisor. I eventually get the hold down to a dollar for the advance return. We will see if it comes off the UPS truck in the next few days, I have not been furnished a tracking number as of yet.

    Anyone else have a fauly speaker? lol
  2. joegti10's Avatar
    Posts
    16 Posts
    Global Posts
    18 Global Posts
       #2  
    I had a brand new device delivered next day air on the morning UPS run. New TP has two functioning speakers, im psyched.
  3. vanngoh's Avatar
    Posts
    58 Posts
    Global Posts
    59 Global Posts
    #3  
    oh I had the same prob too! Left speaker not working. Think have to call HP singapore..

Posting Permissions