Results 1 to 15 of 15
Like Tree1Likes
  • 1 Post By roundruler
  1.    #1  
    while i was cleaning my touchpad's screen i noticed a small speck of dust under the screen near the home button. i'm sure it wasn't there when i got it brand new. anyone else have this too?
  2. #2  
    Yes, I have *something* up towards the camera. At first I thought it was a dead pixel but it's higher up (in layers) than the LCD panel itself. It just sort of appeared there about a week after purchase.

    I suppose it could have always been there but I looked over the screen when I first got it, specifically to see if there were any defects.
  3.    #3  
    Quote Originally Posted by jtfolden View Post
    Yes, I have *something* up towards the camera. At first I thought it was a dead pixel but it's higher up (in layers) than the LCD panel itself. It just sort of appeared there about a week after purchase.

    I suppose it could have always been there but I looked over the screen when I first got it, specifically to see if there were any defects.
    thought it leaked in thru the home button or usb port, but since your dust is near the camera, it's probably because these things aren't properly sealed
  4.    #4  
    so nobody else has this problem?
  5. #5  
    Mine has one too.
  6. Prey521's Avatar
    Posts
    15 Posts
    Global Posts
    433 Global Posts
    #6  
    Same here...wasn't there when I opened it up earlier (replaced under warranty) and now I'm here cleaning it and there's something underneath the screen. UGH!!!!
  7.    #7  
    hope it doesn't get worse. Anyone contact HP about this?
  8. #8  
    I think I have this too. I thought it was 2 dead pixels but I'm fairly certain it is not. I have called HP (when I thought it was dead pixels) and I asked for an exchange. Of course they had none in stock to give me. I since decided that I did not mind it so much. I suppose they could "repair" your TP, and by repair I mean open it up and clean it out . I really don't know though.
  9. #9  
    I had one as well....very, very close to the camera eye. After a few weeks, I don't know where it is, and really don't care. It's not there anymore, and that's all that matters
  10. #10  
    Quote Originally Posted by ceejay View Post
    while i was cleaning my touchpad's screen i noticed a small speck of dust under the screen near the home button. i'm sure it wasn't there when i got it brand new. anyone else have this too?
    Same here... I was cleaning my screen in order to put on a screen protector.
    There were two specks of dust that I couldn't get rid of. I finally realized that
    they were under the glass, also near the home button.

    Those two specks of dust don't bother me, but I'm only worried about more
    dust getting inside in the future.
  11. #11  
    Quote Originally Posted by finecismad View Post
    I think I have this too. I thought it was 2 dead pixels but I'm fairly certain it is not. I have called HP (when I thought it was dead pixels) and I asked for an exchange. Of course they had none in stock to give me. I since decided that I did not mind it so much. I suppose they could "repair" your TP, and by repair I mean open it up and clean it out . I really don't know though.

    I was told by HP webOS support that they don't "repair" such thing. However, they will
    allow me to exchange it for a refurbished unit during the warranty period. (with no
    guarantee that the refurbishe Touchpads will have zero dust under the glass)

    Oh well.. this is not really limited to HP. My previous iPad 2 had a lot more dust
    under the glass.
    Jive Turkey likes this.
  12. #12  
    same as situation as roundruler
  13. #13  
    Does anyone know if the headphone jack is closed at the bottom? I have seen headphone jacks that are open on the bottom, and they can let dust in. If it is open the best thing you can do is get a headphone jack plug.
  14. Prey521's Avatar
    Posts
    15 Posts
    Global Posts
    433 Global Posts
    #14  
    I had something that looked to be a small piece of lint underneath my screen that appeared a few hours after I opened it....wasn't there when I first opened since it was a warranty replacement to replace one that had a defective screen so I went over that screen like Sherlock Holmes. Cheap build quality apparently since it's not sealed very well. I'm sending it back as well, it's annoying as all hell.
  15. #15  
    Quote Originally Posted by Paralel View Post
    Does anyone know if the headphone jack is closed at the bottom? I have seen headphone jacks that are open on the bottom, and they can let dust in. If it is open the best thing you can do is get a headphone jack plug.
    I sure hope it's either the headphone jack on the top or the USB port on the bottom.
    Those two can be easily covered up. (50-cent 3.5mm jack and micro-USB plastic/
    rubber covers can be found on Ebay and Amazon) Come to think of it, I probably
    have a few in my basement... going to look for them now.

Posting Permissions