Results 1 to 6 of 6
  1.    #1  
    I put the Zagg screen protector on my TP right after I got it so I don't know how it feels without one. So someone who used it before and after screen protector can perhaps comment/help.

    I notice sometimes I have to touch the screen multiple times before it gets registered. It happens when I click on a link on a website, use the virtual keyboard, or touch the browser's address bar. It's getting annoying and I want to know if this is due to the screen protector or not.

    Can someone comment? BTW, I've already done the OC, install speed up patches, and increase sensitivity patch.

    Thanks!
  2. #2  
    I don't have a Zagg shield on my TP but I have one on my Evo and all you lose a bit of ability to slide your finger easily off the glass I never had a problem clicking on anything or typing. How long has it been on there? It does take a bit of time to dry completely.
  3. #3  
    Quote Originally Posted by next_milenium View Post
    I put the Zagg screen protector on my TP right after I got it so I don't know how it feels without one. So someone who used it before and after screen protector can perhaps comment/help.

    I notice sometimes I have to touch the screen multiple times before it gets registered. It happens when I click on a link on a website, use the virtual keyboard, or touch the browser's address bar. It's getting annoying and I want to know if this is due to the screen protector or not.

    Can someone comment? BTW, I've already done the OC, install speed up patches, and increase sensitivity patch.

    Thanks!
    havent used a screen protector yet, but on rare occasions i do have issues w/ links but keyboard works fine....i would suggest doing a recalibration w/ the protector on ...should be under device info>menu>diagnostics
  4.    #4  
    Quote Originally Posted by uh60james View Post
    I don't have a Zagg shield on my TP but I have one on my Evo and all you lose a bit of ability to slide your finger easily off the glass I never had a problem clicking on anything or typing. How long has it been on there? It does take a bit of time to dry completely.
    I don't think this is an issue since I've had it on there for 6 days now. I also noticed a little more difficulty in sliding my finger on the screen though.

    Quote Originally Posted by retroblu View Post
    havent used a screen protector yet, but on rare occasions i do have issues w/ links but keyboard works fine....i would suggest doing a recalibration w/ the protector on ...should be under device info>menu>diagnostics
    Oh, ok. I didn't know there was such a thing. I'll try it tonight and see if it helps.

    Thanks.
  5. #5  
    Quote Originally Posted by next_milenium View Post
    I also noticed a little more difficulty in sliding my finger on the screen though.
    Thats the only complaint I had about the Zagg, I am used to it now. It took about a month but I don't even notice it on my phone now even using the TP without one.
  6.    #6  
    just did recalib and it seems to be helping. I still get some delay on the virtual keyboard but that's probably because I was installing apps in the background.

Posting Permissions