Results 1 to 16 of 16
  1.    #1  
    Hi,
    I tried to connect my touchpad via VPN to my router FRITZBOX 7390. Unfortanality it doesn't work - either with "VPNC" not "Cisco ANYWHERE". I tried to connect my iphone to the same router and it works perfect. So I try to use the same parameter for the touchpad - but the only message I got was "Conncetion failre: no response from vpn-server".

    Can anybody give me a hint?

    Once again - with my iphone it works perfect (IPSEC) - and i used the same settings / credentials

    thanks
  2. Vince42's Avatar
    Posts
    92 Posts
    Global Posts
    96 Global Posts
    #2  
    *bump* - would be interesting for me too ...
    Cheers, Vince
    @webos24net • donate
  3. #3  
    you should probably install pptp a free vpn app in the app catalog. I use it with kebrum.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  4. Vince42's Avatar
    Posts
    92 Posts
    Global Posts
    96 Global Posts
    #4  
    Hi,

    Quote Originally Posted by shneor View Post
    you should probably install pptp a free vpn app in the app catalog. I use it with kebrum.
    Unfotunately pptp or any other vpn app is available in my app catalog ... anyway: thx.
    Cheers, Vince
    @webos24net • donate
  5. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #5  
    It is working!

    I posted a German Howto on Nexave: VPN mit webOS 2.1 und Fritz!Box? - Verbindungen - Nexave Palmforum

    I will add an english version if needed.

    HaPe
  6. #6  
    It is working!

    I posted a German Howto on Nexave: VPN mit webOS 2.1 und Fritz!Box? - Verbindungen - Nexave Palmforum

    I will add an english version if needed.

    HaPe
    Please post an English version here. I have a Fritz.box myself.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  7. chris42's Avatar
    Posts
    170 Posts
    Global Posts
    171 Global Posts
    #7  
    Quote Originally Posted by rwhitby View Post
    Please post an English version here. I have a Fritz.box myself.

    -- Rod
    Hey, I played around with the Palm VPN and made it work for my Palm Pre2 2.2.4 and my Touchpad 3.0.4. So here a translation out of that above mentioned forum entry:

    Step1:
    Create a Fritzbox configuration File

    [EDIT]
    You can now use "Fritz!Box Fernzugang einrichten" to create the config file. Please see Post #11.
    Then you can continue in Step 2.
    [/EDIT]


    /*
    * Example Config for VPNC
    */

    vpncfg {
    connections {
    enabled = yes;
    conn_type = conntype_user;
    name = "your@email_adress.com"; /* will be the group_id in the vpn profile config */
    always_renew = no;
    reject_not_encrypted = no;
    dont_filter_netbios = yes;
    localip = 0.0.0.0;
    local_virtualip = 0.0.0.0;
    remoteip = 0.0.0.0;
    remote_virtualip = 192.168.178.201; /*set the vpn IP */
    remoteid {
    key_id = "your@email_adress.com"; /* will be the group_id in vpn profile config */
    }
    mode = phase1_mode_aggressive;
    phase1ss = "all/all/all";
    keytype = connkeytype_pre_shared;
    key = "long and strong passowrd"; /* will be the group_password in the vpn profile config*/
    cert_do_server_auth = no;
    use_nat_t = yes; /* important to set in the vpn config as well, if you are on 3G */
    use_xauth = yes;
    xauth {
    valid = yes;
    username = "user"; /* set a username, which you use in the vpn config */
    passwd = "password"; /* set a password, which you use in the vpn config */
    }
    use_cfgmode = no;
    phase2localid {
    ipnet {
    ipaddr = 0.0.0.0;
    mask = 0.0.0.0;
    }
    }
    phase2remoteid {
    ipaddr = 192.168.178.201; /* IP for the vpn client in your LAN */
    }
    phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
    accesslist =
    "permit ip 0.0.0.0 0.0.0.0 192.168.2.201 255.255.255.255"; /* needs to match the IP config */
    }
    ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500",
    "udp 0.0.0.0:4500 0.0.0.0:4500";
    }


    // EOF


    Some info to it:
    - name is a qualified name and does not have to be your email. I use something to identify my devices. So I use "Palm@mydomain.com" etc.
    - If I say "vpn config", I mean the VPN configuration on the Palm/TouchPad
    - If you want to use the VPN for the WebOS devices and e.g. your windows PC, you can put both configs in one file and the Fritzbox will have both available.
    You do a structure like this:
    /*
    * Example Config for VPNC
    */

    vpncfg {
    connections {
    <first configuration goes here>
    } {
    <second configuration goes here>
    }
    ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500",
    "udp 0.0.0.0:4500 0.0.0.0:4500";
    }
    // EOF


    With that I use my touchpad and pre on the WebOS config via the username password and my Laptop via a preshared key.

    Step 2:
    Load the configuration into the Fritzbox.

    Step 3:
    Replace the vpnc binary with the new compiled version out of the Post #8 in this thread (file version 0.5.3 !).

    [EDIT]
    Or take the attachment
    [/EDIT]


    Copy the file to the USB Partition and then reconnect to the Palm via command line to replace the binary:
    mount -o remount,rw /
    mv /usr/sbin/vpnc /usr/sbin/vpnc_org
    mv /media/internal/vpnc /usr/sbin/vpnc
    mount -o remount,ro /


    Step 4:
    Connect the VPN :-)

    I made this as a translation, so it would be nice, if someone actually could try this and we can see that all steps are in there and working.
    I am right now trying to make WebOS tunnel all traffic through the VPN. So far it only uses the VPN for the local addresses. I was able to make it work on my laptop, but I can't find an option in WebOS to tunnel all traffic to the VPN and change the DNS to the Fritzbox.

    Greetings
    Christian
    Attached Files Attached Files
    Last edited by chris42; 04/08/2012 at 10:55 AM.
  8. chris42's Avatar
    Posts
    170 Posts
    Global Posts
    171 Global Posts
    #8  
    I looked into vpnc and found the vpnc-script in /etc/vpnc. It seems, that the routing and DNS setting is done there.
    I have no clue about such scripts, but would it be possible to patch it with tweaks, so you get the option to change the behaviour?

    Greetings
    Christian
  9. chris42's Avatar
    Posts
    170 Posts
    Global Posts
    171 Global Posts
    #9  
    Anyone?
  10. chris42's Avatar
    Posts
    170 Posts
    Global Posts
    171 Global Posts
    #10  
    Echo?
  11. chris42's Avatar
    Posts
    170 Posts
    Global Posts
    171 Global Posts
    #11  
    Hey everyone,
    good news, the whole thing became now easier. You still need to replace the vpnc file on the WebOS device though, but you can automatically create the config file for the fritzbox with "Fritz!Box Fernzugang einrichten" in Version 01.03.00.
    There is now an option for iPhone included, just pick that for the WebOS.
    Also you can check an option to route all traffic through your fritzbox. Very nice if you are in public WiFis.

    Only error I found: If you also create a fritzbox configuration for your laptop with the shrew VPN client and you want to completely surf via the firtzbox, the checkbox is somewhat ignored in creating the config file.

    So you need to do one manual change in the fritzbox config file:
    phase2localid {
    ipnet {
    ipaddr = 192.168.2.0;
    mask = 255.255.255.0;
    }
    }

    TO:
    phase2localid {
    ipnet {
    ipaddr = 0.0.0.0;
    mask = 0.0.0.0;
    }
    }


    Also you need to check in shrew the option to tunnel all traffic (very last page).

    Hope this helps someone :-)
    Chris
  12. #12  
    Hallo,

    I am also highly interested in connecting my Veer to FritzBox via VPN.

    However, loading a binary from forum webside an installing it to my smartphone looks quite suspious to me.

    Are there any plans to integrate this vpnc binary as a patch to Preware. Thus, more people would benifit from
    the extended functionality.

    Another question, is there any review process on the software that is integrated to Preware?

    Thanks a lot,

    best

  13. #13  
    just for other security aware people. Exactly this miss behaviour of old vpnc behavior (on e.g. debian) with fritzboxes is discussed here:

    Bug#629646: marked as done (vpnc: patch to support Fritz!Box VPN servers)
    #629646 - vpnc: patch to support Fritz!Box VPN servers - Debian Bug report logs

    With identical .diff patch as solution.

    VPNC doesn't offer support for draft-ietf-ipsec-nat-t-ike-03, which is
    required by the Fritz!Box series of home routers. This patch adds
    support for that feature so that VPNC can connect to these routers.
    Also, the default timeout is lowered to 3600 seconds (also required by
    Fritz!Boxes).
    So one could patch it with that .diff file for yourself and compile with selfdownloaded source
  14. #14  
    Hi,

    there are a few days gone since this instruction was written and I really liked to use VPN with my devices and my FritzBox and I'm struggling now for two days to make it work.

    I have FRITZ!OS 06.05 running on my box and I think the easiest way now seems to be like written below. The weird thing is that my Veer (2.1.0) works like a charm with this. My Touchpad and my Pre2 establish a VPN connection (my Fritzbox confirms this too), But while calling a webpage there comes an error "can't resolve hostname". Does anybody know what might be missing?

    Settings on the FritzBox

    Activate MyFRITZ! and create a user account
    In return you'll get a server name like abcdefghijk.myfritz.net
    Go to Internet -> Permit Access -> VPN
    Press button "Add VPN Connection"
    Chose the first option "Setup access for a user"
    FRITZBox will jump to System -> FRITZ!Box-User
    Press button "Add user"
    Enter a user name
    Enter a password
    Select options Account active and VPN
    Deselect all other options
    Press OK

    FritzBox will ask to show the VPN settings
    Confirm this and look at iPhone settings

    Settings on my webOS-device

    Copy file vpnc of the attachment of posting #7 on your device and do as described in Step 3 of posting #7

    Open VPN-App
    Tap on Add profile
    Select conection type VPNC
    VPN-Server is the name that is shown in the iPhone settings
    Tap Continue
    Next page opens
    Chose a profile name like "MyFirstProfile"
    Server-Name should be filled with the name that is shown in the iPhone settings
    Username is the Account that is shown in the iPhone settings
    Password is the password you entered in the FritzBox while adding this user
    Group-ID is the Groupname shown in the iPhone settings (the same as the username)
    Group-Password is the Shared Secret shown in the iPhone settings
    Domain is the Server that is shown in the iPhone settings
    Select Dead Peer Detection
    Select strong encryption
    Select NAT-Traversal detect automatically
    Tap connect
  15. #15  
    Still struggling to make my TouchPad work like the Veer does...

    VPN connection seems to be established. TouchPad shows VPN sign and my VPN-profile is checked. My FritzBox tells that a VPN connection is established to my TouchPad.
    When I start my browser with http://google.de there comes a message: Error. Hastname can't be resolved.
    If I start my browser with http://173.194.113.8/ then google is opening in my browser.

    I don't know much about VPN, IP, DNS, Linux etc. But this seems to me like a nameserver problem (?). Is there a file where I have to enter a special nameserver for VPN usage. And if yes, which nameserver has to be entered?
  16. #16  
    Though I really don't know exactly what I'm doing, I might have a solution for this problem.
    So far I tested in my network and outside my network. I had the same problems in both cases. In my network I use static IP adresses so I have to setup the WiFi-connections of each of my webOS devices. In the configuration I use an entry DNS wich is the IP of my FritzBox in my network (192.168......).
    If I use the second field for DNS in the WiFi settings of my TouchPad and fill in 8.8.8.8 (which is google) then I can connect to VPN and the browser works

    But I have to confirm this outside my network because I don't know if it is possible to connect to a foreign WiFi and manipulate the settings that I've got automatically from a router with DHCP...

Posting Permissions