Page 9 of 26 FirstFirst ... 4567891011121314 19 ... LastLast
Results 161 to 180 of 507
Like Tree73Likes
  1. #161  
    Quote Originally Posted by nseemann View Post
    Yeah I try to cd and it isn't working I check with pwd and I am still in root :/ Tried copypasting and typing it myself but it isn't letting me cd

    I do ls and it shows the directories but I can't seem to change to any of them.
    It should... That makes absolutely no sense.

    Reload webos quick install, go back into the terminal. Try typing:

    cd /media/internal

    then hit enter

    type ls, see if you've moved...
  2. #162  
    Still nothing, I am having trouble installing ipks from it as well so I am going to redownload it and see if that fixes it, if not I will run webOS Doctor, maybe it's something on my pad.

    Yeah must have downloaded an old Quick Install, it was opening the commandline in a gui before now it just opened in my command prompt and is working.

    Thanks.
    Last edited by nseemann; 08/25/2011 at 11:43 PM.
  3. #163  
    Quote Originally Posted by nseemann View Post
    Still nothing, I am having trouble installing ipks from it as well so I am going to redownload it and see if that fixes it, if not I will run webOS Doctor, maybe it's something on my pad.

    Yeah must have downloaded an old Quick Install, it was opening the commandline in a gui before now it just opened in my command prompt and is working.

    Thanks.
    LOL!

    You had me going nuts over here trying to figure out why in the world simple commands like LS and CP weren't working. Egads man .

    Glad to hear it's working now.
  4. JoeNM84's Avatar
    Posts
    15 Posts
    Global Posts
    595 Global Posts
    #164  
    Quote Originally Posted by ncinerate View Post
    for those with the read-only issue, try this:

    mount -o remount,rw /

    ... make changes - then type

    mount -o remount,ro /

    If this works, please let me know and I'll adjust my initial post to reflect this step. For some reason, my pad was already in write mode, no idea why.
    Thanks this worked for me!
  5. hiero's Avatar
    Posts
    27 Posts
    Global Posts
    156 Global Posts
    #165  
    any ideas out there whether something like this would work for the pre 2 on 2.1.0? I'm not familiar enough with the way the file system is set up to say one way or the other (apologies for not taking the time to delve in myself or if someone already askedthis one)
  6. #166  
    Quote Originally Posted by hiero View Post
    any ideas out there whether something like this would work for the pre 2 on 2.1.0? I'm not familiar enough with the way the file system is set up to say one way or the other (apologies for not taking the time to delve in myself or if someone already askedthis one)
    Theoretically, this should work on -any- pre running 2.1.0 or higher (like a pre- hacked up to 2.1, or a pre +, or a pre 2, or even most likely a pre 3).

    Same basic instructions should apply. Give it a shot and report back (at your own risk of course, it's completely possible this action will send you to the webOS doctor instead).

    I look forward to hearing how it goes .
  7. jmleese's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #167  
    any shot on getting a fix without doing it from a PC? Such as making sure all browsers are closed and opening the terminal from the TP, or are we talking no dice.

    I have HULU+ and it was working fine a few days ago and now nothing works. Sucks that I'm blocked even when I am paying for access..... Ugh!
  8. jmleese's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #168  
    Quote Originally Posted by woody88 View Post
    Thanks guys for all of the work as usual!

    This brings up an interesting aspect that I've been sad about; and that is viewing slingbox on the browser. Does anyone think what has applied to hulu and its fix, can somehow be implemented to how sling restrict the touchpad to view remotely?

    Ever since I owned the original Pre, this has always bother me a lot. and looks like for sure sling will not develop a player, and I don't know why they would still block the touchpad users at this time. Any ideas on this guys that we can address the browser issue with sling player?
    Go over to the TP Apps forum. I contacted them about this and am urging others to do so to get them working on it I hope! The thread title is something like " Like an iOS or Android app - why you should contact the developer."

    I even put a copy of the message I sent them in the bottom of my post, if that is any help for people that want to copy it, and then can edit it a bit to suit their needs for what to send to SlingMedia or really any other app developers...

    I hope it helps and really would like to see them correct this lack of support!!
  9. pigsflew's Avatar
    Posts
    46 Posts
    Global Posts
    48 Global Posts
    #169  
    ncinerate: If you'd like to package it as an installable ipk, you might want to use my modified version of the WOSI build-scripts, that I used in Increase Touchpad Volume.

    You can fork it and just replace the postinst and prerm with scripts to do your sed command back and forth, and you can change the Makefile to match your own info and you'll want to add the lines:

    Code:
    POSTINSTALLFLAGS=RestartDevice
    POSTUPDATEFLAGS=RestartDevice
    POSTREMOVEFLAGS=RestartDevice
    to the top of the Makefile as well to ensure it gets applied.

    You'll have to build it from linux; it won't work with just cygwin. If you're using Ubuntu, you should be golden if you have build-essential installed.
    jmleese likes this.
  10. pigsflew's Avatar
    Posts
    46 Posts
    Global Posts
    48 Global Posts
    #170  
    (Of course, feel free to PM me if you need help!)
  11. #171  
    Quote Originally Posted by pigsflew View Post
    ncinerate: If you'd like to package it as a script you might want to use my modified version of the WOSI build-scripts, that I used in Increase Touchpad Volume.

    You can fork it and just replace the postinst and prerm with scripts to do your sed command back and forth, and you can change the Makefile to match your own info and you'll want to add the lines:

    Code:
    POSTINSTALLFLAGS=RestartDevice
    POSTUPDATEFLAGS=RestartDevice
    POSTREMOVEFLAGS=RestartDevice
    to the top of the Makefile as well to ensure it gets applied.

    You'll have to build it from linux; it won't work with just cygwin. If you're using Ubuntu, you should be golden if you have build-essential installed.
    Love the info, but actually -don't- have ubuntu installed etc at the moment. Honestly, since it sounds like you have a good handle on how to do this, please, take the info we've come up with and make a patch for the masses . I'm sure everyone would love having a simpler way of performing this (even though I'd say the current way is pretty simple). It should be an extremely simple little patch to put together, since it's just changing that tiny little bit of data in the flash file. The only hangup might be the oddball issue where half the people who are trying this seem to have a touchpad that is in READ-ONLY mode. I imagine a proper patch would avoid this issue.

    If you don't feel like doing it maybe I'll get around to messing with ubuntu and working on it myself, but it probably wont be until next week (have a pretty huge project that needs to get done by sunday night).
  12. pigsflew's Avatar
    Posts
    46 Posts
    Global Posts
    48 Global Posts
    #172  
    Quote Originally Posted by ncinerate View Post
    Love the info, but actually -don't- have ubuntu installed etc at the moment. Honestly, since it sounds like you have a good handle on how to do this, please, take the info we've come up with and make a patch for the masses . I'm sure everyone would love having a simpler way of performing this (even though I'd say the current way is pretty simple). It should be an extremely simple little patch to put together, since it's just changing that tiny little bit of data in the flash file. The only hangup might be the oddball issue where half the people who are trying this seem to have a touchpad that is in READ-ONLY mode. I imagine you can get around that with the remount command I added, just doing it by default on every touchpad to ensure proper patching.....

    If you don't feel like doing it maybe I'll get around to messing with ubuntu and working on it myself, but it probably wont be until next week (have a pretty huge project that needs to get done by sunday night).
    Hee. I actually replaced my hard drive a week ago and haven't had a chance to set up Ubuntu yet. I think I may be able to do this by the end of the weekend though. I'll let you know once it's together.
  13. #173  
    Quote Originally Posted by pigsflew View Post
    Hee. I actually replaced my hard drive a week ago and haven't had a chance to set up Ubuntu yet. I think I may be able to do this by the end of the weekend though. I'll let you know once it's together.
    Awesome, I will defer to your ninja-like powers of ubuntu dev work.


    I actually spent quite a bit of time messing around with ubuntu and the whole chain required to port sdl apps awhile back, but after a massive amount of frustration and seemingly endless setbacks, I gave up on the whole thing . I wonder if it's easier this time around - maybe I COULD finally get ur-quan masters running on webos (wouldn't -that- be awesome on a touchpad).

    In the end, I just didn't have time to keep fiddling with it - and ubuntu went the way of the dodo on my system .
  14. #174  
    Thank you guys!! That was actually a really easy and quick fix.
  15. #175  
    My balls tingle every time I open a command prompt screen no matter how easy it's supposed to be. It's the fear I can screwup (please refer to me on page 1 and 3) but when it finally works... it's so damn sweet.
  16. #176  
    For anyone who cares - I tossed this info up on the Pre 2 forum as well, and someone has already confirmed that it -does- work on the 2.1.0 pre.

    So you can rock hulu on your Pre as well. The only thing you need to do differently is to make sure to remove any user-agent spoof if you have one installed on your phone. After that, poof, hulu on the phone.
  17. #177  
    Quote Originally Posted by ncinerate View Post
    I APOLOGIZE FOR THE ERROR THAT WAS HERE - I HAVE SINCE FIXED IT BY CHANGING THE MV TO A CP COMMAND, MY BAD, EVERYTHING SHOULD NOW WORK PROPERLY.

    Please remember that this is an advanced fix using a terminal connection to a linux command line. You are doing this at your own risk. It is a simple process, but if you are at all unsure of your ability to follow these instructions -exactly- please do not attempt this unless you want to visit the webOS doctor.

    I went ahead and changed this post (thanks Abyssul). I've removed the link to the file - but - Abyssul has given us an even easier method. Here's what you do:

    First, ensure you are in DEV MODE. If you don't know how to do this, check my post here:

    http://forums.precentral.net/hp-touc...ted-guide.html

    Go into webOS quick install on your home pc - you can find it here:

    http://forums.precentral.net/canuck-...-v4-2-3-a.html

    Run the program, select the TOOLS tab, and pick LINUX COMMANDLINE. Make sure your browser is closed on the touchpad.

    You should now be in a terminal at a command line looking at your touchpad .

    Now type or copy and paste the following lines into the terminal window. Hit enter after each line:

    cd /usr/lib/BrowserServerPlugins

    cp libflashplayer.so libflashplayer.so.bak

    sed -i 's/WEB 10/WIN 10/' libflashplayer.so

    reboot


    If you run into any issues related to your touchpad regarding it being in Read Only mode, you can fix it by typing the following:

    mount -o remount,rw /

    Then hit enter, and perform the steps listed above.


    TADA, hulu works.

    Want to reverse the process? Simply type (ALL ONE LINE):
    cp /usr/lib/BrowserServerPlugins/libflashplayer.so.bak /usr/lib/BrowserServerPlugins/libflashplayer.so
    do we need to restore the original file libflashplayer.so prior to any system updates? If yes, can you please include it in your summary? Thanks.
    Sent via HP TouchPad using Forums
  18. #178  
    Quote Originally Posted by palmpre06062009 View Post
    do we need to restore the original file libflashplayer.so prior to any system updates? If yes, can you please include it in your summary? Thanks.
    Honestly, I'd say no.

    You may have to perform this "trick" again -after- an update though - if it updates the libflashplayer.so file anyway.

    I'd say the chances of another flash update are fairly slim, so we shouldn't have much to worry about. Worst case, an update would overwrite this file and break hulu support again until we can find the proper spot to hex-edit.

  19. #179  
    I'm more concerned about Hulu finding another way to block the touchpad as opposed to a Flash update breaking this. Like it or not, Hulu has content distribution restrictions that they are contractually obligated to enforce. Hopefully blocking the non-hacked TouchPad is sufficient to satisfy their contracts.
  20. marwp's Avatar
    Posts
    8 Posts
    Global Posts
    9 Global Posts
    #180  
    Quote Originally Posted by jmleese View Post
    any shot on getting a fix without doing it from a PC? Such as making sure all browsers are closed and opening the terminal from the TP, or are we talking no dice.

    I have HULU+ and it was working fine a few days ago and now nothing works. Sucks that I'm blocked even when I am paying for access..... Ugh!
    Worked for me. No pc. I did not even shutdown the browser in another card.

    Just get to a terminal. I used Xterm (already had Xecutah, Servers, and Xterm installed from plying with Ubuntu chroot). After the reboot Hulu worked like a charm.
Page 9 of 26 FirstFirst ... 4567891011121314 19 ... LastLast

Posting Permissions