Page 6 of 26 FirstFirst 123456789101116 ... LastLast
Results 101 to 120 of 507
Like Tree73Likes
  1. #101  
    Quote Originally Posted by daffy4u View Post
    That seems to have done the trick! Thank you so much!
    YAY!

    Ok, so we've fixed everyone who got screwed up by that stupid move command right?
  2. #102  
    yay .. the mv command seems to have worked in USB mode.

    now i: cp /usr/lib/BrowserServerPlugins/libflashplayer.so /usr/lib/BrowserServerPlugins/libflashplayer.so.bak

    so that I have two files, the bak and the original in the /usr/lib/BrowserServerPlugins folder

    time to run the sed -i 's/WEB 10/WIN 10/' /usr/lib/BrowserServerPlugins/libflashplayer.so command?
  3. #103  
    OK - so, for the record, these EXACT instructions should work without problems. I apologize for the earlier screwups, it was my fault (I put a MV command instead of a CP command, so people were moving the critical file and couldn't edit it - this is fixed now). Do this at your own risk, failure to follow these steps very exactly will potentially send you to the webOS doctor .

    I've also fixed my post on page 1 to reflect this. So, enjoy!

    INSTRUCTIONS:

    First, ensure you are in DEV mode. If you don't know how to do this, refer to my instructions here:

    http://forums.precentral.net/hp-touc...ted-guide.html

    Go into webOS quick install on your home pc - you can find it here:

    http://forums.precentral.net/canuck-...-v4-2-3-a.html

    Run the program, select the TOOLS tab, and pick LINUX COMMANDLINE. Make sure your browser is closed on the touchpad.

    You should now be in a terminal at a command line looking at your touchpad .

    Now type the following -exactly- (ALL ON ONE LINE, not two lines):

    cp /usr/lib/BrowserServerPlugins/libflashplayer.so /usr/lib/BrowserServerPlugins/libflashplayer.so.bak

    Now type:

    cd /usr/lib/BrowserServerPlugins

    Now type (again, ALL ON ONE LINE):

    sed -i 's/WEB 10/WIN 10/' libflashplayer.so

    Lastly, type:

    chmod 755 /usr/lib/BrowserServerPlugins/libflashplayer.so

    Now reboot your touchpad and you should be good to go.




    TADA, hulu works.

    Want to reverse the process? Simply type (ALL ONE LINE):
    cp /usr/lib/BrowserServerPlugins/libflashplayer.so.bak /usr/lib/BrowserServerPlugins/libflashplayer.so
    Last edited by ncinerate; 08/25/2011 at 04:34 PM.
    hiero likes this.
  4. Peppy431's Avatar
    Posts
    98 Posts
    Global Posts
    100 Global Posts
    #104  
    Quote Originally Posted by j_grouchy View Post
    whoa whoa whoa whoa!

    Can we just back up to square one?
    Is this the latest and greatest?: Hulu Fix - WebOS Internals

    I assume we go to dev mode and not usb drive mode, correct?

    We copy/paste the whole chunk of text from that site and then BAM everything works fine?
    Are we doing this copy/pasting from our PC while the TP is hooked up?
    It works.
    Make sure you're in developer mode
    Connect touchpad to computer with USB cable
    Go into USB Mode: No
    Open WebOS Quick Install
    Under Tools select Linux Commandline
    Copy and paste the text using your mouse (Ctrl+V won't work in in a DOS window).
    Your touchpad will reboot. Allow it to completely reboot before unplugging cable.
  5. #105  
    Quote Originally Posted by srinsubra View Post
    yay .. the mv command seems to have worked in USB mode.

    now i: cp /usr/lib/BrowserServerPlugins/libflashplayer.so /usr/lib/BrowserServerPlugins/libflashplayer.so.bak

    so that I have two files, the bak and the original in the /usr/lib/BrowserServerPlugins folder

    time to run the sed -i 's/WEB 10/WIN 10/' /usr/lib/BrowserServerPlugins/libflashplayer.so command?
    Yep, that should finish everything up.

    Type:

    cd /usr/lib/BrowserServerPlugins

    Now type (again, ALL ON ONE LINE):

    sed -i 's/WEB 10/WIN 10/' libflashplayer.so

    And finally, type:

    chmod 755 /usr/lib/BrowserServerPlugins/libflashplayer.so
  6. #106  
    If you're getting a read-only error when attempting to copy libflashplayer.so, check how your root file system is mounted (mount | grep 'store-root'). If the first line displayed indicates the root file system, /, is mounted ro, then you need to remount in read-write mode before you can change anything. The command is:

    mount -o remount,rw /

    ... make changes

    mount -o remount,ro /

    This is equivalent to removing the safety, so make sure you know what you're doing. Otherwise, you'll be doctoring your Touchpad.
    Dan Donovan
  7. #107  
    thanks ncin!

    working now .. and no webos doctor! appreciate the help!
  8. #108  
    Quote Originally Posted by Abyssul View Post
    New wiki page:

    Hulu Fix - WebOS Internals

    Contribute to it if you have something to add.
    BINGO!! Easy peasy leason squeezy. Worked for me!
  9. #109  
    Awesome - once again everyone, I apologize for that small slip.

    One little tiny mixup of a MV and CP command caused 4 pages of pain ;p.

    Glad everyone is fixed and working! My instructions are fixed now, so anyone else coming into this thread should be a-o-k.
  10. thurman's Avatar
    Posts
    60 Posts
    Global Posts
    235 Global Posts
    #110  
    Quote Originally Posted by ncinerate View Post
    I APOLOGIZE FOR THE ERROR THAT WAS HERE - I HAVE SINCE FIXED IT BY CHANGING THE MV TO A CP COMMAND, MY BAD, EVERYTHING SHOULD NOW WORK PROPERLY.

    I went ahead and changed this post (thanks Abyssul). I've removed the link to the file - but - Abyssul has given us an even easier method. Here's what you do:

    First, ensure you are in DEV MODE. If you don't know how to do this, check my post here:

    http://forums.precentral.net/hp-touc...ted-guide.html

    Go into webOS quick install on your home pc - you can find it here:

    http://forums.precentral.net/canuck-...-v4-2-3-a.html

    Run the program, select the TOOLS tab, and pick LINUX COMMANDLINE. Make sure your browser is closed on the touchpad.

    You should now be in a terminal at a command line looking at your touchpad .

    Now type the following -exactly- (ALL ON ONE LINE, not two lines):

    cp /usr/lib/BrowserServerPlugins/libflashplayer.so /usr/lib/BrowserServerPlugins/libflashplayer.so.bak

    Now type:

    cd /usr/lib/BrowserServerPlugins

    Now type (again, ALL ON ONE LINE):

    sed -i 's/WEB 10/WIN 10/' libflashplayer.so



    TADA, hulu works.

    Want to reverse the process? Simply type (ALL ONE LINE):
    cp /usr/lib/BrowserServerPlugins/libflashplayer.so.bak /usr/lib/BrowserServerPlugins/libflashplayer.so
    I can't get this to work. Kind of a newbie. Please help me. Now Hulu page won't even open.
    HP Touchpad 32GB , Treo 650, Treo 600
    webOS 3.0.4
  11. #111  
    Quote Originally Posted by thurman View Post
    I can't get this to work. Kind of a newbie. Please help me. Now Hulu page won't even open.
    Did you follow the guide exactly?

    Did you reboot your touchpad at the end and try to log into hulu?
  12. #112  
    If anyone's interested, this also enabled the BBC Radio iPlayer. Listening to Yes Minister as I type!!
  13. thurman's Avatar
    Posts
    60 Posts
    Global Posts
    235 Global Posts
    #113  
    Quote Originally Posted by ncinerate View Post
    Did you follow the guide exactly?

    Did you reboot your touchpad at the end and try to log into hulu?
    I didn't reboot. I tried to log into Hulu
    HP Touchpad 32GB , Treo 650, Treo 600
    webOS 3.0.4
  14. thurman's Avatar
    Posts
    60 Posts
    Global Posts
    235 Global Posts
    #114  
    After going into the Linux commandline and copying the lines into the command lines I closed the window and tried to go into hulu on the tp. Did I mess up something
    HP Touchpad 32GB , Treo 650, Treo 600
    webOS 3.0.4
  15. #115  
    Quote Originally Posted by thurman View Post
    After going into the Linux commandline and copying the lines into the command lines I closed the window and tried to go into hulu on the tp. Did I mess up something
    That shouldnt have messed anything up. What's happening when you go to hulu?

    Reboot the touchpad and see if it's working.
  16. #116  
    Quote Originally Posted by ncinerate View Post
    No worries, you probably followed my original FLAWED instructions.

    Listen, all you did was moved the file instead of copying it - it's not a problem and easily fixed. You need to copy the file back from the backup, then run the sed command.

    So type (all one line):

    cp /usr/lib/BrowserServerPlugins/libflashplayer.so.bak /usr/lib/BrowserServerPlugins/libflashplayer.so

    Then run the sed command.

    I apologize for the screw-up on my end.

    Nice job man. After the Doctor made my hair turn gray, I said why not try again? And, we're good to go!!! Nice work homie.
    I love Nerdy Girls.
    Oh... I should totally follow this BAMF www.twitter.com/demiroquai
  17. #117  
    As a linux newbie it took me three tries to figure it out. Get your TP all hooked up and open the linux command line. Then copy and ctrl-v this:

    cd /

    -hit return then copy and ctrl-v:

    cp /usr/lib/BrowserServerPlugins/libflashplayer.so /usr/lib/BrowserServerPlugins/libflashplayer.so.bak

    -hit return-copy and ctrl-v:

    sed -i 's/WEB 10/WIN 10/' /usr/lib/BrowserServerPlugins/libflashplayer.so

    -hit return then copy and ctrl-v:

    reboot

    -hit return-

    Then your touchpad should reboot and you're good to go.

    I don't give a monkey's about Hulu, but iPlayer FTW!!!
    Last edited by Bollybolly; 08/25/2011 at 04:57 PM. Reason: left out an enter
  18. omullins's Avatar
    Posts
    95 Posts
    Global Posts
    115 Global Posts
    #118  
    Quote Originally Posted by Abyssul View Post
    New wiki page:

    Hulu Fix - WebOS Internals

    Contribute to it if you have something to add.
    WOSQI method worked like a charm!
  19. #119  
    I can verify that ncinerate's tweak works. Now if I could just get my flash a little smoother.
  20. thurman's Avatar
    Posts
    60 Posts
    Global Posts
    235 Global Posts
    #120  
    Ok I will start over from the top.

    I copy each line, paste it into the command line. After each line I hit enter and after I have completed all of this reboot correct?
    HP Touchpad 32GB , Treo 650, Treo 600
    webOS 3.0.4

Posting Permissions