Results 1 to 19 of 19
  1.    #1  
    Hello-

    Just wondering if someone can walk me through the process of accessing the wpa_supplicant.conf file and updating it. I have the settings but I have no idea how to access the file to edit it.

    TIA
  2. davegarbs's Avatar
    Posts
    27 Posts
    Global Posts
    29 Global Posts
    #2  
    Use webOS quick install to launch a novacom terminal. From there, I prefer to just kill the running wpa_supplicant and relaunch it with a different conf file. Use ps to look at the default process to determine what flags you'll need.
  3.    #3  
    Quote Originally Posted by davegarbs View Post
    Use webOS quick install to launch a novacom terminal. From there, I prefer to just kill the running wpa_supplicant and relaunch it with a different conf file. Use ps to look at the default process to determine what flags you'll need.
    Thanks for the speedy response. I think i'll need a little more detail. I'm not used to mucking around in terminals. I guess everything can't have a GUI lol.
  4. #4  
    Where is wpa_supplicant.conf? You could probably use Internalz Pro to edit it then restart the device
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  5. akshunj's Avatar
    Posts
    379 Posts
    Global Posts
    380 Global Posts
    #5  
    It's in /usr/sbin
  6.    #6  
    Quote Originally Posted by Jason Robitaille View Post
    Where is wpa_supplicant.conf? You could probably use Internalz Pro to edit it then restart the device
    I'm trying to use Internalz Pro but I can't scroll down to wpa_supplicant. It's there but the screen won't permanently scroll down below vpnc-disconnect. There are 4 files after that but I can't get to them.

    EDIT: If I order the list by size I can get to wpa_supplicant but I can't edit it because it says no file handler found for /usr/sbin/wpa_supplicant

    I copied it to the downloads folder so I could just enable USB Drive support to edit it on my Mac and place it back. However, when I try to open it using TextEdit there is a bunch of unreadable text.

    I was expecting to see something like:
    Quote Originally Posted by ecko04
    ctrl_interface=/var/run/wpa_supplicant
    network={
    ssid="psu"
    mode=0
    proto=WPA2
    key_mgmt=WPA-EAP
    auth_alg=OPEN
    eap=TTLS
    identity="USERNAME"
    anonymous_identity="USERNAME"
    password="PASSWORD"
    ca_cert="/etc/cert/ca.cer"
    phase2="auth=PAP"
    priority=5
    }
    EDIT After messing around for a minute, I came to the realization that I shouldn't have been editing wpa_supplicant but instead CREATING a new wpa_supplicant file that should go into /var/run/wpa_supplicant then what I need to do is kill /usr/sbin/wpa_supplicant and start my own *I THINK*

    Which brings me to my next question, how do I access the terminal on the TouchPad?
    Last edited by ecko04; 08/25/2011 at 08:05 AM.
  7. #7  
    Quote Originally Posted by ecko04 View Post
    I'm trying to use Internalz Pro but I can't scroll down to wpa_supplicant. It's there but the screen won't permanently scroll down below vpnc-disconnect. There are 4 files after that but I can't get to them.

    EDIT: If I order the list by size I can get to wpa_supplicant but I can't edit it because it says no file handler found for /usr/sbin/wpa_supplicant
    That would be the wpa_supplicant binary. I believe you're looking for wpa_supplicant.conf, the text file with the configuration
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  8.    #8  
    Quote Originally Posted by Jason Robitaille View Post
    That would be the wpa_supplicant binary. I believe you're looking for wpa_supplicant.conf, the text file with the configuration
    Exactly
  9.    #9  
    I've tried & failed to write a successful wpa_suppicant configuration
  10.    #10  
    Here are the details of the network if someone wants to give it a shot


    SSID (aka, Network Name): psu *note that the SSID is case sensitive and must be all lower case
    Network Type: Infrastructure
    Security: WPA2-Enterprise (not WPA2-PSK)
    Encryption: AES
    Authentication Type: EAP-TTLS
    Authentication Protocol: PAP
    Certificate Authority: Thawte Premium Server CA
    Authentication Server: radius1.aset.psu.edu

    I tried this to no avail:

    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    network={
    ssid="psu"
    scan_ssid=1
    key_mgmt=WPA2-EAP
    eap=TTLS
    identity="username"
    anonymous_identity="username"
    password="password"
    ca_cert="/media/internal/downloads/ca.pem"
    phase2="auth=PAP"
    }
  11. akshunj's Avatar
    Posts
    379 Posts
    Global Posts
    380 Global Posts
    #11  
    My bad guys, I obviously didn't read the first post very closely.
  12. libray's Avatar
    Posts
    195 Posts
    Global Posts
    204 Global Posts
    #12  
    Usually wpa_supplicant.conf goes in /etc. Make sure to look for conf and not the others because:

    /usr/sbin/wpa_suplicant is the binary as you found.

    /var/run/wpa_supplicant has the process id and should only be written by the binary
    so control jobs can control and kill the running binary.

    Helpful tip, if you have a terminal via the terminal app or novaterm try the
    following command to help find where the binary expects the conf to be.

    strings /usr/sbin/wpa_supplicant | grep conf
    Palm III -> Treo 90 -> Treo 650 -> Motorola Q -> Treo 755p -> Pixi -> Sprint FrankenPixi+ -> Blackberry Bold 9930
  13. #13  
    To any other new Touchpad owners trying to connect to corporate wifi's, I've tried the above so far with no success. I extracted my wpa_supplicant.conf off my Android device (nook color), and copied it into the /etc directory on the Touchpad - rebooted device, still a no go.

    My corporate wifi is 802.1x WEP, with EAP TTLS and PAP.

    If you issue the "strings /usr/sbin/wpa_supplicant | grep TTLS" or use other search terms, you will see that there are references in this compiled binary file for various enterprise level wifi settings. I've just had no luck figuring out where to make the right edits.

    I also did a "find" on wpa_supplicant.conf files across the system, and only find the one I had placed in /etc.
  14. #14  
    Alright...now I'm doing what one of the other responses said to do.

    1. ps -e -f > /media/internal/downloads/output.txt
    This prints out current running processes (verbosely) to a text file, search and find wpa_supplicant and see how it was launched.

    2. kill -9 2231
    This kills, with extreme prejudice, the currently running process ID for wpa_supplicant (your PID number will vary)

    3. wpa_supplicant -D wext -B -c /etc/wpa_supplicant.conf -i eth0
    This relaunches wpa_supplicant my own configuration.

    4. ??? Profit ?

    Not sure where I'm at now. I've reloaded the .conf file, and I can verify its running with another ps -e, but I'm not seeing the connection added to System > WiFi "Stored Profiles".

    On android, now would be the time to turn off/on wifi and it would magically work. Boo.
  15. #15  
    Ok, now I know from another thread that the "Stored Profiles" is located here:

    /var/preferences/com.palm.wifi/prefsDB.sl

    You can pull that file using Nova, then edit it using the SQL lite DB browser, but all you get is an encrypted data chunk for the wifi profiles

    Was hoping I could manually add a profile there
  16. #16  
    Still no progress...

    I pulled the wpa_supplicant.conf off my *working* Nook Color, which runs Android 2.3.3 CM7 and can connect to the enterprise 802.1x network here at work just fine. No dice, doesn't auto join the network.

    Might just be blocked from doing this on the Touchpad until CM7 + android is ported.
  17. #17  
    I had to drop the anonymous_identity line from the custom configuration file and remove the certificates from the certificate manager to get the connection to work.

    This won't fix 'no network' errors if you do connect. (EDIT: if you are connected any wireless network before restarting wpa_supplicant you'll get the benefits of the connection and fool apps into thinking the wifi app set it up.)

    If wpa_cli were installed, you could push a custom stanza into the /tmp/.wpa_supplicant.conf file which the running Wifi app spawned copy of wpa_supplicate uses. Probably still fail as above, breaking some applications like the store.

    Also, pkill is available. You kill the running wpa_supplicant with

    pkill wpa_supplicant

    and not worry about the PID.

    This is easier to troubleshoot if you watch the /var/log/messages file with less in a separate novaterm Linux Command Line. I noticed that the wifi client kept trying to use WEP to talk to the Enterprise WPA2 connection. So, even if you could inject the proper configuration into that SQLite DB, the wifi app is probably to broken to use it properly.
    Last edited by waveclaw; 08/29/2011 at 02:24 PM. Reason: workaround for no network errors
  18. #18  
    you must have rooted device

    download es file explorer from one market it has a blue folder icon

    open it and active write permissions in setting

    then go to the base system folder it;s name is device

    and search for wifi

    you will find about three folders or more that have the same name

    one of there it have a wpa_supplicant.conf file

    this file must contain passwords of your saved wireless networks

    you will find in it the configurations

    add your code by editing it

    and save
    restart your device

    you will have the new configs


    please if you find it helpful give me a small thank>>>
  19. #19  
    This is a webos forum not android, so no "rooting" and no es explorer.

Posting Permissions