Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28
  1. Prey521's Avatar
    Posts
    15 Posts
    Global Posts
    433 Global Posts
       #21  
    OH, BTW, the lint wasn't there when I first opened it since I thoroughly inspected the screen before I started tweaking. And of course after I apply all of the Preware patches and kernel running @ 1.8ghz this crap happens. So ****ed off right now!!!
  2. MincerRay's Avatar
    Posts
    79 Posts
    Global Posts
    82 Global Posts
    #22  
    One of the TP's I bought has this same white spot. My wife is the one using it. We've been debating whether to have it fixed and risk god knows what, or live with it as the rest of the TP is screwed together well. So far we have been living with it...
  3. #23  
    Quote Originally Posted by Prey521 View Post
    Well guess what....my replacement came in and it has some crap underneath the screen....looks like a piece of white lint maybe 1/4 of an inch long and you can see it even when the screen is off......*** is going on!! I have the worst luck with tablets.

    I have the Playbook and had to send it in once for an issue with power.....they repaired the power issue but when I received it, one of the speakers were blown, so they fixed one issue and created another one and had to have that one replaced under warranty. And now this!

    Now to call them again....UGH!!!!!!!!
    Damn. Maybe I'll just learn to live with it. That sucks man.
  4. Prey521's Avatar
    Posts
    15 Posts
    Global Posts
    433 Global Posts
       #24  
    Just got off of the phone with them....they're sending me another one and didn't apply the hold on my credit card like they did the last time. I'm hoping that this one arrives issue free!!! Dying to start using it already without issues!
  5. Prey521's Avatar
    Posts
    15 Posts
    Global Posts
    433 Global Posts
       #25  
    So guess what....the TP that they sent me to replace the TP that had something underneath the screen, ALSO has something underneath the screen! OMG this is ridiculous!! What kind of quality control are they doing when these are being put together? WOW, I'm glad I only paid $150 for this. This one is NOT going back though, it's very very small and near the top by the camera so it doesn't bother me. HP should be ashamed of themselves.
  6. #26  
    Just went thru the same stuff mentioned here. I have a white pressure spot and raised screen (with touchpad in landscape and Home button to the right, the problem is in the lower left corner). I'm convinced there is something underneath the screen pressing up in that area where the spot is, causing both issues. On some webpage I saw a picture of a touchpad with the screen off and it looked like there was a bundle of wires or something right in the same spot where my issue is. Anyway, I called support, sent in the touchpad, and 7 days later I get it back....and nothing has been fixed. This is ridiculous.
  7. Prey521's Avatar
    Posts
    15 Posts
    Global Posts
    433 Global Posts
       #27  
    Wow they did the same thing to you to? That is ridiculous! Call them back asap.
  8. #28  
    Quote Originally Posted by Prey521 View Post
    Wow they did the same thing to you to? That is ridiculous! Call them back asap.
    I plan to on Monday if I can find the time. I think I'm going to ask for the advanced replacement thing and demand the fee be waived like some of you did. I doubt I'll keep sending this thing in over and over otherwise. Its just not worth the hassle.

    I think the culprit could be phone support not getting the problem right. I had a guy on the phone that I could barely understand what he was even saying.

    Update: Called today and got the advanced replacement. No $60 charge and I refused to have a hold on my card greater than what I paid (they quoted $365 or something), so $150 for that. Hopefully I get a defect free replacement.
    Last edited by pshanks20; 09/25/2011 at 12:02 PM.
Page 2 of 2 FirstFirst 12

Posting Permissions