Page 3 of 3 FirstFirst 123
Results 41 to 53 of 53
Like Tree6Likes
  1. #41  
    I've had this problem off and on for some time.
    my only work around was to delete my talk google account
    and re sign in,it has worked every time so far.

    BTW I'm using netgear'
  2. wz2b's Avatar
    Posts
    4 Posts
    Global Posts
    5 Global Posts
    #42  
    I have been trying to fix the problem with google talk on the touchpad, and think I know what the problem is -- and how to "fix" it. I'm not sure how to make a permanent fix or patch that will work for everybody, but here goes for me.

    I found the strange piece of code in the source for imlibpurpletransport that remaps @gmail.com to xmpp server talk.google.com. I also found that the logic in that line of code is screwed up:

    Code:
    if (strcmp(prplProtocolId, "prpl-jabber") == 0  && g_str_has_suffix(transportFriendlyUserName, "@gmail.com") == FALSE && g_str_has_suffix(transportFriendlyUserName, "@googlemail.com") == FALSE) {
       remap connection to talk.google.com
    }
    Look closely though ... for that condition to be true, the line has to not end in @gmail.com and not end in @googlemail.com. However, the problem here is in trying to log into something that's user@gmail.com. So something in that code is very sketchy.

    But that's really beside the point.

    People were saying this problem was associated with specific routers. Seemed unlikely to me, until someone on freenode told me to use tcpdump and look at the name resolution. WebOS is trying to use SRV records to look up the xmpp-client service. Unfortunately, dnsmasq (on my OpenWRT WRT54GL) doesn't appear able to answer those messages. I suspect this may be the case with other routers.

    When that happens, strace shows that imlibpurpletransport merely tries to connect to port 5222 on gmail.com. I tested a dozen or so addresses that come from the gmail.com round robin name servers, and NONE of them appeared to be listening on port 5222.

    The answer, for me at least, was to not use my own DNS. I went into /etc/dnsmasq.palm.conf and did this:

    * uncomment #no-resolv
    * add this line: server=8.8.8.8

    What this does is forces it to use a proper, static name server - in this case one of the google public nameservers - that is able to answer the request for the SRV record properly.

    This working depends on the local router/firewall allowing you to make requests to outside nameservers. I suspect this is probably OK in most cases, though if you have a split dns horizon this will spell trouble.

    I hope this helps. Questions/comments please reply.

    --Chris
  3. #43  
    If all you want to do is SMS, use/install google voice, go to the website and message to your heart's content. I still have not been able to place a voice call, but I'll keep at it.
  4. wz2b's Avatar
    Posts
    4 Posts
    Global Posts
    5 Global Posts
    #44  
    All,

    I have confirmed the problem now to be the dns proxy. Older versions of dnsmasq don't proxy srv requests.

    Newer version on a router running 'tomato' works fine:

    Dnsmasq version 2.57 Copyright (c) 2000-2011 Simon Kelley

    ;; ANSWER SECTION:
    _xmpp-client._tcp.gmail.com. 62492 IN SRV 5 0 5222 talk.l.google.com.
    _xmpp-client._tcp.gmail.com. 62492 IN SRV 20 0 5222 alt1.talk.l.google.com.
    _xmpp-client._tcp.gmail.com. 62492 IN SRV 20 0 5222 alt4.talk.l.google.com.
    _xmpp-client._tcp.gmail.com. 62492 IN SRV 20 0 5222 alt2.talk.l.google.com.
    _xmpp-client._tcp.gmail.com. 62492 IN SRV 20 0 5222 alt3.talk.l.google.com.


    Older version on my openwrt doesn't work:

    Dnsmasq version 2.47 Copyright (C) 2000-2009 Simon Kelley

    $ dig srv _xmpp-client._tcp.gmail.com
    ; <<>> DiG 9.5.1-P2.1 <<>> srv _xmpp-client._tcp.gmail.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22640
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;_xmpp-client._tcp.gmail.com. IN SRV

    ;; Query time: 2 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Thu Oct 6 10:29:51 2011
    ;; MSG SIZE rcvd: 45

    or, via nslookup, it's easier to see

    $ nslookup
    > set type=srv
    > _xmpp-client._tcp.gmail.com
    Server: 192.168.0.1
    Address: 192.168.0.1#53

    *** Can't find _xmpp-client._tcp.gmail.com: No answer


    So there are two problems here, one of them being the router, and the other being imlibpurpletransport not doing the right thing when it doesn't get a response to the SRV query.

    Does anybody know if/how we can get this information to HP? Or if anybody would care?

    --Chris
  5. #45  
    Make sure your dnsmasq configuration does not have the "-f" option or "filterwin2k". This will strip all SRV lookups. Most likely your problem.
  6. #46  
    Thanks, i am glad i was right from the get go that it has something to do with routers. i just got lazy and decided to use chat in the browser. HP dropped the ball and gave up on me, i guess i could have nagged more but i got patch hungry and wanted linux so did not want to keep re setting up. i will see what i can do with dns and see if i can fix, hopefully someone more computer savy can make a patch for this.
  7. #47  
    Seem weird this wasnt addressed in last update, I have tried 3 routers, and also my iphones hot spot and still no go,

    Is there a patch for this?
  8. #48  
    i am having the same problems since day 1.

    messaging works on every network except mine at home.

    i also have a netgear router. =(
    -Posted with my HP Touchpad 32GB.
  9. #49  
    I had the same problem and solved it as follows.

    1. Find the IP-addresses of the primary and secondary DNS-servers for your internet provider. I found these in my router.
    2. On the TouchPad go to wifi settings and hit the active wifi connection between TP and router. Remember the IP address of your TP which is shown and also the subnet.
    3. Set 'automatic IP settings' to OFF. Now enter the IP address from step 2 and the subnet. The gateway will be there automatically.
    4. The most important step. In the first subnet field enter the IP address of the primary DNS server of your internet provider and in the second subnet field fill in the IP address of the secondary DNS server of your internet provider.
    5. Save the settings on the TP. In your router you can make sure that the TP always gets the same IP address assigned, but this should be optional for this solution.

    You might need to turn wifi off and on again on the TP or else restart the TP. Hope this helps.
    glassed and MISC like this.
  10. #50  
    Quote Originally Posted by Fresh View Post
    I had the same problem and solved it as follows.

    1. Find the IP-addresses of the primary and secondary DNS-servers for your internet provider. I found these in my router.
    2. On the TouchPad go to wifi settings and hit the active wifi connection between TP and router. Remember the IP address of your TP which is shown and also the subnet.
    3. Set 'automatic IP settings' to OFF. Now enter the IP address from step 2 and the subnet. The gateway will be there automatically.
    4. The most important step. In the first subnet field enter the IP address of the primary DNS server of your internet provider and in the second subnet field fill in the IP address of the secondary DNS server of your internet provider.
    5. Save the settings on the TP. In your router you can make sure that the TP always gets the same IP address assigned, but this should be optional for this solution.

    You might need to turn wifi off and on again on the TP or else restart the TP. Hope this helps.
    well well well....

    THANK YOU!!! Worked perfect
  11. #51  
    Quote Originally Posted by Fresh View Post
    I had the same problem and solved it as follows.

    1. Find the IP-addresses of the primary and secondary DNS-servers for your internet provider. I found these in my router.
    2. On the TouchPad go to wifi settings and hit the active wifi connection between TP and router. Remember the IP address of your TP which is shown and also the subnet.
    3. Set 'automatic IP settings' to OFF. Now enter the IP address from step 2 and the subnet. The gateway will be there automatically.
    4. The most important step. In the first subnet field enter the IP address of the primary DNS server of your internet provider and in the second subnet field fill in the IP address of the secondary DNS server of your internet provider.
    5. Save the settings on the TP. In your router you can make sure that the TP always gets the same IP address assigned, but this should be optional for this solution.

    You might need to turn wifi off and on again on the TP or else restart the TP. Hope this helps.
    Thanks you saved my day.

    If you are not able to find the primary and secondary DNS servers from the modem/router's settings, you can use Google's Public DNS servers - 8.8.8.8 and 8.8.4.4

    These are what I used and it solved my problem.
  12. #52  
    Oh my goodness it works!!!!!!!!!!!!!!
    -Posted with my HP Touchpad 32GB.
  13. #53  
    The last post is a half year ago, but I've created a patch for this problem!

    See here:[patch] Google Talk login fix
Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions