Page 2 of 2 FirstFirst 12
Results 21 to 23 of 23
Like Tree4Likes
  1. Clayman's Avatar
    Posts
    8 Posts
    Global Posts
    21 Global Posts
    #21  
    jsteelio, yes I did figure it out...

    The TouchPad cannot connect to an Adhoc share on the Mac, has to be through a normal router. With the normal router you can connect with WPA/2 which is better than the WEP share limited connection on the Mac. I did find out that the next version of PDANET on the iPhone (Version 4 or higher) should be able to do this, but that is not available yet.

    So to get around this, I connect to my TouchPad to my WiFi router and connect to the Mac share via the home wired intranet.

    Here is the description of what I did... In my case, I was using an iPhone with USB tethering to Mac OS X Lion and sharing that on my internal network. I do this because I have no internet access any other way then the iPhone and the intranet I have is just for distribution. My intranet does have a WiFi on it, so portable devices like the TP can connect to the WiFi -> Network hub -> Mac -> iPhone for access to internet.

    1) In System Preferences you will want to select sharing from iPhone USB to Ethernet. Go ahead and enable.
    2) Connect your Mac to your network using an Ethernet cable.
    3) Open up Terminal on your Mac by going to Applications > Utilities and type ifconfig. en0 should be the first one and this is your connection for the share. You should see inet xxx.xxx.xxx.xxx some where in the en0 section. I believe it defaults to 192.168.2.1 and can not be changed that I know of, but I am not absolutely sure. Assure you have no other devices on your network with that IP address.
    4) On the Mac, go to System Preferences > Network> Select iPhone USB and the assigned IP will be shown to the right.* Mine was 172.20.10.2. This is a result of enabling Internet Connect Sharing on the Mac and has nothing to do with the computer's IP at this point.
    5) On the Touchpad, I connected to my WiFi access point (can't be Adhoc, has to be a true access point/router). When connected, bring up the card for the connection on the card and go to manual IP setup.* You will now have to put some numbers in manually.
    6) For the IP you will want to enter the number you found in en0 +1 (or more), so for me that was 192.168.2.3. Subnet should be 255.255.255.0.
    7) For Router/Gateway enter the en0 inet number from earlier.* Mine was 192.168.2.1
    8) DNS has to be defined too. In the case of sharing the iPhone connection, it is not as transparent and you must go to a terminal window on the Mac and enter "cat /etc/resolv.conf". The response will show the current DNS being used. For me, that was 172.26.38.1 and 172.26.38.2.
    9) Rather than using both of these DNS numbers, I used only one and entered 172.20.10.2 (IP for the iPhone from the Mac Networking panel) to assure it looks there too. Not sure if this is necessary, but it works and I have not experimented with changing.

    I find that every once in a while I have to toggle the Internet sharing on the Mac... sort of like it stalls. If your touchpad looses the WiFi connection, you will have to reenter the manual IP settings.
    Last edited by Clayman; 09/06/2011 at 10:43 AM.
  2. #22  
    Quote Originally Posted by cobrakon View Post
    Nope. Supported just fine. Like the other poster, the variable here is your *router* not the touchpad. I've been on a Linksys and a Netgear with WEP64 and WEP128 and it works fine.

    The TPad does have issue with Enterprise WEP 802.11x with LEAP. Try visiting a friend with wireless on a different make router and confirm. Rule out the variables first.
    Yes I also think it is router and software specific. I tried connecting to my parents old router using WEP and it did not work for me either. In their case, I just switched them to WPA/WPA2 and problem went away...which will work as long as everything you have support WPA/WPA2. Sorli...
  3. LurkerX's Avatar
    Posts
    357 Posts
    Global Posts
    367 Global Posts
    #23  
    If you have equipment that can't handle WPA/WPA2, it's time to upgrade it.
Page 2 of 2 FirstFirst 12

Posting Permissions