Page 2 of 2 FirstFirst 12
Results 21 to 35 of 35
Like Tree2Likes
  1.    #22  
    my issue was fixed with 3.0.2
  2. #23  
    I'm not able to get on my university's wpa2 enterprise LEAP network even with their security certificate installed. I'd be willing to donate to whomever makes a patch for this.
  3. #24  
    Quote Originally Posted by wannabesean1123 View Post
    I'm not able to get on my university's wpa2 enterprise LEAP network even with their security certificate installed. I'd be willing to donate to whomever makes a patch for this.
    Same here with both - I will donate for whoever helps out and makes a patch.
  4. #25  
    Quote Originally Posted by davegarbs View Post
    No call from HP yesterday...why am I not surprised?

    If you guys want to do things from the command line, you can use wpa_cli and craft a working wpa_supplicant.conf file. Follow the instructions here:

    Advanced Wifi - WebOS Internals

    I changed my script to have the following:

    cp /my_wpa_supplicant.conf /tmp/.wpa_supplicant.conf
    chmod a-w /tmp/.wpa_supplicant.conf
    /usr/sbin/wpa_cli reconfigure

    And here's my my_wpa_supplicant.conf file for a my network:

    ctrl_interface=/var/run/wpa_supplicant/
    update_config=1
    network={
    ssid="Your SSID"
    key_mgmt=WPA-EAP IEEE8021X
    pairwise=CCMP
    group=CCMP
    eap=PEAP
    identity="your_username"
    password="your_password"
    phase2="auth=MSCHAPV2"
    }

    Open the wifi preferences app and attempt to connect to the network. Enter your credentials when prompted (you can enter anything since the new config file with override them). As soon as you hit sign in, execute the script above. You have to be very fast.
    Did you need the packages suggested in the Advanced Wifi wiki or did you just need to write the script and supplicant config?
  5. #26  
    I'm having trouble installing the debian packages. Anyone know how to accomplish that task?
  6. pec
    pec is offline
    pec's Avatar
    Posts
    4 Posts
    #27  
    As of today, my Pre2 is now working with our WPA/WPA2 Enterprise WiFi network. I first encountered this problem after upgrading my Pre+ to webOS 1.4.5. I have since moved on to an unlocked Pre 2 on webOS 2.1, but it had the same problem.

    The issue was with the EAP/MSCHAPv2 authentication protocol. WebOS tries this protocol first, and it hangs halfway through authentication causing the whole authentication process to fail. Nobody else uses this for wireless authentication, and the networking staff thought it was strange to see it being tried. After they disabled EAP/MSCHAPv2 for wireless authentication, webOS moves on to using EAP/PEAP which work fine.

    regards,
    -pierce
  7. #28  
    Quote Originally Posted by pec View Post
    As of today, my Pre2 is now working with our WPA/WPA2 Enterprise WiFi network. I first encountered this problem after upgrading my Pre+ to webOS 1.4.5. I have since moved on to an unlocked Pre 2 on webOS 2.1, but it had the same problem.

    The issue was with the EAP/MSCHAPv2 authentication protocol. WebOS tries this protocol first, and it hangs halfway through authentication causing the whole authentication process to fail. Nobody else uses this for wireless authentication, and the networking staff thought it was strange to see it being tried. After they disabled EAP/MSCHAPv2 for wireless authentication, webOS moves on to using EAP/PEAP which work fine.

    regards,
    -pierce
    how did they disable EAP/MSCHAPv2?
  8. #29  
    Quote Originally Posted by NavasC View Post
    I'm also having this same issue at my school's campus. We tried loading the campus' security certificate on my touchpad and that did not help. We have a WPA2 802.11x Enterprise, PEAP wireless network. It also has a Phase 2 Authentication with MSCHAPV2. Does anyone know if it's possible to connect under these settings?
    My University has the same WiFi configuration.

    Any updates yet guys?
  9. d0u8l3m's Avatar
    Posts
    196 Posts
    Global Posts
    197 Global Posts
    #30  
    anything anyone? my dad is bringing me my touch pad on saturday and i still cant get the universities network working on my pre 2 =/
  10. #31  
    No updates
  11. #32  
    Any updates? Still unable to connect to my University's WPA2-Enterprise network.
  12. d0u8l3m's Avatar
    Posts
    196 Posts
    Global Posts
    197 Global Posts
    #33  
    sadly i tweeted webosinternals and haven't gotten a reply...guess the're busy with all the pre 3 stuff =[
  13. #34  
    3.0.4 fixed this!!! So happy right now. I can finally connect to my university's network.
    MobileBill23 and newsalt like this.
  14. #35  
    yes works for me too at my university!!
Page 2 of 2 FirstFirst 12

Posting Permissions