Results 1 to 17 of 17
Like Tree1Likes
  • 1 Post By Mutoidi
  1.    #1  
    Hello. Recently I've been experiencing a very annoying issue with my Pre 3: its App Catalog doesn't manage to install any app I download from its lists, Evernote for example. On the other side, Preware works perfectly. I can't understand what's going on, I need help, please.

    EDIT: The source of the problem really is the Catalog Update. It seems like the OS can't recognize it anymore. It appears like a blank app in the Software Manager and although I tap on "Delete" nothing happens. I try with Preware, which succeeds in removing it, but after rebooting App Catalog still says I've already installed it and Preware can't see it anymore. So I'm stuck: I can't definitely uninstall it, I can't re-install it. Help!
    Last edited by WebOSLloyd; 05/27/2014 at 03:09 PM.
  2. MikeN68's Avatar
    Posts
    332 Posts
    Global Posts
    333 Global Posts
    #2  
    I guess the first question would be have you updated the certificate yet? Surely by now you would have unless you've recently Dr'd and just missed out this step.
  3.    #3  
    Quote Originally Posted by MikeN68 View Post
    I guess the first question would be have you updated the certificate yet? Surely by now you would have unless you've recently Dr'd and just missed out this step.
    Yes I did, a long time ago. That's why I can't understand what's going on...
    Pre 2 (16 GB, dismissed), Pre 3 (8 GB, dismissed), Wi-Fi TouchPad (32 GB). Moved to Android (Nexus 5) in late 2014.
  4. #4  
    Are there error messages, the grey spinner or just nothing happening?
  5.    #5  
    It downloads the app and shortly after it says: "Couldn't install" showing the yellow ! triangle. This happens every time I try to re-download the app.
  6. #6  
    In your place, I could try to install the certificate again... of course, I'm tolding about me...


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  7.    #7  
    The source of the problem really is the Catalog Update. It seems like the OS can't recognize it anymore. It appears like a blank app in the Software Manager and although I tap on "Delete" nothing happens. I try with Preware, which succeeds in removing it, but after rebooting App Catalog still says I've already installed it and Preware can't see it anymore. So I'm stuck: I can't definitely uninstall it, I can't re-install it. Help!
  8. #8  
    Your problem is the Security Certificate is not updated.

    You have to set the date to 22 July 2013, making sure that you turn the network time off.

    That will let you update the catalog.

    Reboot, and do it again if you want to be sure it worked (it may take a couple of times to get it right).

    Then return the time setting to network, and the HP catalog should be updated and apps will install as the Security Certificate (which they packaged within the catalog update) will have been update.

    For more details, I had done a thread about just this a while back:
    Root certificate fix for WebOS- A MUST FOR EVERYONE
    Palm M105 > M130 > Zire 71 > Zire 72 >TX > Lifedrive > Pre > Pre2 >Touchpad > Pre3(8GB) > Pre3 (16GB)
    I see a pattern...
  9.    #9  
    Quote Originally Posted by imfallen_angel View Post
    Your problem is the Security Certificate is not updated.

    You have to set the date to 22 July 2013, making sure that you turn the network time off.

    That will let you update the catalog.

    Reboot, and do it again if you want to be sure it worked (it may take a couple of times to get it right).

    Then return the time setting to network, and the HP catalog should be updated and apps will install as the Security Certificate (which they packaged within the catalog update) will have been update.

    For more details, I had done a thread about just this a while back:
    Root certificate fix for WebOS- A MUST FOR EVERYONE
    Thanks, but unfortunately I have problems with the Update being stuck between installed and uninstalled, as I said above your post.
  10.    #10  
    No one knows how to manually remove the Catalog Update?
  11.    #11  
    Please, anyone?
    Pre 2 (16 GB, dismissed), Pre 3 (8 GB, dismissed), Wi-Fi TouchPad (32 GB). Moved to Android (Nexus 5) in late 2014.
  12. #12  
    Quote Originally Posted by WebOSLloyd View Post
    It downloads the app and shortly after it says: "Couldn't install" showing the yellow ! triangle. This happens every time I try to re-download the app.
    Hi Lloyd,

    I know this probably wont help but maybe a doctor might be required if someone with better knowledge than I can't help out?

    Can you get in to the Software manager and remove from there? Perhaps remove the certificate patch set time to say 2012 reinstall, reboot set time back to 2014?

    Barry
  13. #13  
    Use Internalz to go to:

    /etc/ssl/certs/trustedcerts/PalmWebOS.pem

    and 'delete'.

    That should successfully nuke the HP Catalog Update.. which may hopefully in turn allow you ro reboot & successfully reinstall etc etc?


    TP 32Gb 4G. 3.0.5 / CM10. ~ Pre3 16Gb GSM. 2.2.4. ~ TS2 BT Audio-Dock ~ HP iPaq. hx-2790b.
    TP 32Gb Wifi. 3.0.5 / CM10. ~ Veer (Wht.) 8Gb GSM. 2.2.4. ~ HP Omen-15-5206tx. 256Gb SSD. i7-O/C@3.39Ghz. Win10.
    barryb20 likes this.
  14.    #14  
    Quote Originally Posted by barryb20 View Post
    Hi Lloyd,

    I know this probably wont help but maybe a doctor might be required if someone with better knowledge than I can't help out?

    Can you get in to the Software manager and remove from there? Perhaps remove the certificate patch set time to say 2012 reinstall, reboot set time back to 2014?

    Barry
    Unfortunately the Manager doesn't work, it won't uninstall it since it only displays a blank icon with no name, showing "2.0.0" as only info and as the version of this ghost-app which can't be uninstalled.
    Quote Originally Posted by Mutoidi View Post
    Use Internalz to go to:

    /etc/ssl/certs/trustedcerts/PalmWebOS.pem

    and 'delete'.

    That should successfully nuke the HP Catalog Update.. which may hopefully in turn allow you ro reboot & successfully reinstall etc etc?

    I tried, but the App Catalog still shows it as already installed and the correlated "ghost-app" in the Software Manager still appears... It's like the Catalog Update is there and isn't there. The Doctor is the only solution...?
    Pre 2 (16 GB, dismissed), Pre 3 (8 GB, dismissed), Wi-Fi TouchPad (32 GB). Moved to Android (Nexus 5) in late 2014.
  15. #16  
    Hhmm.. sorry that didn't work.. shame to have to Dr. if you don't need to though.. but maybe you do now?
    My Pre3 (2.2.4) shows App Catalog v2.1.10000
    You are on-line & rebooting after every 'move'?

    Last edited by Mutoidi; 06/16/2014 at 06:49 AM.

    TP 32Gb 4G. 3.0.5 / CM10. ~ Pre3 16Gb GSM. 2.2.4. ~ TS2 BT Audio-Dock ~ HP iPaq. hx-2790b.
    TP 32Gb Wifi. 3.0.5 / CM10. ~ Veer (Wht.) 8Gb GSM. 2.2.4. ~ HP Omen-15-5206tx. 256Gb SSD. i7-O/C@3.39Ghz. Win10.
  16. MikeN68's Avatar
    Posts
    332 Posts
    Global Posts
    333 Global Posts
    #17  
    I know Mutoidi advised to delete and reinstall the certificate (/etc/ssl/certs/trustedcerts/PalmWebOS.pem), but did you look at the cert? It should read as expiring on 27th April 2037. If it does you have the latest cert and this (I would imagine) can be taken off any list of 'things to fix'.

    If not, you will need to update this before the AppCat work.

    I can let you have a copy of my cert if you don't have this version, but I don't know if I'm allowed to post it here. If you want it, I can send a PM and may also be able to find the appcat ipk file too - if that helps.

Similar Threads

  1. Replies: 1
    Last Post: 11/15/2013, 10:18 AM
  2. Can't download anything from the app catalog due to blank download
    By knickrox13 in forum webOS Discussion Lounge
    Replies: 3
    Last Post: 06/06/2010, 09:57 PM
  3. Downloaded - unpacked - but refuses to install.
    By eightyf0ur in forum Palm Pre and Pre Plus
    Replies: 1
    Last Post: 12/29/2009, 02:13 AM
  4. Replies: 3
    Last Post: 12/19/2009, 03:07 PM
  5. Replies: 0
    Last Post: 12/09/2009, 12:56 PM

Posting Permissions