Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 50
Like Tree14Likes
  1. #21  
    Quote Originally Posted by mr-scorpio View Post
    OK, After much nail biting .. & seeing more things needing to install,...
    BINGO! it is working... App Store 2.1.1.0.0.0 installed & ALL working
    I couldn't get WOSQI to 'see' my pre 3 until i set it into 'dev mode'....
    Many thanks Mat for your help
    Al
    You owe that man a coke. (it's the yellow button)
  2. #22  
    Quote Originally Posted by Grabber5.0 View Post
    Glad I could help! Sorry if some was a bit over your head or short on detail. I was a bit short on time, so I tried to give just enough guidance in the apps needed to do the work. That you were able to accomplish it with a little guidance is a testament to your ability.
    nice work completing a full troubleshoot for this, which probably should be re-titled and stickied, since practically every new user will need this.

    thanks for illustrating you can install ipks simply by putting in /media/internal and opening with Internalz. i didnt know that simple trick. i wonder how many other simple tricks there are that aren't widely known by should be. maybe we should start a 'my favorite trick' thread. hmmm...

    question though, after updating, did u install an app without first correcting the date?
    2nd question while it's on topic, should we be hoarding copies of our ipks in case the cat goes down someday? or, has someone already created a repository we could 'subscribe' to?
  3. #23  
    Since it wouldn't download anything with the date set back, I didn't figure it would work even after fixing the cert, so I didn't even try.

    I do think this is probably going to be the norm now, but at this point there haven't been enough reports to be sure.

    Most of what I did, if not all of it, has been posted here and there - I just pulled it all together into a step by step guide (which still needs some improvement for new folks coming in with their first webOS device, or people that (gasp!) have never done homebrew). I set out to confirm what I had seen posted a few times about the problem of not being able to install the update after setting the clock back. I had also seen a post about using the nodelete patch to save the update ipk (which I had done to try to see how it was packaged). Sometimes if you don't see something when it's first posted, you never notice it.
  4. #24  
    I'm about to do all of this again since I just reassembled and re-doctored my Sprint FrankenPre2. (Though with a different radio board, since it was already in my Sprint Pre and I didn't want to do the swap twice)
  5. #25  
    Interesting update - I forgot to set the date back (because I wasn't sitting here reading my step by step guide) when I installed the App Catalog Update using Preware, and it installed fine. I will confirm this again before updating the instructions. Also want to do it all on a 1.4.5 device, and my wife's Touchpad (what you don't think I'm going to use my Touchpad do you? )
    Last edited by Grabber5.0; 02/04/2014 at 12:22 AM.
    ananimus and TJs11thPre like this.
  6.    #26  
    Morning,
    Yes a detailed & thorough sticky thread would be good..
    I had to learn quick, & there were numerous steps to overcome that were not mentioned.
    E.G.:
    1) What is WOSQI - that is actually a desktop PC app called "WebOS Quick Install" - And it is not even a .exe but a java script, which also needs a recent version of Java on your comp.
    2) That also a separate USB driver Nova.. is also required.
    3) Does the Pre need to be in a Developer mode? - If so, a clear & reliable way to do this is needed. -Do you need to rip the back off & take the sim out etc etc...? - What code is required .... & so on.
    Plus more.....

    So i think a thorough step by step hand holding would be great!

    But once again guys many many thanks for your assistance!
    If i can help (despite my lack of experience (1 days worth)) in any way, pls let me know.
    Best
    Al
  7. GoJoe2's Avatar
    Posts
    133 Posts
    Global Posts
    172 Global Posts
    #27  
    I would like to point out that the [How To] Retain App IPKs from App Catalog Patch did not work for me because in WOSQI I got a message saying something about there was only garbage found in this path.

    What saved my day was:
    Re: App Catalog Update not working? Fixed - HP Support Forum - 3458127

    There you'll find the ipk for the catalog update. From there on can download all you previous apps just fine.

    Last thing, I want to add that this behaviour is indeed new. I doctored my Pre3 7 weeks ago and everything went fine according to the offical work around. I doctored this Pre3 again yesterday running in the problems described in this thread.

    So there might be the need for this "HowTo" at prominent place for the future!

    Best Jörg
  8. #28  
    You installed com.palm.app.appcatalogupdate_3.0.0.ipk on your Pre3 and it worked? Am asking because there is also a com.palm.app.appcatalogupdate_2.0.0.ipk that is (was) downloaded when you try updating the App Catalog on a Pre3. You would assume there's a difference.
  9. #29  
    I actually wouldn't be very surprised. Gonna have to try it.
  10. #30  
    I just installed the app catalog update ipk from my Pre2 onto a Pre with 1.4.5 and it worked fine. I had to reboot to get it to install my apps though because the 'software manager' scene of the app catalog app errors out as soon as it opens. App catalog itself is working fine though.

    Note: the primary reason I did this, aside from confirming whether it would work or not, was because the retain ipk patch (which doesn't install on 1.4.5 so I added the value manually) behaves differently on 1.4.5, so instead of leaving ipk files in the downloads directory, it left exploded ipk directories. That was actually good because I could see exactly what it was doing in the install script - just copying the new certs to /etc/ssl/certs (and one to trustedcerts, which doesn't exist on 1.4.5, so I'd bet it is the identical package for both 1.x and 2.x)
    Last edited by Grabber5.0; 02/06/2014 at 10:26 PM.
  11. c4r
    c4r is offline
    c4r's Avatar
    Posts
    57 Posts
    #31  
    Worked Great! Quick and easy.

    Thanks guys!
    Grabber5.0 likes this.
  12. #32  
    Quote Originally Posted by Grabber5.0 View Post
    I just installed the app catalog from my Pre2 onto a Pre with 1.4.5 and it worked fine. I had to reboot to get it to install my apps though because the 'software manager' scene of the app catalog app errors out as soon as it opens. App catalog itself is working fine though.

    Note: the primary reason I did this, aside from confirming whether it would work or not, was because the retain ipk patch (which doesn't install on 1.4.5 so I added the value manually) behaves differently on 1.4.5, so instead of leaving ipk files in the downloads directory, it left exploded ipk directories. That was actually good because I could see exactly what it was doing in the install script - just copying the new certs to /etc/ssl/certs (and one to trustedcerts, which doesn't exist on 1.4.5, so I'd bet it is the identical package for both 1.x and 2.x)
    After I applied this IPK and rebooted, all of the exploded IPK temp directories were gone, so either the patch actually does nothing, and they were simply not removed initially because the installs failed, or, well, that's the only reason I can think of.

    So, to confirm that the App Catalog Update IPK for 1.x and 2.x are indeed the same, I uninstalled it using Preware (since it wouldn't show in the launcher) and I resorted to the old watch the downloads folder while downloading with a copy command ready to copy the ipk to another folder... after successfully capturing the IPK, I did a binary diff and they are indeed the same exact IPK.

    All that said, since it appears that on 1.4.5 devices the failure will leave the exploded IPK sitting in the downloads folder, with no easy way to save the IPK, it seems the process would be overly cumbersome for the average user to do. Does anyone know if I can write a script to build a new IPK on-device, or kick off the installation of that exploded structure? It seems the easiest would be to host a download link for the IPK, but there's that darn copyright issue..
    Last edited by Grabber5.0; 02/12/2014 at 08:05 AM.
  13. GoJoe2's Avatar
    Posts
    133 Posts
    Global Posts
    172 Global Posts
    #33  
    Quote Originally Posted by DocJones View Post
    You installed com.palm.app.appcatalogupdate_3.0.0.ipk on your Pre3 and it worked? Am asking because there is also a com.palm.app.appcatalogupdate_2.0.0.ipk that is (was) downloaded when you try updating the App Catalog on a Pre3. You would assume there's a difference.
    Now that you mention it. Indeed, it was the 3.0.0 Version. And yes everything works just fine.
  14. #34  
    Thank you for this CURRENT thread. I'm a ranker noobie than you so I hope I get through it. I know that setting the date back worked in August for a replacement pixi I bought for a family member, but it did not work for the pre 2 I just bought to replace my dying pixi. I will try to figure my way through all this.

    I have a few questions before that though: The failure message I get when I do set the date back says download failure (for the app catalog update). The failure message I get when I have the phone on network time, so current date, is different: it says install failure. Is there a way to download and then set the time back and then install? or is that basically as complicated as following the above advice?

    Also, the first thing i did when I got the phone was OTA webos update from 2.0 to 2.1. did that make the problem worse?
  15. #35  
    Quote Originally Posted by susanhilary View Post
    Thank you for this CURRENT thread. I'm a ranker noobie than you so I hope I get through it. I know that setting the date back worked in August for a replacement pixi I bought for a family member, but it did not work for the pre 2 I just bought to replace my dying pixi. I will try to figure my way through all this.

    I have a few questions before that though: The failure message I get when I do set the date back says download failure (for the app catalog update). The failure message I get when I have the phone on network time, so current date, is different: it says install failure. Is there a way to download and then set the time back and then install? or is that basically as complicated as following the above advice?

    Also, the first thing i did when I got the phone was OTA webos update from 2.0 to 2.1. did that make the problem worse?
    Hi friend. You install this app with preware or wosqui

    https://app.box.com/s/x7vc7uuwezpj5r69iep5

    and then this

    https://app.box.com/s/2fi0zq8vg6136p0c0czk

    These apps be app catalog and update app catalog.
    I wait than fix you
  16. #36  
    Quote Originally Posted by Grabber5.0 View Post
    What I did:

    First the steps to recreate the problem:
    Signed into profile.
    Confirmed I can't download apps, including the App Catalog Update app.
    Set date to 7/22/13
    Confirmed date was 7/22/13 in device menu
    Got prompted about the update to the App Catalog - Download failed
    Tapped update failure, which opened Software Manager. Tapped the error and then "'Don't download"
    Opened App Catalog
    Searched for "App Catalog"
    Tapped "App Catalog Update" app from HP.
    Tapped "Download for free" - Download failed.

    Now, the steps you need to take to resolve the problem:
    Note the nodelete patch only works on webos 2.x and higher.
    If you haven't already got WOSQI, get it now, and use it to install Internalz Pro and Preware onto your phone. (Read about WOSQI here: http://forums.webosnation.com/canuck...-v4-5-0-a.html)
    Installed nodeleteipk.patch using WOSQI (download from first post in this thread: [How To] Retain App IPKs from App Catalog )
    Turned network time on to change clock to current date (airplane mode toggle to speed up)
    Opened App Catalog
    Searched for "App Catalog"
    Tapped "App Catalog Update" app from HP.
    Tapped "Download for free" - Download took forever to start, but eventually got 'install failed'
    Confirmed IPK was in /media/internal/downloads using Internalz
    Set date to 7/3/2013
    Tapped com.palm.appcatalogupdate...ipk in Internalz which opened Preware (can also install with WOSQI and I think Internalz can do it too)
    Installed package
    Turned network time on again to set current daet.
    Got notified about update to App Catalog again..
    Tapped install updates
    update dowloaded and... installed successfully
    Installed TuneIn by RadioTime, to confirm everything is working
    Enjoyed a Coke*.

    *Planned.. I need to walk downstairs to get a Coke from the fridge, but someone from work keeps bothering me. :\

    Note, never once did I restart my phone. I typed each step as I did it, because I knew I would not be able to remember them all.
    Hey! I'm having the same problem on my palm pixi plus, and I need a bit of help getting through these instructions. Had my own thread up asking for help and was referred to this one. I figured out how to put my phone in dev mode so WebOSqi would recognize it. Then I put on internalz with file mgr and preware. I cannot, however, figure out how to open the patch file from [How To] Retain App IPKs from App Catalog
    Do I need to download something that lets me download patch files? I googled "how to download patch files" and got a lot of stuff I didn't understand, but it said something about UNIX computers. I'm on a windows computer. I tried openning the patch file there on my phone too, didn't work either. I thought maybe it wasn't necessary and tried to go on with your instructions but what shows up in internalz pro in the location you described is an appcatalog .ipk_tmpdir/ and that's just a folder, clicking on it openned another folder, didn't start preware. I've tried looking for it in preware and webosqi, but don't know what I'm looking for, typing in app catalog doesn't get me anywhere.
    I hope I'm close to fixing this issue, I've been looking for a solution to the app catalog for a while for my phone and my wife's and I'm very hopeful that this will provide that solution.
  17. #37  
    Quote Originally Posted by mr-scorpio View Post
    OK, After much nail biting .. & seeing more things needing to install,...
    BINGO! it is working... App Store 2.1.1.0.0.0 installed & ALL working
    I couldn't get WOSQI to 'see' my pre 3 until i set it into 'dev mode'....
    Many thanks Mat for your help
    Al
    Hi Mr Scorpio
    I have just opened my 2nd palm pre 3 and have the same prob you did....Apps catalogue doesnt work....i am trying to work out the instructions that helped you but being a complete technophobe i am lost...would you /could you take me thru it like a complete nooob???
    Many thanks.
  18.    #38  
    Quote Originally Posted by bonnisolli View Post
    Hi Mr Scorpio
    I have just opened my 2nd palm pre 3 and have the same prob you did....Apps catalogue doesnt work....i am trying to work out the instructions that helped you but being a complete technophobe i am lost...would you /could you take me thru it like a complete nooob???
    Many thanks.
    Hi Bonnisolli,
    The first step is to get WOSQI (WebOS Quick Installer) program talking to your pre.
    And before that you need to make sure the novacomd.exe USB driver / runtime is also installed on your PC even before trying to run WOSQI. (All these steps can be found within this thread.)

    To get the phone into Dev mode (so it can be seen by WOSQI), i found it best to take the sim card out first. Then power up the phone.. Thus when you dial the special code on the key pad, the phone either launches or reboots into dev mode, instead of trying to 'dial' the code and fail. - Dev Mode actually looks like an app card filling the screen, so can't be missed.
    I think the code i dialled in was: #*3386633#

    Once you have the WOSQI talking to the phone, then you can follow the steps of installing various files onto the phone, which will forcibly put the updated App Catalog on the phone, then you're good to go ...
    It's a pain in the ***, but once done it's done.
    Best of Luck.
  19. #39  
    I didn't want to start a new thread so forgive me for taking this a bit off topic. I'm going to purchase a pre 3 off ebay or amazon. Can I use the same sim card in my veer, or do I need to get a different one? If I need to get a new one, how do I go about that? I don't think the phone (pre 3) comes with one. Sorry to sound so ignorant, but the veer is the first phone I had with a sim card, and I don't know if they are interchangeable.
    The value of knowledge is not in its possession, but in its use.
  20.    #40  
    Quote Originally Posted by Sukiyaki View Post
    I didn't want to start a new thread so forgive me for taking this a bit off topic. I'm going to purchase a pre 3 off ebay or amazon. Can I use the same sim card in my veer, or do I need to get a different one? If I need to get a new one, how do I go about that? I don't think the phone (pre 3) comes with one. Sorry to sound so ignorant, but the veer is the first phone I had with a sim card, and I don't know if they are interchangeable.
    Hi
    I'm not familiar with the veer personally, but the Pre 3 takes a standard size sim, not one of these silly little micro & pathetic-micro versions that are popping up now.
    You should be able to put your sim into the Pre 3 just fine...
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. How to fix App Catalog/App errors related to Certificate expiration
    By Alan Morford in forum webOS Tips, Info & Resources
    Replies: 14
    Last Post: 12/30/2014, 09:27 AM
  2. App Catalog keeps failing, 2.1. Please Help!!
    By Torg20 in forum Palm Pre 2
    Replies: 2
    Last Post: 10/03/2011, 04:13 PM
  3. Help with bell Palm pre app catalog urgent please
    By pre456 in forum Palm Pre and Pre Plus
    Replies: 4
    Last Post: 01/10/2010, 12:47 PM
  4. Possible reason for failing to install from App Catalog
    By sagipe in forum webOS Apps & Games
    Replies: 5
    Last Post: 01/03/2010, 09:46 PM

Posting Permissions