Results 1 to 13 of 13
Like Tree1Likes
  • 1 Post By geekpeter
  1.    #1  
    Hi,
    Yesterday, my Pre3 rebooted, and was stuck showing the HP logo, for 30 minutes before I rebooted it, only to have it start up with a black (bluish light is emitted) screen. I can click on various places, and hear sounds, so it appears the screen is at least partially working.

    I tried toggling mute, removing battery, and finally doctored it, no luck.

    Any advice, before I try to buy another one?
    Last edited by ka1; 06/19/2013 at 01:36 PM.
    KA1
    Visor Deluxe->Visor Prism/Digital Link->Treo 650->Treo 700p->Pre->GSM Unlocked Pre 2 (wifi only)->FrankenPre + Touchpad 32 ->+ Touchpad 4G ATT + ATT Pre3 + 64 White Touchpad... bliss.
  2. #2  
    proximity sensor covered by screen protector?
    Touchpad Keyboard Themes - >> Click Me <<
    Rnp likes this.
  3. #3  
    Quote Originally Posted by geekpeter View Post
    proximity sensor covered by screen protector?
    But this only work while calling, don't?


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  4. #4  
    yeah but anything is worth a try before thinking of buying a whole new replacement, next steps probably opening it up to see everythings connected as it should be.
    Touchpad Keyboard Themes - >> Click Me <<
  5.    #5  
    I plan on opening it up tonight (don't have my torx screwdrivers at work). I have another broken Pre3 (my nephew's), so I may be able to canabalize parts). My Pre3 is ATT, the other is a Verizon Pre3.

    There isn't a screen protector, but maybe something else is messing up the proximity sensor?
    KA1
    Visor Deluxe->Visor Prism/Digital Link->Treo 650->Treo 700p->Pre->GSM Unlocked Pre 2 (wifi only)->FrankenPre + Touchpad 32 ->+ Touchpad 4G ATT + ATT Pre3 + 64 White Touchpad... bliss.
  6. #6  
    Your problem sounds like what commonly happens to the Veer.... either the screen cable is loose/damaged, or the chip that drives the LCD panel has "died".

    You should be able to re-seat both ends of the cable, and if that doesn't help, try replacing the LCD or the cable. It's good to hear that the digitizer still works.
  7.    #7  
    Quote Originally Posted by Remy X View Post
    Your problem sounds like what commonly happens to the Veer.... either the screen cable is loose/damaged, or the chip that drives the LCD panel has "died".

    You should be able to re-seat both ends of the cable, and if that doesn't help, try replacing the LCD or the cable. It's good to hear that the digitizer still works.
    ok, looking at the tear down photos, and I'm stuck. Rob's photo of the sim card area being pulled lower - how do you do that? Maybe I should ignore that, but need to find the way to see the cables...
    KA1
    Visor Deluxe->Visor Prism/Digital Link->Treo 650->Treo 700p->Pre->GSM Unlocked Pre 2 (wifi only)->FrankenPre + Touchpad 32 ->+ Touchpad 4G ATT + ATT Pre3 + 64 White Touchpad... bliss.
  8. #8  
    Quote Originally Posted by ka1 View Post
    ok, looking at the tear down photos, and I'm stuck. Rod's photo of the sim card area being pulled lower - how do you do that? Maybe I should ignore that, but need to find the way to see the cables...
    TBH, i only have experience with the 1st gen (Pre/+), so i'm really not able to help you there. But there's been literally dozens of Veers failing the same way, with the backlight and digitizer working, but the LCD remaining black. I know it's hardware failure, and Veers also experience non-"black screen" cable failure (slow image repainting, some jigsaw/checkerboard effect), which i'm inclined to think is caused by the improved slider mechanism with (possibly) cheaper cables.


    All i can suggest at this point is to look for any screws or clips you may have missed, but hopefully someone will come around who's disassembled the Pre3 at least once..

    Edit: From looking at the pictures, it seems like the SIM-related daughterboard should just lift off.... i think he just put it there to show both sides of it... (the connector side and the side with the rows of round holes)

    Oh, and have a look here: HP Pre 3 dissasembly - PCB photos, the daughterboard is shown in the first post, and yes it looks like it's only held in place by its connector...
    Last edited by Remy X; 06/19/2013 at 10:05 PM.
  9. #9  
    From re-reading your OP, i'm beginning to wonder if the "dead chip" theory is more correct, because "boot looping" is caused by either bad firmware that the boot process can't get past or corrupted system files.

    I just don't know if the chip was accessible at boot time but malfunctioned and stalled the boot process, OR, the image was displayed and the screen never repainted afterwards... well, both can be one and the same, but it's more of the matter of what died first.

    But in many cases, Doctor doesn't seem to stall/fail when reflashing the firmware of borked chips, and hardware-related issues persist even after doctoring multiple times, which leads me to believe that many chips have some sort of a "settings" area that holds some variables/flags, and those don't get cleared by the firmware reflash... i'm not a hardware guy, so i only have a relative idea of what i'm talking about, but from experience, it looks that way to me

    I believe that manufacturers' tools are more effective at reflashing troublesome chips than simple doctoring.. and by tools, i also mean manually connecting to a chip through the JTAG interface, and not just going through the fully assembled phone
  10.    #10  
    Quote Originally Posted by Remy X View Post
    From re-reading your OP, i'm beginning to wonder if the "dead chip" theory is more correct, because "boot looping" is caused by either bad firmware that the boot process can't get past or corrupted system files.

    I just don't know if the chip was accessible at boot time but malfunctioned and stalled the boot process, OR, the image was displayed and the screen never repainted afterwards... well, both can be one and the same, but it's more of the matter of what died first.

    But in many cases, Doctor doesn't seem to stall/fail when reflashing the firmware of borked chips, and hardware-related issues persist even after doctoring multiple times, which leads me to believe that many chips have some sort of a "settings" area that holds some variables/flags, and those don't get cleared by the firmware reflash... i'm not a hardware guy, so i only have a relative idea of what i'm talking about, but from experience, it looks that way to me

    I believe that manufacturers' tools are more effective at reflashing troublesome chips than simple doctoring.. and by tools, i also mean manually connecting to a chip through the JTAG interface, and not just going through the fully assembled phone
    I now also leaning towards chip theory...

    I realized I missed on screw, near the SIM, so removed that, and then was able to take it apart further, and see the wires connecting both halves. I'll post photos, but it looks like they put clear tape around the wires, and more clear tape where the wires go into the clasp, so I can't see how the wires could have come loose... They seem well connected.

    After all this, I realized I was being a bit stupid, and should have first tried disassembling my nephew's Pre3 first, which is known to be bad, before I tried my own.

    Wil shift my focus to EBay, and away from repairs...
    KA1
    Visor Deluxe->Visor Prism/Digital Link->Treo 650->Treo 700p->Pre->GSM Unlocked Pre 2 (wifi only)->FrankenPre + Touchpad 32 ->+ Touchpad 4G ATT + ATT Pre3 + 64 White Touchpad... bliss.
  11. #11  
    Quote Originally Posted by ka1 View Post
    I now also leaning towards chip theory...

    I realized I missed on screw, near the SIM, so removed that, and then was able to take it apart further, and see the wires connecting both halves. I'll post photos, but it looks like they put clear tape around the wires, and more clear tape where the wires go into the clasp, so I can't see how the wires could have come loose... They seem well connected.

    After all this, I realized I was being a bit stupid, and should have first tried disassembling my nephew's Pre3 first, which is known to be bad, before I tried my own.

    Wil shift my focus to EBay, and away from repairs...
    i only scanned this thread. but you said you had a parts donor phone on hand?
    you can't cannibalize and parts swap just for testing/eliminating possible causes??

    aw man. i hope you get it worked out. i did let my Pre 3's go while still new just to avoid this kind of potential scenario, so i definitely sympathize. good luck.

    aw crap, forgot what i was going to mention...

    your Pre3 should be ATT branded, right? if so, there's a very strong chance you can take it to a service center and get a tech to look at it and possibly diag for you. you may have to visit a few different stores to find a technician that enjoys solving problems vs. just reflashing refurbs.

    but If it's got their logo on it,
    they will usually at least give it a try, and maybe they can help you pinpoint where the issue is. then if you have that parts donor, you can swap and try again.
    Last edited by TJs11thPre; 06/20/2013 at 04:39 PM. Reason: short term memory issues...
  12.    #12  
    Hi,
    Yes, the Pre3 is ATT branded, and I am a customer (monthly with discount). Hmm.

    The donor phone is a dead Verizon Pre3 (nephew dropped it in water). So I do have to worry about radios (not sure where they are). The other funny difference is the headphone jack - on the ATT Pre3, it is a loose component, held in place by the two large halves. For the Verizon Pre3, it is connected to the plastic.

    I managed to disconnect the cable going to the screens for each, and swapped both halves. No luck, ATT doesn't boot (haven't tried Verizon yet). The ATT phone will get warm if I try to charge it, the Verizon one stays cold...

    Will play a bit more, and look at EBay and here, and am thinking of getting an iPhone for my parents and stealing their Pre3..
    KA1
    Visor Deluxe->Visor Prism/Digital Link->Treo 650->Treo 700p->Pre->GSM Unlocked Pre 2 (wifi only)->FrankenPre + Touchpad 32 ->+ Touchpad 4G ATT + ATT Pre3 + 64 White Touchpad... bliss.
  13. #13  
    Quote Originally Posted by ka1 View Post
    Hi,
    am thinking of getting an iPhone for my parents and stealing their Pre3..
    THIS may be the best solution yet!

Similar Threads

  1. pre 3 glass theme no longer works with new update.
    By Motorhead777#WN in forum HP Pre 3
    Replies: 3
    Last Post: 12/21/2011, 04:30 PM
  2. Camera no longer works on pre
    By roygbiver in forum Palm Pre and Pre Plus
    Replies: 12
    Last Post: 12/06/2010, 09:35 PM
  3. Touchscreen (Sprint Pre) only works briefly after waking
    By eff20see in forum Palm Pre and Pre Plus
    Replies: 0
    Last Post: 08/17/2010, 02:17 PM
  4. Replies: 5
    Last Post: 02/04/2010, 01:19 PM
  5. one of my contacts no longer shows up under messaging
    By maniacmatt1782 in forum Palm Pre and Pre Plus
    Replies: 9
    Last Post: 11/18/2009, 07:24 PM

Posting Permissions