Results 1 to 6 of 6
  1.    #1  
    A couple of times now I have my pre3 fully charged 4.1V or 4.2V but battery indicator shows 0%, and when placed on charge imcreases to 1% > 2% >etc over time. battery widget and doctor battery show the same low % value.

    restart doesnt fix it, I think after charging a while jumps from 7% to 100%.

    No idea why this happens.

    Any one come across this before , think it 3rd time it happened.
    Last edited by Firepower; 04/07/2013 at 05:34 PM.
  2. #2  
    Quote Originally Posted by Firepower View Post
    A couple of times now I have my pre3 fully charged 4.1V or 4.2V but battery indicator shows 0%, and when placed on charge imcreases to 1% > 2% >etc over time. battery widget and doctor battery show the same low % value.

    restart doesnt fix it, I think after charging a while jumps from 7% to 100%.

    No idea why this happens.

    Any one come across this before , think it 3rd time it happened.
    they sometimes get out of sync. (battery logic and phone logic). The Way I have solved it on my pre3 is to run the battery flat until the phone shuts down, then fully charge to 100%. This has worked every time I have had the problem.
  3. #3  
    Happened to me twice this week. The symptom is that the touchscreen would stop working, only the keyboard and volume keys work. First time somehow it recovered, but battery shows 0%, didn't shut down. But after a restart phone won't start again with the red battery icon. Second time this morning, same symptom, but I didn't wait for screen to come back, I just pulled the battery. Thank goodness I'm used to carrying a spare battery these days.
  4. #4  
    Pulled the logs, seems like something wrong with the I2C in the A6 chip:

    Line 8606: 2013-06-06T11:40:32.338592Z [30487] webos-device user.info powerd: {powerd}: ChangeGIOHelper
    Line 8607: 2013-06-06T11:40:32.341735Z [30487] webos-device user.info powerd: {powerd}: ChangeGIOHelper: 185
    Line 8608: 2013-06-06T11:40:32.341918Z [30487] webos-device user.info powerd: {powerd}: Received uevent 185:change@/devices/i2c-0/0-0031.
    Line 8609: 2013-06-06T11:40:32.342010Z [30487] webos-device user.info powerd: {powerd}: A6_CHG: Probe: A6_ACTION=PECENT_LOW_CRIT_NOTIFY
    Line 8610: 2013-06-06T11:40:32.356201Z [30487] webos-device user.warning powerd: {powerd}: w1_battery: Surprising battery level reading of 0%, rereading 5 more times
    Line 9145: 2013-06-06T11:45:32.434021Z [30787] webos-device user.warning powerd: {powerd}: w1_battery: Surprising battery level reading of 0%, rereading 4 more times
    Line 9147: 2013-06-06T11:45:32.583892Z [30787] webos-device user.warning powerd: {powerd}: w1_battery: Surprising battery level reading of 0%, rereading 3 more times

    I wonder if these A6 chips just die over time. Although the battery doesn't start another phone either.
  5. #5  
    I have no idea to be honest. Reflashing A6 seems to cure battery drain for some people with a TP, might be possible for Pre 3 too? It could be it does some "re-calibration" this way? Too bad only really reliable method at the moment is to do a Doctor that would wipe your device...

    We might want to reach out to John Steffes and ask if he could create Meta Doctor scripts that would only update the A6 and nothing else? But it might be good to confirm that updating A6 would cure it before asking him

    -- Sent from my Palm Veer using Forums
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  6. #6  
    Yeah I think I should do that. My last reset wasn't so clean because I didn't do one, just a wipe and erase.

Similar Threads

  1. Replies: 38
    Last Post: 07/13/2013, 06:24 AM
  2. alert on full battery charge using Touchstone?
    By bsoder in forum Palm Pre and Pre Plus
    Replies: 7
    Last Post: 07/28/2009, 05:49 PM
  3. Battery dead from full charge in three hours...?
    By jknorr in forum Palm Pre and Pre Plus
    Replies: 23
    Last Post: 06/12/2009, 12:12 AM
  4. Battery shows 98% after full charge
    By chenling in forum Palm OS Devices & Apps
    Replies: 10
    Last Post: 05/31/2007, 04:13 AM
  5. Seidio 2400 mah Extended Battery Stopped Showing Charge
    By trojanvision in forum Palm Windows Mobile Devices & Apps
    Replies: 2
    Last Post: 04/18/2007, 01:35 AM

Posting Permissions