webOS Nation Forums >  webOS Devices >  HP Pre 3 > Captive portal never connects
Captive portal never connects
  Reply
 
Thread Tools Display Modes
Old 02/01/2013, 01:04 AM   #1 (permalink)
Member
 
Posts: 988
This problem's happening on both my retiring Pre 2 and my new Pre 3, both on 2.2.4. At work there's a captive portal to connect, which either phone can detect. On the page you have to type in some identifying info, then submit with an "I Agree [to not be naughty]" button. Our network then saves the credentials for one year before they redirect you back through the portal to again complete the form.

Trouble is, on both phones nothing happens after clicking "I Agree." It never advances to the next page. Very rarely, after a very long time it will say "Network connected." But then as soon as I try to use data it's clearly still not connected (no data, browser complains "no network", etc).

The browser doesn't redirect straight away, either. It just complains about enabling the network. I got the URL for the portal page from my laptop and manually typed it in the browser, then filled the form and hit enter to see what it'd do. But it just twirls away, never loading or moving on to a new page.

Anyone ever seen this behavior? Never have trouble on any other captive portals, just this one.
ananimus is offline   Reply With Quote
Old 02/02/2013, 03:01 PM   #2 (permalink)
Member
 
Posts: 988
Yesterday I gave it another shot. This time I disabled data so only the wifi was available. Loaded the portal in the browser and when I tried to submit, the browser immediately spat back the "Please enable the network connection" error, as though nothing were connected. So of course it didn't connect.

Also noted from the URL that the page is not on port 80 (or 443).

Any ideas? IT dept says, "If it it doesn't just work then I'm afraid we can't help you."
ananimus is offline   Reply With Quote
Old 02/04/2013, 11:44 AM   #3 (permalink)
Member
 
Posts: 331
Maybe it's your company's laziness on upgrading. For example, at my job, intranet pages only render w/ IE6 (no, I didn't flip the 9) but the last 3 versions of FireFox can't even do a decent job at rendering any of the pages. Perhaps your IT set up the cookies, or whatever captive portal uses, on a very old standard.
bassman97 is offline   Reply With Quote
Old 02/04/2013, 02:25 PM   #4 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Depending on your company's policies, you could try spoofing the MAC address of your computer (or other WiFi devices you have), signing in there, then try connecting again with your phones. Not sure if you would run into legal/ethical/whatever issues, though.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 02/04/2013, 03:17 PM   #5 (permalink)
Member
 
Posts: 988
Quote:
Originally Posted by GMMan View Post
Depending on your company's policies, you could try spoofing the MAC address of your computer (or other WiFi devices you have), signing in there, then try connecting again with your phones. Not sure if you would run into legal/ethical/whatever issues, though.
You're right, that would probably work. But yeah, don't want to in case there's ever an issue. If I were notified of trouble, they'd only have my word to identify which was causing an issue and might shut down (take away) both.
ananimus is offline   Reply With Quote
Old 02/07/2013, 02:24 PM   #6 (permalink)
Member
 
Posts: 988
One last bump, then I'm giving up.

Tried a few other combos of things, but it's always the same issue. Not sure where it's looking to submit the verification to, but it's just not finding it. bassman97 may be right regarding server side stuff, but no way to tell.
ananimus is offline   Reply With Quote
Old 02/07/2013, 04:29 PM   #7 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
You should check it out on another wireless device, whether registered or not, if possible. It's likely due to the TP's browser being unable to handle whatever your company is serving for the authentication page. If the device is registered, try visiting the "default gateway", which is the IP address you can find from your network settings. Usually, if they do it right, it'll go to a page that gives you your authentication status. Try logging out if possible, then when you're asked to log in again pull up some web debugger tools (Ctrl-Shift-I in Chrome and FireBug in Firefox). See if it's using a button or something, and you can try emulate what it sends with curl.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Thanked By: ananimus
Old 02/08/2013, 11:38 AM   #8 (permalink)
Member
 
Posts: 988
Thanks, GMMan! Problem solved. I'll just document here for folks, as well as for me next year when I have to do it again.

Thought I might try to submit the POST manually but didn't know where to start. cURL was a great tip! I couldn't get the original landing page to show on my laptop as it's registered and not up for verification again until some date next year. So I snooped the source code for the PHP welcome page on my Pre 3 (Browser-> Top Menu -> Page -> View Source -> [comes up in Internalz Pro]) to get the form field parameter names and the URL to submit to.

I then used curl to try and post (using XTerm, cellular off, wifi on/connected)...

Code:
curl --data "[param1]=[value1]&[param2]=[value2]" https://www.posturl.com
curl returned the error...
Code:
curl: (35) error:14077458:SSL routines:SSL23_GET_SERVER_HELLO:reason(1112)
Which led me to this thread and similar. So I forced SSLv3 by adding the -3 option to the above curl command and trying again. After a full second or two the command completed with no response.

I stared at it for a second, then shrugged and opened the browser pointed at Google. And it loaded! Did a search and that came back, too! After successfully loading a webpage the Captive Portal dashboard notification also disappeared. Still with cellular data off!

Thanks again, GMMan. I just switched from Sprint to Straight Talk. Trying to a) keep the data usage down so ST doesn't cut me and b) there are areas at work that take me out of range of cell but where we have wifi. Now I won't have to drag my laptop around to stay on the company email.

Awesome sauce.
ananimus is offline   Reply With Quote
Thanked By: bradmeister1
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0