Results 1 to 7 of 7
  1.    #1  
    I bought a used Pre 3 off ebay, it came with a stock battery and a Mugen. When I powered it up with the Mugen, it showed 98% charge. I wanted to fully charge it to use as a backup for my main Pre 3, but when I swapped the Mugen into the main Pre 3, it wouldn't power on. Connecting it to the charger got the ? icon. I tried it again in the newly acquired Pre 3, same result. I don't have the receipt, and would guess it's over 30 days-any tricks to get the battery functional or is this now useless? I have another Mugen and two stock batteries, but it never hurts to have another!
    TIA
    My gadget list-TouchPad, Pre 3, Pre 2, Pre+, Pixi+, Treo 700p, Treo 650, Centro, Handspring, Kyocera 6035, 7135-all with Verizon.
  2. #2  
    Quote Originally Posted by broncot View Post
    I bought a used Pre 3 off ebay, it came with a stock battery and a Mugen. When I powered it up with the Mugen, it showed 98% charge. I wanted to fully charge it to use as a backup for my main Pre 3, but when I swapped the Mugen into the main Pre 3, it wouldn't power on. Connecting it to the charger got the ? icon. I tried it again in the newly acquired Pre 3, same result. I don't have the receipt, and would guess it's over 30 days-any tricks to get the battery functional or is this now useless? I have another Mugen and two stock batteries, but it never hurts to have another!
    TIA
    Try to send email to Mugen. Maybe they know of a reset option.

    If battery is totally depleted, it can take some time before it start charging. Just leave it on the loader for a few hours or so. I believe there is also a Touchpad (battery) reviving thread on this forum, maybe they have some useful tips which can also be used for pre3.

    Just some thoughts
  3. #3  
    There is this thread as well...

    http://forums.webosnation.com/webos-...ry-health.html

    The HP devices differ from the Palm ones in terms of how battery is treated in some major aspects...
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  4.    #4  
    I left the battery in my backup Pre 3 overnight and it charged/powered on. Dr Battery shows it has life of 1525 with a manufacturer rating of 1556. Pretty good for a 1400 mAh battery! I put calibration on (I know it won't calibrate, just to discharge), it shut off the Pre at 19%. Obviously, it's off! At least its working, good to have spares.
    My gadget list-TouchPad, Pre 3, Pre 2, Pre+, Pixi+, Treo 700p, Treo 650, Centro, Handspring, Kyocera 6035, 7135-all with Verizon.
  5. #5  
    Watch that overcharge... could be a sign the regulator chip in the battery is faulty.

    That might be the root cause of the original problem. Monitor for sudden shutdowns and unexplained charge % drops...

    It's a shame it is a used Mugen because for original purchase you would have a warranty. If the battery (chip) is defective you might try querying them anyway about replacement.
    Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

    Windows Central Senior Ambassador

    Mobile Nations Devotee
  6.    #6  
    I contacted Mugen, I'll let you know what they say.
    My gadget list-TouchPad, Pre 3, Pre 2, Pre+, Pixi+, Treo 700p, Treo 650, Centro, Handspring, Kyocera 6035, 7135-all with Verizon.
  7. #7  
    I have the same Mugen Power 1400 mAh battery.
    Dr. battery shows 100% battery health: manufacturer rating 1556 mAh,calculated left 1556 mAh.
    The battery lasts longer than the original one (more than day with Wi-Fi / GPRS always on). Of course I've done 5 cycles for battery full re-charging (as Mugen insists).
    But there is an issue. It drains faster from 100% to 80% than after. On 0% it still works about 2 hours! So the proper calibration is needed but can't find the way to do it

Posting Permissions