webOS Nation Forums >  webOS Devices >  HP Pre 3 > Screenstate CPU freq affecting the Alarm
Screenstate CPU freq affecting the Alarm
  Reply
Like Tree1Likes
  • 1 Post By slight9

 
Thread Tools Display Modes
Old 12/20/2012, 09:03 AM   #1 (permalink)
Member
 
Posts: 27
Hi everyone,

I'm about a week into my new Pre3 and I am using the Screenstate reduced CPU freq setting in Govnah+UberKernel to reduce my battery usage when the screen is off. I have the maximum freq when the screen is off set to 245Mhz. It seems to me that this setting "breaks" the Alarm feature on the phone. My alarms don't go off on-time. So, far, they've never gone off on time, and they've ranged from going off 2 minutes late to 10 minutes late. If I use Govnah and set a profile that does NOT reduce the CPU at all (i.e., keeps it at 1.4Ghz), the alarm goes off on-time.

Is this normal? Do other people have this issue? It makes intuitive sense that reducing the CPU means it's going to take longer for things to happen (i.e., callbacks to fire, timers to increment, etc.), but this will be quite annoying and force me into a touch decision on battery life versus expected functionality.

I haven't done enough testing to determine the exact freq at which the alarm will still go off on-time, but I will look into it and post the result here.
slight9 is offline   Reply With Quote
Old 12/20/2012, 11:59 AM   #2 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,680
worth testing, my alarm went off this morning, tho i use mode switcher to launch my media player which autostarts my mp3's, i havent tested this every day tho as i turn the alarm mode off if i wake up before the alarm.

would be nice to find out for sure that it can or cannot happen.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 12/21/2012, 11:54 AM   #3 (permalink)
Member
 
Posts: 331
Read about the screenstate governor with the Pre1 guys. At some point, the speed isn't fast enough so you start creating a huge back-up at the CPU since it can't process everything on time. Then to make matters worse, you start killing your battery as the CPU is running on full load. Think of your cpu speed as traffic lanes and cpu load as traffic volume. The numbers of lanes needs to be appropriate for the traffic volume, otherwise you get pile-ups. I'd raise the speed to the point where the alarms work fine and would call that the lowest you can reasonably run. Then, you can fine tune the battery life by seeing if that speed is optimal, or if going up a step or two helps.
bassman97 is offline   Reply With Quote
Thanked By: lagoldste
Old 12/28/2012, 09:49 AM   #4 (permalink)
Member
 
Posts: 27
Update:
I never actually did a step by step increment of the max CPU with the screen off in Govnah, but I did get the alarms working fine without killing the battery. The default UberKernal 1.4Ghz profile does NOT enable the "screenstate" feature in the Govnah profile, but it does set a maximum CPU freq when the screen is off to 3XXMhz. I think the 3XXMhz limit works because the battery drains at the same rate as my custom Govnah profile with a bunch of tweaks. So, I'm just using the UberKernal profile and things are working fine.

Thanks for all the help.
slight9 is offline   Reply With Quote
Liked by geekpeter likes this.
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0