webOS Nation Forums >  webOS Devices >  HP Pre 3 > Internet APN Settings Pre 3
Internet APN Settings Pre 3
  Reply
 
Thread Tools Display Modes
Old 04/09/2012, 07:54 PM   #1 (permalink)
Member
 
Posts: 17
Hello All,

I have an ATT branded HP Pre 3 that I have had for a few months now on ATT. Since I am a broke college student, I saw a few others who have succesfully switched over the straight talk network using their SIM Card. I have the correct APN settings from straight talk and verified them through some of the other posts seen around here.

My problem is that whenever I enter in these APN settings in the dialer APP for some reason they do not save. Whenever I hit save or setup anyway (since I get an unable to setup APN error) I come back to the APN settings and it is back to Automatic again and requires that I re-enter all of this info for both Internet and MMS. I've seen solutions in the forums but it seems they only applied to changing a file that no longer exists in 2.0+ devices. I've also been at this for days randomly entering the settings in over and over again, still doesn't work so i'll give up on that approach.

Anyone know a way I can get these settings to stay and hopefully get this to work. Saving money is a pain sometimes.

Thank you!
Ultrashock is offline   Reply With Quote
Old 04/13/2012, 10:37 AM   #2 (permalink)
Homebrew Developer

 
Posts: 3,032
On my Pre2, I had to enter them twice and hit "Change Settings" followed by "Setup Anyway" both times. Looks like it's working, although now i'm having several other issues with my Pre2 now. . .
__________________
Author:
Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
Quote:
(1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
GO OPEN WEBOS!
People asked me for a donate link for my non-catalog work, so here you are:
eblade is offline   Reply With Quote
Old 04/13/2012, 12:26 PM   #3 (permalink)
Member
 
Posts: 17
Quote:
Originally Posted by eblade View Post
On my Pre2, I had to enter them twice and hit "Change Settings" followed by "Setup Anyway" both times. Looks like it's working, although now i'm having several other issues with my Pre2 now. . .
Yea it seems like no matter what I do and no matter how many bars of service I get it still wont hold or get internet, every time I back out of the phone app I go back in and find the manual settings are off. I would hate to go crawling back to ATT defeated.

One thing I will say too that has been odd is that I never had to enter an unlock code when I stuck the new SIM in..... im not sure if this is because it is an ATT sim from straight talk or what. I dont believe I bought it unlocked either......
Ultrashock is offline   Reply With Quote
Old 04/16/2012, 10:10 AM   #4 (permalink)
Member
 
Posts: 17
Well now I am really at a loss, first I tried making sure this phone was unlocked by using this blog:

Dogbert's Blog: Free Unlocker for Palm/HP Phones
(I used the writeback parameter listed at the bottom, as if I know that what does)

Then I took my carrierdb file and edited it with this:
https://github.com/destinal/meta-doc...520a49d8ca8e80

It seemed to save the manual settings overnight and after a reboot, but now its back to its old behavior and not saving the apn settings...... Looks like its back to ATT for me
Ultrashock is offline   Reply With Quote
Old 04/18/2012, 10:57 AM   #5 (permalink)
Member
 
Posts: 109
Have you tried to doctor it? Or if that doesn't work could try the EU version and see if that helps.
smackead is offline   Reply With Quote
Old 04/18/2012, 12:01 PM   #6 (permalink)
Member
 
Posts: 698
Quote:
Originally Posted by Ultrashock View Post
Hello All,

I have an ATT branded HP Pre 3 that I have had for a few months now on ATT. Since I am a broke college student, I saw a few others who have succesfully switched over the straight talk network using their SIM Card. I have the correct APN settings from straight talk and verified them through some of the other posts seen around here.

My problem is that whenever I enter in these APN settings in the dialer APP for some reason they do not save. Whenever I hit save or setup anyway (since I get an unable to setup APN error) I come back to the APN settings and it is back to Automatic again and requires that I re-enter all of this info for both Internet and MMS. I've seen solutions in the forums but it seems they only applied to changing a file that no longer exists in 2.0+ devices. I've also been at this for days randomly entering the settings in over and over again, still doesn't work so i'll give up on that approach.

Anyone know a way I can get these settings to stay and hopefully get this to work. Saving money is a pain sometimes.

Thank you!
I had to do it multiple times, until it changed the APN from phone to att.mvno. I was getting frustrated and kept backing out but you shouldn't backout until it changes to att.mvno. Now even mms is working on mine Goodluck
Sapient2k7 is offline   Reply With Quote
Old 04/18/2012, 02:21 PM   #7 (permalink)
Member
 
Posts: 17
Quote:
Originally Posted by smackead View Post
Have you tried to doctor it? Or if that doesn't work could try the EU version and see if that helps.
I did doctor it when I first stuck the new SIM in, which ended up being annoying since I had to devmode my phone to get past the activation screen.

I did consider using the unlocked EU version just to see what happens and I think thats what I will try next.
Ultrashock is offline   Reply With Quote
Old 04/18/2012, 04:36 PM   #8 (permalink)
Member
 
Posts: 17
Quote:
Originally Posted by Ultrashock View Post
I did doctor it when I first stuck the new SIM in, which ended up being annoying since I had to devmode my phone to get past the activation screen.

I did consider using the unlocked EU version just to see what happens and I think thats what I will try next.
Just tried it and it doesnt work, just says that this device is incompatible for this doctor version.... oh well
Ultrashock is offline   Reply With Quote
Old 04/18/2012, 11:14 PM   #9 (permalink)
Member
 
Posts: 17
Well the good news is now the values stay there. I took the carrierdb file and took out all the other instances of mcc and mnc that matched the att/straight talk values and inserted only the one in there. (Dont worry I have the original saved just in case I find out that I did something stupid).

So now those values stay in there but they still wont give me Data or MMS as they are "invalid". I hit setup anyway and maybe when I get in an area of better connection something will happen, I guess I'll find out
Ultrashock is offline   Reply With Quote
Old 04/20/2012, 05:51 PM   #10 (permalink)
Member
 
Posts: 17
Still nothing, the values that are inputted for the internet apn and mms apn are staying in there since wednesday, but it keeps saying invalid and gets no data. I honestly could care less about MMS, its the data I want.
Ultrashock is offline   Reply With Quote
Old 04/20/2012, 09:39 PM   #11 (permalink)
Member
 
Posts: 562
Which values are they? I recall someone saying that the 'Max size' value - 600 specifically - made the difference on their device.

These settings here are said to work.
p41m3r is offline   Reply With Quote
Old 04/21/2012, 05:59 PM   #12 (permalink)
Member
 
Posts: 17
Quote:
Originally Posted by p41m3r View Post
Which values are they? I recall someone saying that the 'Max size' value - 600 specifically - made the difference on their device.

These settings here are said to work.
Yea it looks like I have the same settings and they still come back as invalid

phone_2012-21-04_185524.png

phone_2012-21-04_185627.png
Ultrashock is offline   Reply With Quote
Old 04/22/2012, 03:34 AM   #13 (permalink)
Member
 
Posts: 562
Thats really weird. Do they have a site w/ the settings that can be sent to the phone? Or maybe tech support can send them and you accept? Maybe there's a conf file from a working device that someone here can send to you?

I'm sorry to hear. Wish I could help some more.
p41m3r is offline   Reply With Quote
Old 05/05/2012, 09:22 AM   #14 (permalink)
Member
 
Posts: 17
Well here is an interesting development..... A new month started for me on straight talk and now I have data

To think that straight talk blamed it on my pre3 too!

-- Sent from my Palm Pre3 using Forums
Ultrashock is offline   Reply With Quote
Old 05/05/2012, 11:01 AM   #15 (permalink)
pivotCE Developer
 
RumoredNow's Avatar
 
Posts: 2,221
Glad to hear you got your data working...

I saw you had posted this:



...I had these exact settings as well on my Pre 2 with Straight Talk (except no ":80" at the end of the MMS Proxy string - that wasn't in my setup info they sent me) and I couldn't send MMS...

I changed max size to 300 and could then send and receive MMS.
__________________
Nokia Lumia 925: T-Mo Branded Windows Phone 8 GDR3 Dev Preview
LG Nexus 4: Ubuntu Touch Public Release Beta
Asus Nexus 7: Pure Google Jelly Bean 4.3
Samsung Galaxy Nexus: Open webOS Alpha 2
RumoredNow is offline   Reply With Quote
Old 05/05/2012, 06:36 PM   #16 (permalink)
Member
 
Posts: 17
I forgot about mms, but I tested it and it seems to work, so all is good now.

Let this be a lesson to other potential straight talk users, its probably not you... Its definitely them

-- Sent from my Palm Pre3 using Forums
Ultrashock is offline   Reply With Quote
Old 05/30/2012, 04:23 AM   #17 (permalink)
Member
 
nickmiller71's Avatar
 
Posts: 4
Quote:
Originally Posted by Ultrashock View Post
I forgot about mms, but I tested it and it seems to work, so all is good now.

Let this be a lesson to other potential straight talk users, its probably not you... Its definitely them

-- Sent from my Palm Pre3 using Forums
Hey there,

So I just picked up a Pre 3 to use on Straight Talk in partnership with my Inspire 4G, and I've been looking over this thread concerning the APN settings. Did you ever get yours to work consistently? If so, what kind of steps did you have to go through? Thanks much for the help!!
nickmiller71 is offline   Reply With Quote
Old 09/18/2012, 06:05 AM   #18 (permalink)
Member
 
Posts: 1
I did the following in an unlocked ATT Pre 3 and it worked fine:

1) in the dial pad screen I clicked on preferences and accounts
2) I then turned manual settings on
3) I then clicked on edit network settings
4) Under internet APN I typed in my apn carrier name (check your carrier to learn the proper setting for your carrier)
5) I clicked on change settings
6) I then clicked on set up anyway
7) I then clicked on ok
8) I then closed the screen by back swiping
9) I thin restarted the phone to reboot with the new settings.

Worked great first time.
Roger Martin is offline   Reply With Quote
Old 03/08/2013, 10:54 AM   #19 (permalink)
Member
 
Posts: 3
I just purchased a servise with Net10. I found out very quickly that their customer service is trash. The set up card that came with the sim said that I had to change the apn settings in my phone. I am not very tech savy, so what am I supposed to enter into the different fields. I am using an unlocked Pre 3. When I go to enter in the settings manually there are two fields one for Internet APN and the other for MMS APN I was hoping someone would be able to help my out with the proper settings, as the ones from Net10 do not work.
sulzen87@yahoo.com is offline   Reply With Quote
Old 03/08/2013, 12:58 PM   #20 (permalink)
pivotCE Developer
 
RumoredNow's Avatar
 
Posts: 2,221
Quote:
Originally Posted by sulzen87@yahoo.com View Post
I just purchased a servise with Net10. I found out very quickly that their customer service is trash. The set up card that came with the sim said that I had to change the apn settings in my phone. I am not very tech savy, so what am I supposed to enter into the different fields. I am using an unlocked Pre 3. When I go to enter in the settings manually there are two fields one for Internet APN and the other for MMS APN I was hoping someone would be able to help my out with the proper settings, as the ones from Net10 do not work.
T-Mo compatible or AT&T???

I'm going to guess you went with the AT&T compatible...

Call up the dialer pad > tap the upper left for the App menu > Preferences and Accounts > scroll down to Manual Settings and turn that ON > tap Edit Network Settings

On the APN tab enter tfdata for APN and leave everything else (user name, password) blank. Tap the Change Settings button. If you get an error saying the settings are incorrect, tap Set Up Anyway.

On the MMS APN tab enter tfdata for the MMS APN. Leave user name and password blank. For MMSC enter http://mms-tf.net and for MMS Proxy enter mms3.tracfone.com:80

Since there is no spot for Port you have to use colon ( : ) 80 at the end of the MMS Proxy string.

Max Size, I dunno. Try leaving it at the default of 600. If you get an error saying the settings are incorrect, tap Set Up Anyway. Test MMS by trying to send/receive a text with a picture attached...


If you have the T-Mo compatible SIM try following that pattern with the T-Mo comp. settings here: Support | NET10 and use the ones for Smart Phone.
__________________
Nokia Lumia 925: T-Mo Branded Windows Phone 8 GDR3 Dev Preview
LG Nexus 4: Ubuntu Touch Public Release Beta
Asus Nexus 7: Pure Google Jelly Bean 4.3
Samsung Galaxy Nexus: Open webOS Alpha 2
RumoredNow is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0