Page 1 of 2 12 LastLast
Results 1 to 20 of 24
Like Tree3Likes
  1.    #1  
    The small chrome piece inside the "P" on the HP logo on my back cover came off, and somehow I managed to save that piece. I've tried epoxy, but it comes right off, the glue doesn't bond to the metal.

    What kind of glue can I use to stick that piece back on to the cover?
    Palm IIIc -> Sony CLIÉ T650C -> Sony TJ-37 -> Palm TX -> Palm Centro -> Palm Pre Bell -> Palm Pre Plus Bell/Verizon Hybrid -> HP Veer -> HP Pre 3 NA -> BlackBerry Classic -> BlackBerry Priv

    It's a Late Goodbye, such a Late Goodbye.

    Need OEM Palm Pre parts? See here
  2. #2  
    ha...i actually took the h and p off my back cover on purpose. I think it looks so much better without the chrome piece and at this point i dont need to advertise for HP since its not like they are selling these phones anymore!
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
    p41m3r likes this.
  3. #3  
    Yeah, that HP logo was one of the main reasons I never wanted a Pre 3. But would you mind telling how you removed it? Acetone?
  4. ferchope's Avatar
    Posts
    92 Posts
    Global Posts
    105 Global Posts
    #4  
    try silicone
  5. #5  
    Quote Originally Posted by RfromR View Post
    Yeah, that HP logo was one of the main reasons I never wanted a Pre 3. But would you mind telling how you removed it? Acetone?
    just take a thin knife (like a butter knife or a swiss army knife) and just try to pry it off. Was very simple and very low tech
    I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

    Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

    Like any of my work:
  6.    #6  
    I thought about that too. I saw it's tape under it just that I don't know what type of tape. Removing it gives it the same appearance as the embossed logo on the TouchPad's case.
    Palm IIIc -> Sony CLIÉ T650C -> Sony TJ-37 -> Palm TX -> Palm Centro -> Palm Pre Bell -> Palm Pre Plus Bell/Verizon Hybrid -> HP Veer -> HP Pre 3 NA -> BlackBerry Classic -> BlackBerry Priv

    It's a Late Goodbye, such a Late Goodbye.

    Need OEM Palm Pre parts? See here
  7. #7  
    try rubber cement or contact cement
    Last edited by c_legaspi; 01/08/2012 at 11:18 AM.
    e-gadget-guy likes this.
  8. #8  
    I'd just use a small bit of superglue/cyanoacrylate.
  9. #9  
    Mine came off too, it was the perfect excuse to just peel the chrome logo off, it looks so much better now...
  10.    #10  
    Quote Originally Posted by johnsonx42 View Post
    I'd just use a small bit of superglue/cyanoacrylate.
    That's what I thought so I went out and bought a tube. Glued up my fingers for a bit but it's all fixed! I hope it doesn't fall out again otherwise the glue probably ate into the black plastic so it'll be horribly ugly.

    Thanks.
    Palm IIIc -> Sony CLIÉ T650C -> Sony TJ-37 -> Palm TX -> Palm Centro -> Palm Pre Bell -> Palm Pre Plus Bell/Verizon Hybrid -> HP Veer -> HP Pre 3 NA -> BlackBerry Classic -> BlackBerry Priv

    It's a Late Goodbye, such a Late Goodbye.

    Need OEM Palm Pre parts? See here
  11. modelnet's Avatar
    Posts
    91 Posts
    Global Posts
    92 Global Posts
    #11  
    mine came off too . So funny no idea where it is.my god I just put it together that's why Leo cancelled pre 3 before release . He heard of the faulty logo and decided to save the company embarrassment , smart guy leo
    Last edited by modelnet; 01/09/2012 at 01:00 AM.
    p41m3r likes this.
  12. #12  
    Just as a curiosity.. are all the people here experiencing the logo detachment issue having an AT&T unit or ?

    (Just trying to figure if this could be considered a problem for every unit, or only for specific variants)
  13. #13  
    my VZW launch day Pre+ Palm logo is doing fine. Great, now that I said that, watch it fall off now
  14.    #14  
    Actually I take that back. Fell out today, and I think I lost it. Think I'll go home and pry the HP out.
  15. #15  
    Quote Originally Posted by ToniCipriani View Post
    Actually I take that back. Fell out today, and I think I lost it. Think I'll go home and pry the HP out.
    good grief HP's quality is crap... I just looked at my Pre3 to see what bit of chrome you meant, and just lighty touched the bit in the P and it moved! I nudged it back straight again, but I'm sure it'll fall out soon. Let us know how yours looks with the entire chrome logo removed.
  16. #16  
    Took me 3 seconds to remove that crap.
    Too bad they attached Leo to the planet with slightly better glue.
    Would've been nice if he'd dropped off the minute he was born.
  17. #17  
    again I wonder if you all have AT&T Pre3 units (aka if this is an issue related to the back covers of the AT&T units... back cover that I think is different as material - composition - whatever from the EU unbranded model(s)
  18. #18  
    yes, mine is an at&t pre3.
  19. Xadion's Avatar
    Posts
    268 Posts
    Global Posts
    956 Global Posts
    #19  
    I just noticed the inside of my 'P' is slanted and ready to come off anytime!

    my pre2 the 'M' got bent/ripped off by the magnets of my touchstone for whatever reason.

    and my old pre minus is perfect lol
  20. #20  
    Plastic Surgery super glue. Works better than regular super glue.
    I like the chrome piece on the back but it's wearing off and I can see the brass underneath.

    -- Sent from my Palm Pre3 using Forums
Page 1 of 2 12 LastLast

Posting Permissions