Results 1 to 12 of 12
  1.    #1  
    Hello guys,
    My SIM card is from China Mobile, and now I come to USA, then my Pre3 always choose AT&T automatically. Does anyone know how to set the carrier manually? I want to set the carrier as T-Mobile, because the communication fee on AT&T is almost 3 times than on T-mobile, but I can't find where to change.
    Appreciate for your replies, and my Pre3 WebOS version is 2.2.4.
  2. reedacus25's Avatar
    Posts
    7 Posts
    Global Posts
    21 Global Posts
    #2  
    Quote Originally Posted by recordallen View Post
    Hello guys,
    Does anyone know how to set the carrier manually? I want to set the carrier as T-Mobile, because the communication fee on AT&T is almost 3 times than on T-mobile, but I can't find where to change.
    Here is how to perform a manual network selection on the Pre3 per the unlocked model's manual.

    1 Open Phone .
    2 Open the application menu and tap Preferences & Accounts.
    3 Under Network, set any of the following:

    Network Auto-Select: Set whether your smartphone automatically selects a network. If you turn auto-select off, tap the network to use.
    From there you should be able to do the manual network selection process to choose T-Mobile or AT&T or any other GSM network in range.
  3.    #3  
    hi,
    in at&t 2.2.4, there isn't network option in the preferences&account.
    could you do me a favor to find out another way to choose carrier?
    Thanks.
  4. #4  
    Quote Originally Posted by recordallen View Post
    hi,
    in at&t 2.2.4, there isn't network option in the preferences&account.
    could you do me a favor to find out another way to choose carrier?
    Thanks.
    I believe installing the following patches from PreWare will solve the issue:
    Advanced System Prefs - Framework (ATT/VZW)
    Advanced System Prefs - Phone Prefs (ATT/VZW)

    This will add the option that's not there for AT&T/Verizon versions of the software
  5.    #5  
    Quote Originally Posted by Herrie View Post
    I believe installing the following patches from PreWare will solve the issue:
    Advanced System Prefs - Framework (ATT/VZW)
    Advanced System Prefs - Phone Prefs (ATT/VZW)

    This will add the option that's not there for AT&T/Verizon versions of the software
    Thanks for you reply.
    I installed both of them, but there isn't the network option in the preferences&account also.
  6. #6  
    Quote Originally Posted by recordallen View Post
    Thanks for you reply.
    I installed both of them, but there isn't the network option in the preferences&account also.
    I have the same problem with my wifes SIM. When I use her SIM (where I haven't said to the carrier that I need Roaming) the option to select the network is not available. But with the other SIM that I have, the option to select the network is always available, even if I'm in my country.
    I think the advance menu will allow you to select advanced options. Just after you press the Antenna icon, press it again and keep presses and will you additional options, like selecting network.
  7. gastr's Avatar
    Posts
    149 Posts
    Global Posts
    190 Global Posts
    #7  
    Quote Originally Posted by recordallen View Post
    Thanks for you reply.
    I installed both of them, but there isn't the network option in the preferences&account also.
    @recordallen, perhaps if i re-write the instructions more clearly:

    find the icon for the "Phone" application and launch it.
    once in the app, pull down the menu in the top-left.
    scroll down and you'll see two sections "Domestic Calls" and "International Calls".
    both of those have a "Use" dropdown, in which you can select the carrier to use there.

    does that help?
  8.    #8  
    Quote Originally Posted by gastr View Post
    @recordallen, perhaps if i re-write the instructions more clearly:

    find the icon for the "Phone" application and launch it.
    once in the app, pull down the menu in the top-left.
    scroll down and you'll see two sections "Domestic Calls" and "International Calls".
    both of those have a "Use" dropdown, in which you can select the carrier to use there.

    does that help?
    Hi gastr,
    there isn't "Domestic Calls" option in the "network service" option, and the "International Calls" doesn't have a dropdown list. you can see the screenshots.
    Attached Images Attached Images
  9. #9  
    I actually have the same on my 2.2.3 Veer version, I cannot select the network. You MIGHT want to try the non-AT&T Pre 3 v2.2.4 Doctor from http://palm.cdnetworks.net/rom/manta...224mantawr.jar
  10. gastr's Avatar
    Posts
    149 Posts
    Global Posts
    190 Global Posts
    #10  
    Quote Originally Posted by recordallen View Post
    Hi gastr,
    there isn't "Domestic Calls" option in the "network service" option, and the "International Calls" doesn't have a dropdown list. you can see the screenshots.
    hmm strange. that's very different to what i have. i have an EU pre3 though so maybe that's why. sorry it didn't help!
  11.    #11  
    Quote Originally Posted by gastr View Post
    hmm strange. that's very different to what i have. i have an EU pre3 though so maybe that's why. sorry it didn't help!
    Thank you very much all the same.
  12.    #12  
    Quote Originally Posted by Herrie View Post
    I actually have the same on my 2.2.3 Veer version, I cannot select the network. You MIGHT want to try the non-AT&T Pre 3 v2.2.4 Doctor from http://palm.cdnetworks.net/rom/manta...224mantawr.jar
    Hi Herrie,
    My phone is AT&T Pre3 and I try to install this doctor, but it isn't compatible with the phone.
    Thanks.

Tags for this Thread

Posting Permissions