Page 7 of 8 FirstFirst ... 2345678 LastLast
Results 121 to 140 of 151
Like Tree9Likes
  1. #121  
    Quote Originally Posted by Rnp View Post
    Kayphoonstar,

    Where I can find this "world mode / CDMA mode"?


    Best Regards...
    Open the Phone App > Drop Down Menu > Preferences & Accounts > Scroll Down to bottom = "World Phone" > Network

    My phone has three options:

    CDMA Mode
    GSM/UMTS Mode
    Global Mode

    I selected CDMA Mode.

    Good luck!
    Rnp likes this.
  2. #122  
    Hi all, !!
    I have a Pre 3 EU(Germany) , my Problem was the bad WiFi rang.
    My solution is to set the 2.4 GHz WIFI Chanel on 11 (was channel 13 before)
    now it works fine!!
    is there a setting to activate the chaanel 12/13 ?
    I tried the 5 GHz Mode,but the range is poor too.

    greets
    SkyRider

    My Pre3 works now with channel 13 too, I dont know why !!
    I had a Signal strength of 1 MBit before I changed to Channel 11
    Then I had a Signal strength of 19-36 Mbit/s.
    Now I changed back to channel 13 I got 52Mbit/s .
    I disabled my 5Ghz Broadcast in my router .
    I installed the Wifi Patch but that made more problems .
    Then I removed the Patch but the problem stays.
    Now ich deleted the PMWiFiDhcpclient.conf (1.09kb) and replaced it with the PMWiFiDhcpclient.conf_orig.webosinternals (1.10kb)
    After Luna restart it work great for now.
    I restarted my Pre 3 times, and the Signal stays at 52MBit/s
    Greetz
    SkyRider

    To get a fast and stable WifI Connection I installed the Unthrottle Download Manager, after doing this , all works perfect.
    I use a AVM FritzBox Fon WLAN 7390 Router .

    PS: Sorry for my bad english.
    Last edited by SkyRider; 08/28/2012 at 10:01 AM.
    Rnp likes this.
  3. #123  
    FWIW, you guys can try experimenting with iwconfig. I don't have time right now, and my bigger problem is Wifi disconnecting when the phone sleeps (W T F is the point of having an option to keep it on, then? Dammit, HPALM, this is ridiculous!).

    You can trigger those settings to run from ifup scripts then. Unfortunately, webos 2.0 changed how that works, and I haven't dug into it yet. Start by looking at /etc/pmnetconfig and /etc/network. I'm not sure if the latter is even used any longer in WebOS 2.x? Again, no time to dig right now.

    iwconfig:
    Code:
    root@Handjob:/etc/network$ iwconfig -h
    Usage: iwconfig [interface]
                    interface essid {NNN|any|on|off}
                    interface mode {managed|ad-hoc|master|...}
                    interface freq N.NNN[k|M|G]
                    interface channel N
                    interface bit {N[k|M|G]|auto|fixed}
                    interface rate {N[k|M|G]|auto|fixed}
                    interface enc {NNNN-NNNN|off}
                    interface key {NNNN-NNNN|off}
                    interface power {period N|timeout N|saving N|off}
                    interface nickname NNN
                    interface nwid {NN|on|off}
                    interface ap {N|off|auto}
                    interface txpower {NmW|NdBm|off|auto}
                    interface sens N
                    interface retry {limit N|lifetime N}
                    interface rts {N|auto|fixed|off}
                    interface frag {N|auto|fixed|off}
                    interface modulation {11g|11a|CCK|OFDMg|...}
                    interface commit 
           Check man pages for more details.
    Here's what my defaults look like:
    Code:
    root@Handjob:/etc/network$ iwconfig eth0
    eth0      AR6000 802.11g  ESSID:"Discord"  Nickname:""
              NWID:off/any  Mode:Managed  Frequency:2.437 GHz  
              Access Point: 00:90:4C:60:04:02   Bit Rate:48 Mb/s   Tx-Power=15 dBm   
              Sensitivity=0/3  
              Retry:on   RTS thr=0 B   Fragment thr=0 B   
              Encryption key:off
              Power Management:on
              Link Quality:32/94  Signal level:-63 dBm  Noise level:-96 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:17  Invalid misc:0   Missed beacon:27
    iwlist also comes in handy:
    Code:
    root@Handjob:/etc/network$ iwlist
    Usage: iwlist [interface] scanning [essid NNN] [last]
                  [interface] frequency 
                  [interface] channel 
                  [interface] bitrate 
                  [interface] rate 
                  [interface] encryption 
                  [interface] keys 
                  [interface] power 
                  [interface] txpower 
                  [interface] retry 
                  [interface] ap 
                  [interface] accesspoints 
                  [interface] peers 
                  [interface] event 
                  [interface] auth 
                  [interface] wpakeys 
                  [interface] genie 
                  [interface] modulation
    Last edited by knobbysideup; 09/05/2012 at 09:14 AM.
    : (){:|:&};:
  4. #124  
    Following up to the info I posted above. I used iwconfig to turn off power saving. Huge increase in performance while in an ssh session, sftp, etc. I get speeds in an ssh session now that are on par with a direct novaterm connection. Yeah, this is what you guys are looking for, I think. Likely fixes performance elsewhere too. Can add an upstart script to make the setting stick, or find out if /etc/network stuff is used. Will post more details when I have time. If somebody else would like to make this a patch to make the setting permanent, that would be spiffy. Likely an upstart script triggered by the interface coming up, but I'll look into /etc/network and post results later.
    Code:
    iwconfig eth0 power off
    ** EDIT **
    I'm having a heck of a time figuring out the right way to do this. It appears that HP/Palm decided to hide all of their control of interfaces in the PmNetConfigManager binary. BOO!

    So, the cheap hack is to just add what I want to do to /etc/PmWiFiDhclient-script. This code segment works, if anybody would like to write a patch:

    Code:
    #                                                                                                                                                            
    # WiFi service: we will only ifconfig for PREINIT.  All other ifconfig                                                                                       
    # will be delegated to Net Config Manager                                                                                                                    
    #                                                                                                                                                            
    if [ x$reason = xPREINIT ]; then                                                                                                                             
                                                                                                                                                                 
    # GKS TEST                                                                                                                                                   
    iwconfig $interface power off
    If you prefer to simply tweak the power saving vs. turning it off entirely, that can be done here as well.

    Enjoy!
    Last edited by knobbysideup; 09/05/2012 at 11:48 AM.
    : (){:|:&};:
    checkmate likes this.
  5. #125  
    Hi, Skyrider,

    Can you post step-by-step, please?

    I'm very newbie in this things!


    Best Regards...

    Quote Originally Posted by SkyRider View Post
    Hi all, !!
    I have a Pre 3 EU(Germany) , my Problem was the bad WiFi rang.
    My solution is to set the 2.4 GHz WIFI Chanel on 11 (was channel 13 before)
    now it works fine!!
    is there a setting to activate the chaanel 12/13 ?
    I tried the 5 GHz Mode,but the range is poor too.

    greets
    SkyRider

    My Pre3 works now with channel 13 too, I dont know why !!
    I had a Signal strength of 1 MBit before I changed to Channel 11
    Then I had a Signal strength of 19-36 Mbit/s.
    Now I changed back to channel 13 I got 52Mbit/s .
    I disabled my 5Ghz Broadcast in my router .
    I installed the Wifi Patch but that made more problems .
    Then I removed the Patch but the problem stays.
    Now ich deleted the PMWiFiDhcpclient.conf (1.09kb) and replaced it with the PMWiFiDhcpclient.conf_orig.webosinternals (1.10kb)
    After Luna restart it work great for now.
    I restarted my Pre 3 times, and the Signal stays at 52MBit/s
    Greetz
    SkyRider

    To get a fast and stable WifI Connection I installed the Unthrottle Download Manager, after doing this , all works perfect.
    I use a AVM FritzBox Fon WLAN 7390 Router .

    PS: Sorry for my bad english.
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  6. #126  
    Quote Originally Posted by Rnp View Post
    Hi, Skyrider,

    Can you post step-by-step, please?

    I'm very newbie in this things!


    Best Regards...
    He did. All you need to do is exactly what he showed. Change Directory to /etc/network and then modify iwconfig by iwconfig eth0 power off.

    However, my remaining questions for this gem of a mod are do the changes take effect immediately or does a service need to be restarted? Also, I found that I could only do this via Novaterm and not wTerm, even as root. So, if a script was created, can it be run by wTerm successfully then? I will see if my WiFi improves, since I have a relative easy way to tell if it's dropping (I have a mode to launch Linphone when connected to my router and the normal behavior is bad enough that it will cycle that mode quite frequently).
  7. #127  
    I never installed the patch and my wifi performance got alot better. I have a dual band router and sometimes use the 5 but mainly stick with 2.4 . Its fine now. Maybe was a bad channel selection by the router?
  8. #128  
    Quote Originally Posted by bassman97 View Post
    He did. All you need to do is exactly what he showed. Change Directory to /etc/network and then modify iwconfig by iwconfig eth0 power off.

    However, my remaining questions for this gem of a mod are do the changes take effect immediately or does a service need to be restarted? Also, I found that I could only do this via Novaterm and not wTerm, even as root. So, if a script was created, can it be run by wTerm successfully then? I will see if my WiFi improves, since I have a relative easy way to tell if it's dropping (I have a mode to launch Linphone when connected to my router and the normal behavior is bad enough that it will cycle that mode quite frequently).
    I think you meant my setting change. Rnp was talking about something else, I think.

    Doing it as above, the setting will be changed by the dhclient script. Works great when you first bring up wifi manually ... UNTIL the phone goes to sleep. Then the powersave option gets set back to on. I don't know where that is being controlled, but when the phone wakes up, it will be the powersave mode. Blah. Next time dhclient does its thing, and the phone is awake, the setting will come back. The touchpad has the same behavior.

    To make it stick will require our own upstart watchdog, it seems. A kludge, to be sure, but if HP won't give us open control to the device, then we have no choice. I don't know the 'right' way to do that yet. We can certainly just do it the normal way in /etc/event.d, but webosinternals has adopted a different method that I don't understand. I guess I need to actually start writing patches now to learn...

    Yes, I noticed it only worked via novaterm, but not over ssh as well. Something is requiring that change be made from local console, is all. Any script would work fine (the /etc/PmWiFiDhclient-script hack is working for me).
    Last edited by knobbysideup; 09/07/2012 at 08:44 AM.
    : (){:|:&};:
  9. #129  
    I knew it was too good to be true if it really were that easy. Maybe if I get some time I'll browse through my device to see if there's something specifically controlling this that we can then modify/disable. I also wonder if maybe prior to 2.2.4, this was set to off and in an attempt to improve battery like, HP just switched it to on.
  10. #130  
    On every laptop I've ever owned, wifi 'power saving' never really had much effect, and ALWAYS caused horrible lag and generally unreliable wifi connections. The difference with a stock linux solution is that it is easy to fix that broken behavior, even with ubuntu and NetworkManager.

    Tweaking other parameters helps a lot in certain situations as well. Like when you are on the wireless in the hotel at DefCon :-)

    I wouldn't recommend stock pre firewall settings in that environment. Especially if you have things like the openssh package installed, but I digress.
    : (){:|:&};:
  11. #131  
    Well at least you guys are making some headway in the issue. Perhaps one day we'll have a patch for 'normal' wifi performance!
    HP Pre 3 (UK)
  12. #132  
    Quote Originally Posted by checkmate View Post
    Well at least you guys are making some headway in the issue. Perhaps one day we'll have a patch for 'normal' wifi performance!
    Yeah, so far my searches have come up dry. Most of the start-up config scripts don't have anything in it related to power-save. I am still looking though.
  13. #133  
    I've changed my email settings to poll every 5 minutes rather than use imap idle. I'm at least getting mail reliably overnight now. The constant tear-down and re-establishment of the imap session acts as a keepalive, it seems. Not directly related to continuous performance, but it solved one of my irritations, at least.

    It looks like WebOS 2.x will shut down all networking as often as it can. ********.
    : (){:|:&};:
  14. #134  
    Here's some files that may be worth looking at:

    /usr/bin/PmWiFiService
    /var/preferences/com.palm.wifi/prefsDB.sl
    /var/preferences/com.palm.wan/prefsDB.sl

    Maybe somebody with more experience can determine if these might be useful to find the issue of the power saving mode state overwriting.
  15. #135  
    Quote Originally Posted by 9edgedown View Post
    This is just an attempt to summarise some testing I did on this issue, with a view to wrapping up my observations.
    this has been a while and needs an update, I think.

    this is a really interesting thread, but Iīm somewhat eben more confused than I was before. the problems discussed concern WiFi, and from what I see there are two problems mangled together: (1) intermittent disconnections without the Pre3 noticing it, and (2) problems with the reception rate.

    Iīm only interested in the first one, since I really would love to have the luxury problem of a bad reception, īcause my WiFi-experience is as follows: WiFi on, 1 minute connection, connection stuck. disable / re-enable WiFi, 1 minute reception, connection stuck. I can even sit next to the router, same game. Iīve tried the patch to no avail. Now in this thread there are least 50 tips and hints of what and what not to do, but Iīm lost. Iīve read at least these tips:

    Quote Originally Posted by knobbysideup View Post
    I've changed my email settings to poll every 5 minutes rather than use imap idle. (...) The constant tear-down and re-establishment of the imap session acts as a keepalive, it seems.
    OK, this is easy and canīt break anything except battery performance.

    here are some more tips, likely more in-depth:
    Quote Originally Posted by knobbysideup View Post
    I used iwconfig to turn off power saving. (...) Likely fixes performance elsewhere too. Can add an upstart script to make the setting stick, or find out if /etc/network stuff is used. (...) So, the cheap hack is to just add what I want to do to /etc/PmWiFiDhclient-script.
    Quote Originally Posted by SkyRider View Post
    Now ich deleted the PMWiFiDhcpclient.conf (1.09kb) and replaced it with the PMWiFiDhcpclient.conf_orig.webosinternals (1.10kb)
    Quote Originally Posted by SkyRider View Post
    To get a fast and stable WifI Connection I installed the Unthrottle Download Manager, after doing this , all works perfect.
    ... not to mention: (1) using channel 11 [or 13, younameit], (2) disabling this or that in your router, (3) use only b- or n-WiFi, and whatever.

    the only problem: what should I do? everything? something? anything? the only solutions I think wonīt work are those concerning something in the router, īcause at least my problems donīt have any connection with the routers I use, they just show up everywhere.

    So, Iīd really like somebody to hint me to a solution that solves my problem. From what I see, the Pre3 somewhat chokes and forgets to keep the bWiFi connection open without knowing itīs closed - thatīs why I see 5 bars and the SSID of my network, but donīt get a da*n bit though the net - the Pre3 doesnīt say "in order to see this page you need to have an internet connection", no, it says "page not available".

    Until now the only solution is to disable an re-enable WiFi, which helps for 5 minutes, literally.



    (after I have a reliable connection, I might consider compalining about how many bars show up.)
  16. #136  
    Disabling powersave helps. Problem is, HP/Palm overwrites the setting when the device goes to sleep. I can't find what causes this anywhere, so this lends some truth to a configured binary that we can't edit. So my thought:

    Did older devices have powersave set to on? If so, is it possible to replace the troublesome files (once identified) with the older files? This would probably be easier than cracking a binary.

    Although the webpage error annoys the hell out of me, what's more annoying to me is I have Linphone set to launch when I connect to my router. Not only does it cycle frequently, it sometimes does so in the middle of a call! So far nothing has helped me (save for disabling powersave while the setting stuck).
  17. #137  
    Since I never used a Pre 3 with anything other than 2.2.4, I don't now about how things changed after the update. But I have seemed to have had more issues with my Pre 3 than with my Pre 2. As I noted earlier, I set my phone to cdma mode (Verizon). I've also changed the power setting as previously discussed. Both steps had some slight benefit. I also found that setting my router channel setting to Auto has helped the reliability at home.

    I'm still not quite satisfied so now I'm curious if anyone has implemented the "net.ipv4.tcp_window_scaling_option=0" that was discussed in this thread?
    http://forums.webosnation.com/hp-tou...ngme-wild.html

    The appropriate file seems to to be /etc/pmnetconfig/netsysctrl.conf rather than /etc/sysctrl.conf which does not seem to exist on the Pre 3.
  18. #138  
    That file doesn't exist period, unless one has installed the System Optimization Patch or created it themselves. I myself may try this tonight, though I'll probably edit it at the source rather than add it to my syctl conf file.
  19. #139  
    Quote Originally Posted by bassman97 View Post
    That file doesn't exist period, unless one has installed the System Optimization Patch or created it themselves. I myself may try this tonight, though I'll probably edit it at the source rather than add it to my syctl conf file.
    The System Optimization Patch won't install for me. I just manually added the line to /etc/pmnetconfig/netsysctrl.conf - can't really say for sure whether it's had an effect.
  20. #140  
    It might be easier to see if you set Mode Switcher to launch an app when connected to WiFi. I have it set to launch Linphone and it cycles on/off quite frequently (sometimes during a call). That has been my test, at least so far...
Page 7 of 8 FirstFirst ... 2345678 LastLast

Posting Permissions