webOS Nation Forums >  webOS Devices >  HP Pre 3 > Boxalicious app
Boxalicious app
  Reply
 
Thread Tools Display Modes
Old 12/16/2011, 01:50 PM   #1 (permalink)
Member
 
Posts: 205
Can someone try and get the bocalicious app working for the pre3? its basicalli stuck when trying to sign in.
jetz is offline   Reply With Quote
Old 12/16/2011, 04:51 PM   #2 (permalink)
Moderator
 
OldSkoolVWLover's Avatar
 
Posts: 7,732
lots of reviews saying not working on Pre3... I didn't even know about this app. downloading and will test now.
__________________
I love physical keyboards... but there is two devices that would make me consider a slab, one is something running a full version of Open webOS. The other is an iPhone!!!! HA HA just kidding (about the iPhone that is)...
OldSkoolVWLover is offline   Reply With Quote
Old 12/16/2011, 04:54 PM   #3 (permalink)
Moderator
 
OldSkoolVWLover's Avatar
 
Posts: 7,732
I'm not even getting an option to sign in...
__________________
I love physical keyboards... but there is two devices that would make me consider a slab, one is something running a full version of Open webOS. The other is an iPhone!!!! HA HA just kidding (about the iPhone that is)...
OldSkoolVWLover is offline   Reply With Quote
Old 12/16/2011, 05:03 PM   #4 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,681
didnt work for me, so using Dropboxify, works np on my pre3.
geekpeter is offline   Reply With Quote
Old 12/19/2011, 04:42 AM   #5 (permalink)
Member
 
Posts: 205
Quote:
Originally Posted by OldSkoolVWLover View Post
I'm not even getting an option to sign in...
yh, that's the same problem, I've tried to mess around with the code to see if it made any difference, but I'm a noob with 0 experience and I (predictably) failed
jetz is offline   Reply With Quote
Old 01/28/2012, 02:15 PM   #6 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
Hi Boxalicious developers,

if you do not fix your app for the Pre3 we do it ourself ;-)
The attached ZIP contains two patch files. One for the free version and one for the paid version. The problem is that the WebView container will not load the login page if it is triggered from ARES, even if the code passes the right URL. I replaced it with a mojo object and it loads again.

I was to lazy to re implement the "please wait" message. As a result you will get a blank page for 20-30 seconds until the box.net login page is loaded. Should not be a problem as you do it only one time to allow the app the access to box.net.

HaPe
Attached Files
File Type: zip Boxalicious WebOS2.2.4.zip (2.2 KB, 169 views) Email Attachment
hape is offline   Reply With Quote
Old 01/28/2012, 03:10 PM   #7 (permalink)
Member
 
trott3r's Avatar
 
Posts: 110
Thanks HaPe but how do you apply the patch?

I havent done any patching on the Pre3 as yet
Martin
__________________
Running WebOS v2.24 on HPalm Pre3
trott3r is offline   Reply With Quote
Old 01/28/2012, 03:19 PM   #8 (permalink)
Member
 
Posts: 285
@haPe thanks for the patch, works great
@trott3r use WebOSQI
__________________
Jim Altman
Palm III ->Treos 600->650->750->Pro->Pre Plus->Pre 2->Pre3+TouchPad
jaltman is offline   Reply With Quote
Old 01/28/2012, 03:26 PM   #9 (permalink)
Member
 
trott3r's Avatar
 
Posts: 110
Quote:
Originally Posted by jaltman View Post
@haPe thanks for the patch, works great
@trott3r use WebOSQI
Ok i have WebOSQI up but i dont see anything about patches in its menus
(found it with the big + sign)

Added the patch and there is an immediate reset to the flashing HP logo.

Is that normal ?
Most apps ask for a reset

The phone is in dev mode

On loading the box.net app it sits on the login screen as before.
__________________
Running WebOS v2.24 on HPalm Pre3

Last edited by trott3r; 01/28/2012 at 03:47 PM.
trott3r is offline   Reply With Quote
Old 01/28/2012, 03:49 PM   #10 (permalink)
Member
 
netwrkr9's Avatar
 
Posts: 3,197
Quote:
Originally Posted by trott3r View Post
Ok i have WebOSQI up but i dont see anything about patches in its menus
(found it with the big + sign)

Added the patch and there is an immediate reset to the flashing HP logo.

Is that normal ?
Most apps ask for a reset

The phone is in dev mode

On loading the box.net app it sits on the login screen as before.
You have to email the app to your computer and download it, then unzip the file and then open webOSQI and drag and drop it into webOSQI and hit the install button.
netwrkr9 is offline   Reply With Quote
Thanked By: kseaston
Old 01/28/2012, 03:53 PM   #11 (permalink)
Member
 
Balooz's Avatar
 
Posts: 270
Ah, ha! Thankeysomuch!
Balooz is offline   Reply With Quote
Old 01/28/2012, 03:55 PM   #12 (permalink)
Member
 
trott3r's Avatar
 
Posts: 110
error occured while attempting to run /tmp/scriptFile.sh
/media/cryptos/apps/usr/lib/ipkg/infoca.canucksoftware.patches.boxaliciousfreewebos224-1.postinst:line1 :cant open !DOCTYPE no such file

same dir: html not found
same dir:line2 syntax error :unexpected newline

no reset this time
__________________
Running WebOS v2.24 on HPalm Pre3
trott3r is offline   Reply With Quote
Old 01/29/2012, 03:08 AM   #13 (permalink)
Member
 
Posts: 205
thanks so much for the patch, although the app is pretty poor, and audio does not play. Using app tuckerbox I had managed to get a better app called box.net for webos. I recommend you try it out too.
jetz is offline   Reply With Quote
Thanked By: Yellowhammer
Old 01/29/2012, 05:08 AM   #14 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
Quote:
Originally Posted by jetz View Post
thanks so much for the patch, although the app is pretty poor, and audio does not play. Using app tuckerbox I had managed to get a better app called box.net for webos. I recommend you try it out too.
Which on do you mean:
https://developer.palm.com/appredire...apps.boxclient <= This one only available in the US
https://developer.palm.com/appredire...=com.box.webos <= that is the Touchpad client. Ican install it via Preware/Tuckerbox, but it dose not work for me on the Pre3.

HaPe
hape is offline   Reply With Quote
Old 01/29/2012, 06:38 AM   #15 (permalink)
Member
 
xanuk's Avatar
 
Posts: 61
Quote:
Originally Posted by HaPe View Post
Hi Boxalicious developers,

if you do not fix your app for the Pre3 we do it ourself ;-)
The attached ZIP contains two patch files. One for the free version and one for the paid version. The problem is that the WebView container will not load the login page if it is triggered from ARES, even if the code passes the right URL. I replaced it with a mojo object and it loads again.

I was to lazy to re implement the "please wait" message. As a result you will get a blank page for 20-30 seconds until the box.net login page is loaded. Should not be a problem as you do it only one time to allow the app the access to box.net.

HaPe
Thank you very much, works for the free version, but not for the extra one, tested everything, internalz, webosquickinstall, deinstall, patch ... Strange.

-- Sent from my Palm Pre3 using Forums
xanuk is offline   Reply With Quote
Old 01/29/2012, 10:55 AM   #16 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
Quote:
Originally Posted by xanuk View Post
Thank you very much, works for the free version, but not for the extra one, tested everything, internalz, webosquickinstall, deinstall, patch ... Strange.

-- Sent from my Palm Pre3 using Forums
Do others also had problems with the patches. I un installed both app versions on my device, re insatalled them from the app catalog, applied the patches with internals-pro and was able to login.

HaPe
hape is offline   Reply With Quote
Old 01/29/2012, 12:19 PM   #17 (permalink)
Member
 
Posts: 205
I meant US catalogue one, Enyo one doesn't work, sorry for the confusion as I am in uk and so only saw the pre version through tuckerbox
jetz is offline   Reply With Quote
Old 01/30/2012, 05:11 AM   #18 (permalink)
Member
 
xanuk's Avatar
 
Posts: 61
Quote:
Originally Posted by HaPe View Post
Do others also had problems with the patches. I un installed both app versions on my device, re insatalled them from the app catalog, applied the patches with internals-pro and was able to login.

HaPe
I solved the issue by copy and paste the patched lines of the loginassistant from the normal file to the xtra file, they seem to be the same. Now it works for me, maybe there is a writing error in the xtra patch ;-)

Xanuk

-- Sent from my Palm Pre3 using Forums
xanuk is offline   Reply With Quote
Old 03/23/2012, 02:56 PM   #19 (permalink)
Member
 
Posts: 1
Thanks a lot HaPe for providing this patch. Access to box.net was one piece missing for me on the Pre3.

Now it's so much better than before!
Laire is offline   Reply With Quote
Old 07/06/2012, 07:23 AM   #20 (permalink)
Member
 
Posts: 109
got an error installing the patch using quick install on my pre3 2.2.4, what did i missed?
Attached Images
File Type: png Untitled.png (57.0 KB, 33 views) Email Attachment
daniela is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0