webOS Nation Forums

webOS Nation Forums (/)
-   HP Pre 3 (http://forums.webosnation.com/hp-pre-3/)
-   -   Boxalicious app (http://forums.webosnation.com/hp-pre-3/308814-boxalicious-app.html)

jetz 12/16/2011 01:50 PM

Boxalicious app
 
Can someone try and get the bocalicious app working for the pre3? its basicalli stuck when trying to sign in.

OldSkoolVWLover 12/16/2011 04:51 PM

lots of reviews saying not working on Pre3... I didn't even know about this app. downloading and will test now.

OldSkoolVWLover 12/16/2011 04:54 PM

I'm not even getting an option to sign in...

geekpeter 12/16/2011 05:03 PM

didnt work for me, so using Dropboxify, works np on my pre3.

jetz 12/19/2011 04:42 AM

[QUOTE=OldSkoolVWLover;3266634]I'm not even getting an option to sign in...[/QUOTE]

yh, that's the same problem, I've tried to mess around with the code to see if it made any difference, but I'm a noob with 0 experience and I (predictably) failed

hape 01/28/2012 02:15 PM

1 Attachment(s)
Hi Boxalicious developers,

if you do not fix your app for the Pre3 we do it ourself ;-)
The attached ZIP contains two patch files. One for the free version and one for the paid version. The problem is that the WebView container will not load the login page if it is triggered from ARES, even if the code passes the right URL. I replaced it with a mojo object and it loads again.

I was to lazy to re implement the "please wait" message. As a result you will get a blank page for 20-30 seconds until the box.net login page is loaded. Should not be a problem as you do it only one time to allow the app the access to box.net.

HaPe

trott3r 01/28/2012 03:10 PM

Thanks HaPe but how do you apply the patch?

I havent done any patching on the Pre3 as yet
Martin

jaltman 01/28/2012 03:19 PM

@haPe thanks for the patch, works great
@trott3r use WebOSQI

trott3r 01/28/2012 03:26 PM

[QUOTE=jaltman;3290681]@haPe thanks for the patch, works great
@trott3r use WebOSQI[/QUOTE]
Ok i have WebOSQI up but i dont see anything about patches in its menus
(found it with the big + sign)

Added the patch and there is an immediate reset to the flashing HP logo.

Is that normal ?
Most apps ask for a reset

The phone is in dev mode

On loading the box.net app it sits on the login screen as before. :(

netwrkr9 01/28/2012 03:49 PM

[QUOTE=trott3r;3290684]Ok i have WebOSQI up but i dont see anything about patches in its menus
(found it with the big + sign)

Added the patch and there is an immediate reset to the flashing HP logo.

Is that normal ?
Most apps ask for a reset

The phone is in dev mode

On loading the box.net app it sits on the login screen as before. :([/QUOTE]

You have to email the app to your computer and download it, then unzip the file and then open webOSQI and drag and drop it into webOSQI and hit the install button.

Balooz 01/28/2012 03:53 PM

Ah, ha! Thankeysomuch!

trott3r 01/28/2012 03:55 PM

error occured while attempting to run /tmp/scriptFile.sh
/media/cryptos/apps/usr/lib/ipkg/infoca.canucksoftware.patches.boxaliciousfreewebos224-1.postinst:line1 :cant open !DOCTYPE no such file

same dir: html not found
same dir:line2 syntax error :unexpected newline

no reset this time :(

jetz 01/29/2012 03:08 AM

thanks so much for the patch, although the app is pretty poor, and audio does not play. Using app tuckerbox I had managed to get a better app called box.net for webos. I recommend you try it out too.

hape 01/29/2012 05:08 AM

[QUOTE=jetz;3290871]thanks so much for the patch, although the app is pretty poor, and audio does not play. Using app tuckerbox I had managed to get a better app called box.net for webos. I recommend you try it out too.[/QUOTE]

Which on do you mean:
[url]https://developer.palm.com/appredirect/?packageid=com.abesapps.boxclient[/url] <= This one only available in the US
[url]https://developer.palm.com/appredirect/?packageid=com.box.webos[/url] <= that is the Touchpad client. Ican install it via Preware/Tuckerbox, but it dose not work for me on the Pre3.

HaPe

xanuk 01/29/2012 06:38 AM

[QUOTE=HaPe;3290653]Hi Boxalicious developers,

if you do not fix your app for the Pre3 we do it ourself ;-)
The attached ZIP contains two patch files. One for the free version and one for the paid version. The problem is that the WebView container will not load the login page if it is triggered from ARES, even if the code passes the right URL. I replaced it with a mojo object and it loads again.

I was to lazy to re implement the "please wait" message. As a result you will get a blank page for 20-30 seconds until the box.net login page is loaded. Should not be a problem as you do it only one time to allow the app the access to box.net.

HaPe[/QUOTE]

Thank you very much, works for the free version, but not for the extra one, tested everything, internalz, webosquickinstall, deinstall, patch ... Strange.

[i]-- Sent from my Palm Pre3 using [url=http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums]Forums[/url][/i]

hape 01/29/2012 10:55 AM

[QUOTE=xanuk;3290906]Thank you very much, works for the free version, but not for the extra one, tested everything, internalz, webosquickinstall, deinstall, patch ... Strange.

[i]-- Sent from my Palm Pre3 using [url=http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums]Forums[/url][/i][/QUOTE]

Do others also had problems with the patches. I un installed both app versions on my device, re insatalled them from the app catalog, applied the patches with internals-pro and was able to login.

HaPe

jetz 01/29/2012 12:19 PM

I meant US catalogue one, Enyo one doesn't work, sorry for the confusion as I am in uk and so only saw the pre version through tuckerbox

xanuk 01/30/2012 05:11 AM

[QUOTE=HaPe;3290994]Do others also had problems with the patches. I un installed both app versions on my device, re insatalled them from the app catalog, applied the patches with internals-pro and was able to login.

HaPe[/QUOTE]

I solved the issue by copy and paste the patched lines of the loginassistant from the normal file to the xtra file, they seem to be the same. Now it works for me, maybe there is a writing error in the xtra patch ;-)

Xanuk

[i]-- Sent from my Palm Pre3 using [url=http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums]Forums[/url][/i]

Laire 03/23/2012 02:56 PM

Thanks a lot HaPe for providing this patch. Access to box.net was one piece missing for me on the Pre3.

Now it's so much better than before!

daniela 07/06/2012 07:23 AM

1 Attachment(s)
got an error installing the patch using quick install on my pre3 2.2.4, what did i missed? :confused:


All times are GMT -5. The time now is 06:59 AM.



Content Relevant URLs by vBSEO 3.6.0