Page 1 of 2 12 LastLast
Results 1 to 20 of 24
  1.    #1  
    Hello,

    I have a AT&T Palm Pre 3 and absolutely love it. The only problem I have, and it is making it hard to use this as my primary business phone, is that almost EVERY inbound call I get comes up as UNKNOWN NUMBER.

    Is there a fix of any kind? At this point I am willing to try anything!

    If someone could help me it would sincerely be appreciated. Thanks in Advance...
  2. #2  
    has something to do with +1 in the number and it's a known problem. hopefully being fixed in 2.2.4
  3.    #3  
    is there 2.2.4 coming?
  4. #4  
    wow there is a 2.2.4 coming ?? really ? what makes you think that ?
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  5. errsta's Avatar
    Posts
    50 Posts
    Global Posts
    55 Global Posts
    #5  
    Quote Originally Posted by kill_Dano View Post
    has something to do with +1 in the number and it's a known problem. hopefully being fixed in 2.2.4
    2.2.4??

    Is that happening?
  6.    #6  
    Really no one has a solution? I even re-doctored my phone to no avail...every inbound call is a Unknown Number...

    ...with all of the talented people like Rod on this site I was hoping someone had cooked something up...maybe I am the only one that has this issue in this way?!?!?!
  7. #7  
    I doubt this is "patchable" and it's likely completely closed source so that users can't tinker with the baseband interface.

    You'd need to hijack whatever IPC is being used to pass the notifications to dialerUI, adjust the number and send it -- or write a new dialer that can invoke itself instead of the phone UI.
  8. #8  
    I have the same issue on an ROW Pre 3 with Australian numbers (+61). I believe it affects all Pre 3s, not just AT&T models, not just in the US (+1) either.
  9. #9  
    Quote Originally Posted by B-E-A-S-T View Post
    Really no one has a solution? I even re-doctored my phone to no avail...every inbound call is a Unknown Number...

    ...with all of the talented people like Rod on this site I was hoping someone had cooked something up...maybe I am the only one that has this issue in this way?!?!?!
    I guess you have already tried this, but changing Phone numbers from UK to Other in Regional Settings solved my problem with incoming calls. I still have one annoying problem remaining with phone calls though: When I want to call back to a number in the call log without the country prefix (in my case +46), I get the error "Unable to connect, not logged in" even though the number is recognized as a contact. If I punch in that same number w/o +46 in Just Type..., the call goes through without problems.
  10. #10  
    I had the same problem (when dialing a number without a country code, the message: "Unable to connect, not logged in" was received).

    The solution is to go to Network Services (accessible from the menu of the Phone app.) and select Network/Service Provider for International Calls instead of Skype (if Skype is selected for International Calls and you are not logged-in to Skype then the above error message is received).
    Last edited by kbywal; 11/27/2011 at 01:11 PM.
  11. #11  
    Quote Originally Posted by kbywal View Post
    I had the same problem (when dialing a number without a country code prefix a message: "Unable to connect, not logged in" was received).

    The solution is to go to Network Services (accessible from the menu of the Phone app.) and select Network/Service Provider for International Calls instead of Skype (if Skype is selected for International Calls and you are not logged-in to Skype then the above error message is received).
    I was beginning to suspect this was the culprit, thanks for confirming. Seems to work now.
  12. #12  
    Quote Originally Posted by tomoqv View Post
    I guess you have already tried this, but changing Phone numbers from UK to Other in Regional Settings solved my problem with incoming calls. I still have one annoying problem remaining with phone calls though: When I want to call back to a number in the call log without the country prefix (in my case +46), I get the error "Unable to connect, not logged in" even though the number is recognized as a contact. If I punch in that same number w/o +46 in Just Type..., the call goes through without problems.
    I've just tried this and it didn't work for me
  13. #13  
    OK, I think this has something to do with the format of numbers and the AT&T version.

    When you set your regional preferences, you'll see that your phone number format is (02) 1234 5678

    It worked just fine with land lines.

    I then tried a mobile. NO matter if I set it to Australia or Other, it still didn't work, until I dropped the +61 from the contact. Then it worked just fine.

    Now, it used to work before the 2.2.4 upgrade, but then I had the AU dial patch.

    My partners phone, which is a UK Pre3, needs the +61 infront of the mobile number, or it wont work. (Set to Australia, Australia)

    Go figure!
    Siobhn

    Palm III, Treo 600/650/680/750, Pre, Pre3, AT&T Pre3, tp 4G, tp 64GB.

    I am an HP Employee. I am not associated in anyway with the development of webOS or associated devices. Opinions expressed in this post are my own and do not in any way represent HP or Palm in any official manner. Any implications derived from my posts are the result of my own point of view and do not indicate any intention or evidence of past, present or future activity or plans of the aforementioned HP or Palm.
  14. #14  
    Quote Originally Posted by siobhanellis View Post
    OK, I think this has something to do with the format of numbers and the AT&T version.

    When you set your regional preferences, you'll see that your phone number format is (02) 1234 5678

    It worked just fine with land lines.

    I then tried a mobile. NO matter if I set it to Australia or Other, it still didn't work, until I dropped the +61 from the contact. Then it worked just fine.

    Now, it used to work before the 2.2.4 upgrade, but then I had the AU dial patch.

    My partners phone, which is a UK Pre3, needs the +61 infront of the mobile number, or it wont work. (Set to Australia, Australia)

    Go figure!
    You're correct on both counts (ATT 2.2.4 and UK Pre3). I have done the same tests. Now we need to hope that it is a) patchable and b) sufficiently annoying to people like Rod and Johncc that we mortal users have a solution to this serious issue.
    Cheers
  15. #15  
    I've the same issue on my French Pre3 updated with the 2.2.4 version. Actually I live in Canada, but in France, I have no problem to see phone numbers, even with my canadian provider : Fido. In Canada, almost always, I have "Unknown number" for incoming call. Of course I have the option activated on my cell plan.
    I thought a problem of international phone number, so I removed the +1, or added both numbers with and without for my contacts ; no improvement.
    I've a skype account set on it, then just after I read you I decided to remove it, and that still doesn't work anymore.
    I forced my provider for dom calls and international calls, it's the same.
    It's a very annoying bug. What I didn't do ?
  16. #16  
    Quote Originally Posted by Noyah View Post
    I've the same issue on my French Pre3 updated with the 2.2.4 version. Actually I live in Canada, but in France, I have no problem to see phone numbers, even with my canadian provider : Fido. In Canada, almost always, I have "Unknown number" for incoming call. Of course I have the option activated on my cell plan.
    I thought a problem of international phone number, so I removed the +1, or added both numbers with and without for my contacts ; no improvement.
    I've a skype account set on it, then just after I read you I decided to remove it, and that still doesn't work anymore.
    I forced my provider for dom calls and international calls, it's the same.
    It's a very annoying bug. What I didn't do ?
    Did you check Formats and Phone Numbers in Regional Settings?
  17. #17  
    Quote Originally Posted by GuyFromNam View Post
    Did you check Formats and Phone Numbers in Regional Settings?
    I was set up in "US, Canada; Caribbean (+1)", and now I just switch to Other. I'll see today, if it's better.
  18. #18  
    Quote Originally Posted by B-E-A-S-T View Post
    Really no one has a solution? I even re-doctored my phone to no avail...every inbound call is a Unknown Number...

    ...with all of the talented people like Rod on this site I was hoping someone had cooked something up...maybe I am the only one that has this issue in this way?!?!?!
    I have the same issue.......very annoying. Caller ID for some people show up but most show as UNKNOWN CALLER (even if they are in my contacts). I need help too.
  19. #19  
    Quote Originally Posted by Noyah View Post
    I was set up in "US, Canada; Caribbean (+1)", and now I just switch to Other. I'll see today, if it's better.
    Did it work when you switched to "other" or are you still getting "unknown caller?"
  20. LevSer's Avatar
    Posts
    51 Posts
    Global Posts
    80 Global Posts
    #20  
    The problems I've encounter with numbers concern both the phone and messaging applications. Most of the problems have been brought up in this thread so I'll share my solutions to all.

    1. Unable to connect
    PROBLEM: Phone > Network Services > International Calls = Skype
    FIX: Phone > Network Services > International Calls = Your service provider

    2. Strange "+0" added to any number missing a country code (affects both phone and text messages, regardless if its a contact or new number)
    PROBLEM: Phone > Network Services > International Calls = ON
    FIX: Phone > Network Services > International Calls = OFF



    The following problems (3-4) are based on the Swedish (+46) number "0701234567"

    3. Unknown caller
    PROBLEM: Incorrect phone number format. In my case my google contacts numbers looked something like "+4670-123-4567"

    4. SMS text msgs are not received by receiver
    PROBLEM: Incorrect phone number format. In my case my google contacts numbers looked something like "+46070-123-4567" (I was trying to fix the above issue)

    3&4 FIX: Make sure your numbers do not have ANY unecessary signs or spaces. The right way is something like "+46 701234567" (one space, first zero removed, no dashes)

    If the contacts number is saved as (first zero removed) "+46 701234567" the Caller ID will work, but not if it's saved as "+4670-123-4567".

    If the contacts number is saved as (no zero removed) "+46070-123-4567" or "+460701234567" Calls can be made and the Caller ID will work, but the text msgs will not be sent properly.

    The phone can connect a call from "0701234567" to contact "+46 0701234567" or "+46 701234567", but as soon as you start adding any additional spaces/dashes (even if it is the 'proper' formatting) you start to get problems.
Page 1 of 2 12 LastLast

Posting Permissions