Results 1 to 4 of 4
  1.    #1  
    I'm currently in Japan using an unlocked AT&T Pre3. The Pre3 selected Softbank as the roaming network by itself. My carrier has a far better deal when I roam using NTT DoCoMo.

    Is there any way to change the network? I tried everything but still couldn't find anything.
  2. #2  
    I had some issues trying to register to two/three of the available roaming networks in Chile. I manually selected each of it, but all the time I had registration problem message. After few tries, I decided to restart, and was able to force the selection. I had the same problem with my Pre2 also.
  3.    #3  
    Please excuse my ignorance, but could you please show me how to manually select a network?
  4. #4  
    While on phone app, select upper left menu, go to Preferences
    There you will find Network section, and turn off Network auto-select, it will show the available networks, just click the on you need.

Posting Permissions